summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2006-11-22 01:36:15 +0000
committerJon Hood <squinky86@gentoo.org>2006-11-22 01:36:15 +0000
commit4731f56411e90a823c31d4bc55afc570f47f972c (patch)
tree84dbebd5420a3a2b191ca67716a6dcd46fe33424 /net-analyzer
parentRework to support multiple languages; resolve long-standing default language ... (diff)
downloadgentoo-2-4731f56411e90a823c31d4bc55afc570f47f972c.tar.gz
gentoo-2-4731f56411e90a823c31d4bc55afc570f47f972c.tar.bz2
gentoo-2-4731f56411e90a823c31d4bc55afc570f47f972c.zip
Version bump and stabilizing of previous version. Mark myself as maintainer as per the netmon herd's request last month.
(Portage version: 2.1.2_rc2-r1)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/httping/ChangeLog9
-rw-r--r--net-analyzer/httping/files/digest-httping-1.2.23
-rw-r--r--net-analyzer/httping/httping-1.2.1.ebuild4
-rw-r--r--net-analyzer/httping/httping-1.2.2.ebuild33
-rw-r--r--net-analyzer/httping/metadata.xml4
5 files changed, 50 insertions, 3 deletions
diff --git a/net-analyzer/httping/ChangeLog b/net-analyzer/httping/ChangeLog
index 294b4f35aff7..43da950bb8f0 100644
--- a/net-analyzer/httping/ChangeLog
+++ b/net-analyzer/httping/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/httping
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/ChangeLog,v 1.27 2006/10/21 15:42:15 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/ChangeLog,v 1.28 2006/11/22 01:36:15 squinky86 Exp $
+
+*httping-1.2.2 (22 Nov 2006)
+
+ 22 Nov 2006; Jon Hood <squinky86@gentoo.org> metadata.xml,
+ httping-1.2.1.ebuild, +httping-1.2.2.ebuild:
+ Version bump, mark 1.2.1 stable on amd64. Mark myself as maintainer as per
+ the netmon herd's request last month.
*httping-1.2.1 (21 Oct 2006)
diff --git a/net-analyzer/httping/files/digest-httping-1.2.2 b/net-analyzer/httping/files/digest-httping-1.2.2
new file mode 100644
index 000000000000..3c828e6e797e
--- /dev/null
+++ b/net-analyzer/httping/files/digest-httping-1.2.2
@@ -0,0 +1,3 @@
+MD5 cde335c0110fb1b156afdf80ff5ade1d httping-1.2.2.tgz 13026
+RMD160 d0a24fcd882bccc9f74be7c6200216f10f09117f httping-1.2.2.tgz 13026
+SHA256 8bedbf9ff95cea483b9d71e0eff8398673d83eafbdac47cb605ad5399e25faea httping-1.2.2.tgz 13026
diff --git a/net-analyzer/httping/httping-1.2.1.ebuild b/net-analyzer/httping/httping-1.2.1.ebuild
index 3f44d32372f4..9dc2493495e4 100644
--- a/net-analyzer/httping/httping-1.2.1.ebuild
+++ b/net-analyzer/httping/httping-1.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/httping-1.2.1.ebuild,v 1.1 2006/10/21 15:42:15 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/httping-1.2.1.ebuild,v 1.2 2006/11/22 01:36:15 squinky86 Exp $
inherit toolchain-funcs
@@ -10,7 +10,7 @@ SRC_URI="http://www.vanheusden.com/${PN}/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~x86"
+KEYWORDS="amd64 ~hppa ~mips ~ppc ~ppc64 ~x86"
IUSE="ssl"
DEPEND=">=sys-libs/ncurses-5"
diff --git a/net-analyzer/httping/httping-1.2.2.ebuild b/net-analyzer/httping/httping-1.2.2.ebuild
new file mode 100644
index 000000000000..438af0d3fc22
--- /dev/null
+++ b/net-analyzer/httping/httping-1.2.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/httping-1.2.2.ebuild,v 1.1 2006/11/22 01:36:15 squinky86 Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="http protocol ping-like program"
+HOMEPAGE="http://www.vanheusden.com/httping/"
+SRC_URI="http://www.vanheusden.com/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~x86"
+IUSE="ssl"
+
+DEPEND=">=sys-libs/ncurses-5"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ local makefile
+ use ssl || makefile="-f Makefile.nossl"
+ export CC="$(tc-getCC)"
+ emake ${makefile} || die "make failed"
+}
+
+src_install() {
+ dobin httping || die
+ dodoc readme.txt
+}
diff --git a/net-analyzer/httping/metadata.xml b/net-analyzer/httping/metadata.xml
index 03aa50bab7e3..6b460e0cad10 100644
--- a/net-analyzer/httping/metadata.xml
+++ b/net-analyzer/httping/metadata.xml
@@ -2,4 +2,8 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>netmon</herd>
+<maintainer>
+ <email>squinky86@gentoo.org</email>
+ <name>Jon Hood</name>
+</maintainer>
</pkgmetadata>