summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-08-22 15:15:59 +0000
committerJeroen Roovers <jer@gentoo.org>2014-08-22 15:15:59 +0000
commit403d4795459860dce439a17229e213fa5eea63e3 (patch)
tree9b88fbb902cc21c6b17679046d4c85c80cd67622 /net-analyzer
parentbumped EAPI to 5; committed directly to stable as no other changes present an... (diff)
downloadgentoo-2-403d4795459860dce439a17229e213fa5eea63e3.tar.gz
gentoo-2-403d4795459860dce439a17229e213fa5eea63e3.tar.bz2
gentoo-2-403d4795459860dce439a17229e213fa5eea63e3.zip
Version bump. Add patch for loglevel expected to be an int (bug #520536 by Fabio Scaccabarozzi).
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/fail2ban/ChangeLog11
-rw-r--r--net-analyzer/fail2ban/fail2ban-0.8.14.ebuild79
-rw-r--r--net-analyzer/fail2ban/fail2ban-0.9.0-r2.ebuild (renamed from net-analyzer/fail2ban/fail2ban-0.9.0-r1.ebuild)5
-rw-r--r--net-analyzer/fail2ban/files/fail2ban-0.9.0-loglevel-int.patch11
4 files changed, 103 insertions, 3 deletions
diff --git a/net-analyzer/fail2ban/ChangeLog b/net-analyzer/fail2ban/ChangeLog
index 1f27df2d4ca9..73d1c4663609 100644
--- a/net-analyzer/fail2ban/ChangeLog
+++ b/net-analyzer/fail2ban/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-analyzer/fail2ban
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/ChangeLog,v 1.141 2014/07/12 13:59:47 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/ChangeLog,v 1.142 2014/08/22 15:15:59 jer Exp $
+
+*fail2ban-0.9.0-r2 (22 Aug 2014)
+*fail2ban-0.8.14 (22 Aug 2014)
+
+ 22 Aug 2014; Jeroen Roovers <jer@gentoo.org> +fail2ban-0.8.14.ebuild,
+ -fail2ban-0.9.0-r1.ebuild, +fail2ban-0.9.0-r2.ebuild,
+ +files/fail2ban-0.9.0-loglevel-int.patch:
+ Version bump. Add patch for loglevel expected to be an int (bug #520536 by
+ Fabio Scaccabarozzi).
12 Jul 2014; Jeroen Roovers <jer@gentoo.org> fail2ban-0.9.0-r1.ebuild:
Set USE=sqlite dependency on dev-lang/python (bug #507306).
diff --git a/net-analyzer/fail2ban/fail2ban-0.8.14.ebuild b/net-analyzer/fail2ban/fail2ban-0.8.14.ebuild
new file mode 100644
index 000000000000..0c9bb2dbc14d
--- /dev/null
+++ b/net-analyzer/fail2ban/fail2ban-0.8.14.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.8.14.ebuild,v 1.1 2014/08/22 15:15:59 jer Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_{6,7} )
+DISTUTILS_SINGLE_IMPL=yes
+
+inherit distutils-r1 systemd vcs-snapshot
+
+DESCRIPTION="scans log files and bans IPs that show malicious signs"
+HOMEPAGE="http://www.fail2ban.org/"
+SRC_URI="https://github.com/${PN}/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="selinux"
+
+DEPEND="selinux? ( sec-policy/selinux-fail2ban )"
+RDEPEND="net-misc/whois
+ virtual/mta
+ virtual/logger
+ net-firewall/iptables
+ selinux? ( sec-policy/selinux-fail2ban )"
+
+src_prepare() {
+ sed -i -e 's|/var\(/run/fail2ban\)|\1|g' $( find . -type f ) || die
+}
+
+src_test() {
+ ./${PN}-testcases-all
+}
+
+DOCS=( ChangeLog DEVELOP README.md THANKS TODO doc/run-rootless.txt )
+
+src_install() {
+ distutils-r1_src_install
+
+ rm -rf "${D}"/usr/share/doc/${PN}
+
+ # not FILESDIR
+ newconfd files/gentoo-confd ${PN}
+ newinitd files/gentoo-initd ${PN}
+ systemd_dounit files/${PN}.service
+ systemd_dotmpfilesd files/${PN}-tmpfiles.conf
+ doman man/*.{1,5}
+
+ # Use INSTALL_MASK if you do not want to touch /etc/logrotate.d.
+ # See http://thread.gmane.org/gmane.linux.gentoo.devel/35675
+ insinto /etc/logrotate.d
+ newins files/${PN}-logrotate ${PN}
+}
+
+pkg_preinst() {
+ has_version "<${CATEGORY}/${PN}-0.7"
+ previous_less_than_0_7=$?
+}
+
+pkg_postinst() {
+ if [[ $previous_less_than_0_7 = 0 ]] ; then
+ elog
+ elog "Configuration files are now in /etc/fail2ban/"
+ elog "You probably have to manually update your configuration"
+ elog "files before restarting Fail2ban!"
+ elog
+ elog "Fail2ban is not installed under /usr/lib anymore. The"
+ elog "new location is under /usr/share."
+ elog
+ elog "You are upgrading from version 0.6.x, please see:"
+ elog "http://www.fail2ban.org/wiki/index.php/HOWTO_Upgrade_from_0.6_to_0.8"
+ fi
+ if ! has_version ${CATEGORY}/${PN} && \
+ ! has_version dev-python/pyinotify && ! has_version app-admin/gamin; then
+ elog "For most jail.conf configurations, it is recommended you install either"
+ elog "dev-python/pyinotify or app-admin/gamin (in order of preference)"
+ elog "to control how log file modifications are detected"
+ fi
+}
diff --git a/net-analyzer/fail2ban/fail2ban-0.9.0-r1.ebuild b/net-analyzer/fail2ban/fail2ban-0.9.0-r2.ebuild
index efd604bf0251..67610e34aa7d 100644
--- a/net-analyzer/fail2ban/fail2ban-0.9.0-r1.ebuild
+++ b/net-analyzer/fail2ban/fail2ban-0.9.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.9.0-r1.ebuild,v 1.5 2014/07/12 13:59:47 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.9.0-r2.ebuild,v 1.1 2014/08/22 15:15:59 jer Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy pypy2_0 )
@@ -33,8 +33,9 @@ src_prepare() {
# Do not install /run/fail2ban
epatch "${FILESDIR}"/${P}-empty-run-dir.patch
- # Upstream patch
+ # Upstream patches
epatch "${FILESDIR}"/${P}-python3-regex.patch
+ epatch "${FILESDIR}"/${P}-loglevel-int.patch
distutils-r1_src_prepare
}
diff --git a/net-analyzer/fail2ban/files/fail2ban-0.9.0-loglevel-int.patch b/net-analyzer/fail2ban/files/fail2ban-0.9.0-loglevel-int.patch
new file mode 100644
index 000000000000..ce4f50606b44
--- /dev/null
+++ b/net-analyzer/fail2ban/files/fail2ban-0.9.0-loglevel-int.patch
@@ -0,0 +1,11 @@
+--- a/fail2ban/client/fail2banreader.py
++++ b/fail2ban/client/fail2banreader.py
+@@ -45,7 +45,7 @@
+ return ConfigReader.getOptions(self, "Definition", opts)
+
+ def getOptions(self):
+- opts = [["int", "loglevel", "INFO" ],
++ opts = [["string", "loglevel", "INFO" ],
+ ["string", "logtarget", "STDERR"],
+ ["string", "dbfile", "/var/lib/fail2ban/fail2ban.sqlite3"],
+ ["int", "dbpurgeage", 86400]]