summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2006-12-09 11:20:09 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2006-12-09 11:20:09 +0000
commit33fae9069100ef16578366cb3e44dd40ad104888 (patch)
tree082ad7c8e7453b3f7ff658c3668b10f26f0f72b9 /net-analyzer
parentAdd fix for gcc-4; thanks to P Nienaber for reporting; bug 127634 (diff)
downloadgentoo-2-33fae9069100ef16578366cb3e44dd40ad104888.tar.gz
gentoo-2-33fae9069100ef16578366cb3e44dd40ad104888.tar.bz2
gentoo-2-33fae9069100ef16578366cb3e44dd40ad104888.zip
Revision bump: Added Mike Auty patch to fix as-needed wrt bug #128675
(Portage version: 2.1.2_rc2-r4)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/ettercap/ChangeLog8
-rw-r--r--net-analyzer/ettercap/ettercap-0.7.3-r1.ebuild68
-rw-r--r--net-analyzer/ettercap/files/digest-ettercap-0.7.3-r13
-rw-r--r--net-analyzer/ettercap/files/ettercap-0.7.3-as-needed.patch14
4 files changed, 92 insertions, 1 deletions
diff --git a/net-analyzer/ettercap/ChangeLog b/net-analyzer/ettercap/ChangeLog
index 95cbd5d834f1..fac0512795a0 100644
--- a/net-analyzer/ettercap/ChangeLog
+++ b/net-analyzer/ettercap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/ettercap
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ettercap/ChangeLog,v 1.55 2006/10/25 08:37:12 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ettercap/ChangeLog,v 1.56 2006/12/09 11:20:09 drizzt Exp $
+
+*ettercap-0.7.3-r1 (09 Dec 2006)
+
+ 09 Dec 2006; Timothy Redaelli <drizzt@gentoo.org>
+ +files/ettercap-0.7.3-as-needed.patch, +ettercap-0.7.3-r1.ebuild:
+ Revision bump: Added Mike Auty patch to fix as-needed wrt bug #128675
25 Oct 2006; Timothy Redaelli <drizzt@gentoo.org> ettercap-0.7.3.ebuild:
Added ~x86-fbsd keyword.
diff --git a/net-analyzer/ettercap/ettercap-0.7.3-r1.ebuild b/net-analyzer/ettercap/ettercap-0.7.3-r1.ebuild
new file mode 100644
index 000000000000..aa69014080e6
--- /dev/null
+++ b/net-analyzer/ettercap/ettercap-0.7.3-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ettercap/ettercap-0.7.3-r1.ebuild,v 1.1 2006/12/09 11:20:09 drizzt Exp $
+
+# the actual version is "NG-0.7.0" but I suppose portage people will not be
+# happy with it (as for the 0.6.b version), so let's set it to "0.7.0".
+# since 'ettercap NG' has to be intended as an upgrade to 0.6.x series and not as
+# a new project or branch, this will be fine...
+
+WANT_AUTOMAKE="1.8"
+
+inherit flag-o-matic autotools
+
+MY_P="${PN}-NG-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A suite for man in the middle attacks and network mapping"
+HOMEPAGE="http://ettercap.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="ssl ncurses gtk debug"
+
+# libtool is needed because it provides libltdl (needed for plugins)
+RDEPEND=">=sys-devel/libtool-1.4.3
+ >=net-libs/libnet-1.1.2.1-r1
+ net-libs/libpcap
+ ncurses? ( sys-libs/ncurses )
+ ssl? ( dev-libs/openssl )
+ gtk? ( >=x11-libs/gtk+-2.2.2 )"
+
+DEPEND=">=sys-apps/sed-4.0.5
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+
+ eautomake
+}
+
+src_compile() {
+ strip-flags
+
+ local myconf
+
+ if use ssl; then
+ myconf="${myconf} --with-openssl=/usr"
+ else
+ myconf="${myconf} --without-openssl"
+ fi
+
+ econf ${myconf} \
+ $(use_enable gtk) \
+ $(use_enable debug) \
+ $(use_with ncurses) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+}
diff --git a/net-analyzer/ettercap/files/digest-ettercap-0.7.3-r1 b/net-analyzer/ettercap/files/digest-ettercap-0.7.3-r1
new file mode 100644
index 000000000000..658da46ad006
--- /dev/null
+++ b/net-analyzer/ettercap/files/digest-ettercap-0.7.3-r1
@@ -0,0 +1,3 @@
+MD5 28fb15cd024162c55249888fe1b97820 ettercap-NG-0.7.3.tar.gz 1138643
+RMD160 f4e6c0d87b2064b3775e9af60f34575273742616 ettercap-NG-0.7.3.tar.gz 1138643
+SHA256 c74239052d62565c13a82f9bbf217a4fdcce4b34949e361b53bb3f28e3168543 ettercap-NG-0.7.3.tar.gz 1138643
diff --git a/net-analyzer/ettercap/files/ettercap-0.7.3-as-needed.patch b/net-analyzer/ettercap/files/ettercap-0.7.3-as-needed.patch
new file mode 100644
index 000000000000..3a74210917c3
--- /dev/null
+++ b/net-analyzer/ettercap/files/ettercap-0.7.3-as-needed.patch
@@ -0,0 +1,14 @@
+diff -uNr ettercap-NG-0.7.3.orig/src/Makefile.am ettercap-NG-0.7.3/src/Makefile.am
+--- ettercap-NG-0.7.3.orig/src/Makefile.am 2006-04-03 19:33:36.000000000 +0100
++++ ettercap-NG-0.7.3/src/Makefile.am 2006-04-03 19:35:09.000000000 +0100
+@@ -140,7 +140,9 @@
+ ettercap_LDADD += interfaces/gtk/libec_gtk.a
+ endif
+
+-ettercap_LDFLAGS = -export-dynamic @EC_LIBS@
++ettercap_LDADD += @EC_LIBS@
++
++ettercap_LDFLAGS = -export-dynamic
+
+ CLEANFILES = *.log *.out core* missing/*.o *~
+