summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2006-01-16 17:02:28 +0000
committerLance Albertson <ramereth@gentoo.org>2006-01-16 17:02:28 +0000
commit1cff72c724fcd7c1aa954ac49dc9edec6c928a28 (patch)
tree57ab877d73c0f3350716c085d2386ea1b451142c /net-analyzer
parentold (diff)
downloadgentoo-2-1cff72c724fcd7c1aa954ac49dc9edec6c928a28.tar.gz
gentoo-2-1cff72c724fcd7c1aa954ac49dc9edec6c928a28.tar.bz2
gentoo-2-1cff72c724fcd7c1aa954ac49dc9edec6c928a28.zip
Version bump (new patched version)
(Portage version: 2.0.53)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/cacti/ChangeLog8
-rw-r--r--net-analyzer/cacti/Manifest2
-rw-r--r--net-analyzer/cacti/cacti-0.8.6h_p20060108.ebuild77
-rw-r--r--net-analyzer/cacti/files/digest-cacti-0.8.6h_p200601085
4 files changed, 91 insertions, 1 deletions
diff --git a/net-analyzer/cacti/ChangeLog b/net-analyzer/cacti/ChangeLog
index 63efeb2a276b..cbe6d68a4d10 100644
--- a/net-analyzer/cacti/ChangeLog
+++ b/net-analyzer/cacti/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/cacti
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.62 2006/01/16 03:56:37 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.63 2006/01/16 17:02:28 ramereth Exp $
+
+*cacti-0.8.6h_p20060108 (16 Jan 2006)
+
+ 16 Jan 2006; Lance Albertson <ramereth@gentoo.org>
+ +cacti-0.8.6h_p20060108.ebuild:
+ * Version bump (new patched version)
16 Jan 2006; Lance Albertson <ramereth@gentoo.org> cacti-0.8.6h.ebuild:
* Corrected ebuild to use httpd-like virtual
diff --git a/net-analyzer/cacti/Manifest b/net-analyzer/cacti/Manifest
index 40381e549e54..4971268b6686 100644
--- a/net-analyzer/cacti/Manifest
+++ b/net-analyzer/cacti/Manifest
@@ -2,8 +2,10 @@ MD5 e06fec859a60f26815bafd271c311ba8 ChangeLog 9065
MD5 8e19108be4619e53fa7e51c02e1dd872 cacti-0.8.6g.ebuild 1710
MD5 e8e9790acabe6a42fda45cc8e72a93a3 cacti-0.8.6g_p20051023.ebuild 1859
MD5 e0e4a72c16fd2c2e3357473c738d4ff5 cacti-0.8.6h.ebuild 1784
+MD5 768d56b4b863e952c81aff0cd9fefa5e cacti-0.8.6h_p20060108.ebuild 1888
MD5 b9b37ff105d9d50fb2c9a7b0b2a60429 files/digest-cacti-0.8.6g 65
MD5 80642855127d3174cad394f11f138243 files/digest-cacti-0.8.6g_p20051023 346
MD5 ede2752b4bd41c56fbb8dd6085875f58 files/digest-cacti-0.8.6h 65
+MD5 0882b2c5bfd2ede2d9fd67eedbf625eb files/digest-cacti-0.8.6h_p20060108 383
MD5 cf35c7601be5a748b851ae64487871f2 files/postinstall-en.txt 2062
MD5 191d624f14b534af99878690f9b5a083 metadata.xml 743
diff --git a/net-analyzer/cacti/cacti-0.8.6h_p20060108.ebuild b/net-analyzer/cacti/cacti-0.8.6h_p20060108.ebuild
new file mode 100644
index 000000000000..72f8e61220df
--- /dev/null
+++ b/net-analyzer/cacti/cacti-0.8.6h_p20060108.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.6h_p20060108.ebuild,v 1.1 2006/01/16 17:02:28 ramereth Exp $
+
+inherit eutils webapp depend.apache
+
+# (patched versions)
+MY_P=${P/_p*/}
+
+DESCRIPTION="Cacti is a complete frontend to rrdtool"
+HOMEPAGE="http://www.cacti.net/"
+# patches
+UPSTREAM_PATCHES="fix_search_session_clear_issue
+fix_sql_syntax_related_to_default_rra_id mysql_5x_strict
+nth_percentile_empty_return_set_issue"
+SRC_URI="http://www.cacti.net/downloads/${MY_P}.tar.gz"
+for i in $UPSTREAM_PATCHES ; do
+ SRC_URI="${SRC_URI} http://www.cacti.net/downloads/patches/${PV/_p*}/${i}.patch"
+done
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="snmp"
+
+DEPEND=""
+
+want_apache
+
+# alpha doesn't have lighttpd keyworded yet
+RDEPEND="!alpha? ( !apache? ( !apache2? ( www-servers/lighttpd ) ) )
+ snmp? ( net-analyzer/net-snmp )
+ net-analyzer/rrdtool
+ dev-db/mysql
+ virtual/cron
+ virtual/php
+ virtual/httpd-php"
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz ; mv ${MY_P} ${P}
+ # patches
+ for i in ${UPSTREAM_PATCHES} ; do
+ EPATCH_OPTS="-p1 -d ${S} -N" epatch ${DISTDIR}/${i}.patch
+ done ;
+}
+
+pkg_setup() {
+ webapp_pkg_setup
+ built_with_use virtual/php mysql || \
+ die "php cli sapi must be compiled with USE=mysql"
+ built_with_use virtual/httpd-php mysql || \
+ die "php apache/cgi sapi must be compiled with USE=mysql"
+}
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc LICENSE
+ rm LICENSE README
+
+ dodoc docs/{CHANGELOG,CONTRIB,INSTALL,README,REQUIREMENTS,UPGRADE}
+ rm -rf docs
+
+ edos2unix `find -type f -name '*.php'`
+
+ dodir ${MY_HTDOCSDIR}
+ cp -r . ${D}${MY_HTDOCSDIR}
+
+ webapp_configfile ${MY_HTDOCSDIR}/include/config.php
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+
+ webapp_src_install
+}
+
diff --git a/net-analyzer/cacti/files/digest-cacti-0.8.6h_p20060108 b/net-analyzer/cacti/files/digest-cacti-0.8.6h_p20060108
new file mode 100644
index 000000000000..23e1daf799f8
--- /dev/null
+++ b/net-analyzer/cacti/files/digest-cacti-0.8.6h_p20060108
@@ -0,0 +1,5 @@
+MD5 5f6100b525b5b29e81f43cc7c55f4000 cacti-0.8.6h.tar.gz 1096877
+MD5 20dd3bd4688e95490d649768e9191f3a fix_search_session_clear_issue.patch 1154
+MD5 4ab874541b292e07eacbbce6dc505717 fix_sql_syntax_related_to_default_rra_id.patch 1058
+MD5 055b4e270e0586ff630b45886850bbbf mysql_5x_strict.patch 2593
+MD5 b64160dd736d404eb1b2537e9c80199d nth_percentile_empty_return_set_issue.patch 4792