summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-09-05 08:21:07 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-09-05 08:21:07 +0000
commit0d868a6e9a0eafd8ffd2e331eba8f11a4f8579c7 (patch)
treedd089883668f6aac9eb46c509ebcad59c4dbaefe /net-analyzer
parentUse domenu instead insinto + doins to install .desktop files (diff)
downloadgentoo-2-0d868a6e9a0eafd8ffd2e331eba8f11a4f8579c7.tar.gz
gentoo-2-0d868a6e9a0eafd8ffd2e331eba8f11a4f8579c7.tar.bz2
gentoo-2-0d868a6e9a0eafd8ffd2e331eba8f11a4f8579c7.zip
Add new revision with virtual/logger dependency wrt bug #433980
(Portage version: 2.2.0_alpha123/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/fail2ban/ChangeLog7
-rw-r--r--net-analyzer/fail2ban/fail2ban-0.8.6-r1.ebuild73
2 files changed, 79 insertions, 1 deletions
diff --git a/net-analyzer/fail2ban/ChangeLog b/net-analyzer/fail2ban/ChangeLog
index 424be2050208..540ce97e6558 100644
--- a/net-analyzer/fail2ban/ChangeLog
+++ b/net-analyzer/fail2ban/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/fail2ban
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/ChangeLog,v 1.83 2012/04/23 16:12:09 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/ChangeLog,v 1.84 2012/09/05 08:21:07 pinkbyte Exp $
+
+*fail2ban-0.8.6-r1 (05 Sep 2012)
+
+ 05 Sep 2012; Sergey Popov <pinkbyte@gentoo.org> +fail2ban-0.8.6-r1.ebuild:
+ Add new revision with virtual/logger dependency wrt bug #433980
23 Apr 2012; Jeremy Olexa <darkside@gentoo.org> -fail2ban-0.8.4-r3.ebuild,
-fail2ban-0.8.4-r4.ebuild, -files/fail2ban-0.8.4-cve2009-5023.patch,
diff --git a/net-analyzer/fail2ban/fail2ban-0.8.6-r1.ebuild b/net-analyzer/fail2ban/fail2ban-0.8.6-r1.ebuild
new file mode 100644
index 000000000000..a3549062aecc
--- /dev/null
+++ b/net-analyzer/fail2ban/fail2ban-0.8.6-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.8.6-r1.ebuild,v 1.1 2012/09/05 08:21:07 pinkbyte Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+
+inherit distutils eutils
+
+DESCRIPTION="Bans IP that make too many password failures"
+HOMEPAGE="http://www.fail2ban.org/"
+SRC_URI="https://github.com/${PN}/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="selinux"
+
+DEPEND="selinux? ( sec-policy/selinux-fail2ban )"
+RDEPEND="net-misc/whois
+ virtual/mta
+ virtual/logger
+ net-firewall/iptables
+ selinux? ( sec-policy/selinux-fail2ban )"
+
+S="${WORKDIR}"/${PN}-${PN}-a20d1f8
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-sshd-breakin.patch \
+ "${FILESDIR}"/${P}-gentoo-init.patch
+ distutils_src_prepare
+}
+
+src_install() {
+ distutils_src_install
+
+ newconfd files/gentoo-confd fail2ban || die
+ newinitd files/gentoo-initd fail2ban || die
+ dodoc ChangeLog README TODO || die "dodoc failed"
+ doman man/*.1 || die "doman failed"
+
+ # Use INSTALL_MASK if you do not want to touch /etc/logrotate.d.
+ # See http://thread.gmane.org/gmane.linux.gentoo.devel/35675
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}-logrotate ${PN} || die
+}
+
+pkg_preinst() {
+ has_version "<${CATEGORY}/${PN}-0.7"
+ previous_less_than_0_7=$?
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ if [[ $previous_less_than_0_7 = 0 ]] ; then
+ elog
+ elog "Configuration files are now in /etc/fail2ban/"
+ elog "You probably have to manually update your configuration"
+ elog "files before restarting Fail2ban!"
+ elog
+ elog "Fail2ban is not installed under /usr/lib anymore. The"
+ elog "new location is under /usr/share."
+ elog
+ elog "You are upgrading from version 0.6.x, please see:"
+ elog "http://www.fail2ban.org/wiki/index.php/HOWTO_Upgrade_from_0.6_to_0.8"
+ fi
+}