summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2007-12-03 23:54:35 +0000
committerWolfram Schlich <wschlich@gentoo.org>2007-12-03 23:54:35 +0000
commit081fb8f05f6168c0be1e46b6e895506c09163676 (patch)
treeb7c4ef2527b5cdde59322a4100d2b159fafe69a7 /net-analyzer
parentfix libotr dep (diff)
downloadgentoo-2-081fb8f05f6168c0be1e46b6e895506c09163676.tar.gz
gentoo-2-081fb8f05f6168c0be1e46b6e895506c09163676.tar.bz2
gentoo-2-081fb8f05f6168c0be1e46b6e895506c09163676.zip
added initgroups patch
(Portage version: 2.1.4_rc3)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/zabbix/ChangeLog9
-rw-r--r--net-analyzer/zabbix/files/1.4.2/initgroups.patch39
-rw-r--r--net-analyzer/zabbix/files/digest-zabbix-1.4.2-r13
-rw-r--r--net-analyzer/zabbix/zabbix-1.4.2-r1.ebuild269
4 files changed, 319 insertions, 1 deletions
diff --git a/net-analyzer/zabbix/ChangeLog b/net-analyzer/zabbix/ChangeLog
index 332662208f16..7839b83c13dd 100644
--- a/net-analyzer/zabbix/ChangeLog
+++ b/net-analyzer/zabbix/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/zabbix
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix/ChangeLog,v 1.3 2007/08/24 14:27:39 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix/ChangeLog,v 1.4 2007/12/03 23:54:34 wschlich Exp $
+
+*zabbix-1.4.2-r1 (03 Dec 2007)
+
+ 03 Dec 2007; Wolfram Schlich <wschlich@gentoo.org>
+ +files/1.4.2/initgroups.patch, +zabbix-1.4.2-r1.ebuild:
+ Added initgroups patch from
+ http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=452682
*zabbix-1.4.2 (24 Aug 2007)
diff --git a/net-analyzer/zabbix/files/1.4.2/initgroups.patch b/net-analyzer/zabbix/files/1.4.2/initgroups.patch
new file mode 100644
index 000000000000..cac41213e2d9
--- /dev/null
+++ b/net-analyzer/zabbix/files/1.4.2/initgroups.patch
@@ -0,0 +1,39 @@
+--- zabbix-1.4.2/src/libs/zbxnix/daemon.c 2007-08-20 21:22:22.000000000 +0200
++++ zabbix-1.4.2/src/libs/zbxnix/daemon.c 2007-11-25 15:53:31.890046746 +0100
+@@ -90,20 +90,33 @@
+ pid_t pid;
+ struct passwd *pwd;
+ struct sigaction phan;
++ char user[7] = "zabbix";
+
+ /* running as root ?*/
+ if((0 == allow_root) && (0 == getuid() || 0 == getgid()))
+ {
+- pwd = getpwnam("zabbix");
++ pwd = getpwnam(user);
+ if (NULL == pwd)
+ {
+ zbx_error("User zabbix does not exist.");
+ zbx_error("Cannot run as root !");
+ exit(FAIL);
+ }
+- if( (setgid(pwd->pw_gid) ==-1) || (setuid(pwd->pw_uid) == -1) )
++ if( (setgid(pwd->pw_gid) ==-1) )
+ {
+- zbx_error("Cannot setgid or setuid to zabbix [%s].", strerror(errno));
++ zbx_error("Cannot setgid to zabbix [%s].", strerror(errno));
++ exit(FAIL);
++ }
++
++ if( (initgroups(user, pwd->pw_gid) == -1) )
++ {
++ zbx_error("Cannot initgroups to zabbix [%s].", strerror(errno));
++ exit(FAIL);
++ }
++
++ if( (setuid(pwd->pw_uid) ==-1) )
++ {
++ zbx_error("Cannot setuid to zabbix [%s].", strerror(errno));
+ exit(FAIL);
+ }
+
diff --git a/net-analyzer/zabbix/files/digest-zabbix-1.4.2-r1 b/net-analyzer/zabbix/files/digest-zabbix-1.4.2-r1
new file mode 100644
index 000000000000..f88b94cba904
--- /dev/null
+++ b/net-analyzer/zabbix/files/digest-zabbix-1.4.2-r1
@@ -0,0 +1,3 @@
+MD5 1a89f3b8b0925c6373379b4c5dd3138b zabbix-1.4.2.tar.gz 3302530
+RMD160 d95e9553dd2daa109db7b7990899f5e7c132a668 zabbix-1.4.2.tar.gz 3302530
+SHA256 8dd0455e8a723cc9f31f0d41e7fbefa4d72088727c470c918e29de94c71c99bd zabbix-1.4.2.tar.gz 3302530
diff --git a/net-analyzer/zabbix/zabbix-1.4.2-r1.ebuild b/net-analyzer/zabbix/zabbix-1.4.2-r1.ebuild
new file mode 100644
index 000000000000..3c788601c669
--- /dev/null
+++ b/net-analyzer/zabbix/zabbix-1.4.2-r1.ebuild
@@ -0,0 +1,269 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix/zabbix-1.4.2-r1.ebuild,v 1.1 2007/12/03 23:54:34 wschlich Exp $
+
+inherit eutils flag-o-matic webapp depend.php
+
+DESCRIPTION="ZABBIX is software for monitoring of your applications, network and servers."
+HOMEPAGE="http://www.zabbix.com/"
+SRC_URI="mirror://sourceforge/zabbix/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+WEBAPP_MANUAL_SLOT="yes"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="agent curl frontend jabber ldap mysql oracle postgres server snmp sqlite3"
+DEPEND="virtual/libc
+ snmp? ( net-analyzer/net-snmp )
+ ldap? (
+ net-nds/openldap
+ =dev-libs/cyrus-sasl-2*
+ net-libs/gnutls
+ )
+ mysql? ( virtual/mysql )
+ sqlite3? ( =dev-db/sqlite-3* )
+ postgres? ( dev-db/libpq )
+ jabber? ( dev-libs/iksemel )
+ curl? ( net-misc/curl )"
+RDEPEND="${RDEPEND}
+ server? ( net-analyzer/fping )"
+
+useq frontend && need_php_httpd
+
+pkg_setup() {
+ if useq server; then
+ local dbnum dbtypes="mysql oracle postgres sqlite3" dbtype
+ declare -i dbnum=0
+ for dbtype in ${dbtypes}; do
+ useq ${dbtype} && let dbnum++
+ done
+ if [ ${dbnum} -gt 1 ]; then
+ eerror
+ eerror "You can't use more than one database type in Zabbix."
+ eerror "Select exactly one database type out of these: ${dbtypes}"
+ eerror
+ die "Multiple database types selected."
+ elif [ ${dbnum} -lt 1 ]; then
+ eerror
+ eerror "Select exactly one database type out of these: ${dbtypes}"
+ eerror
+ die "No database type selected."
+ fi
+ if useq oracle; then
+ if [ -z "${ORACLE_HOME}" ]; then
+ eerror
+ eerror "The environment variable ORACLE_HOME must be set"
+ eerror "and point to the correct location."
+ eerror "It looks like you don't have Oracle installed."
+ eerror
+ die "Environment variable ORACLE_HOME is not set"
+ fi
+ if has_version 'dev-db/oracle-instantclient-basic'; then
+ ewarn
+ ewarn "Please ensure you have a full install of the Oracle client."
+ ewarn "dev-db/oracle-instantclient* is NOT sufficient."
+ ewarn
+ fi
+ fi
+ fi
+
+ if useq frontend; then
+ webapp_pkg_setup
+ require_gd
+ fi
+
+ enewgroup zabbix
+ enewuser zabbix -1 -1 /var/lib/zabbix/home zabbix
+}
+
+pkg_postinst() {
+ if useq server; then
+ elog
+ elog "You need to configure your database for Zabbix."
+ elog
+ elog "Have a look at /usr/share/zabbix/database for"
+ elog "database creation and upgrades."
+ elog
+ elog "For more info read the Zabbix manual at"
+ elog "http://www.zabbix.com/manual/v1.4/"
+ elog
+
+ zabbix_homedir="$(egetent passwd zabbix | cut -d : -f 6 )"
+ if [ -n "${zabbix_homedir}" ] && \
+ [ "${zabbix_homedir}" != "/var/lib/zabbix/home" ]; then
+ ewarn
+ ewarn "The user 'zabbix' should have his homedir changed"
+ ewarn "to /var/lib/zabbix/home if you want to use"
+ ewarn "custom alert scripts."
+ ewarn
+ ewarn "A real homedir might be needed for configfiles"
+ ewarn "for custom alert scripts (e.g. ~/.sendxmpprc when"
+ ewarn "using sendxmpp for Jabber alerts)."
+ ewarn
+ ewarn "To change the homedir use:"
+ ewarn " usermod -d /var/lib/zabbix/home zabbix"
+ ewarn
+ fi
+ fi
+
+ # repeat fowners/fperms functionality from src_install()
+ # here to catch wrong permissions on existing files in
+ # the live filesystem (yeah, that sucks).
+ chown zabbix:zabbix \
+ ${ROOT}etc/zabbix \
+ ${ROOT}var/lib/zabbix \
+ ${ROOT}var/lib/zabbix/home \
+ ${ROOT}var/lib/zabbix/scripts \
+ ${ROOT}var/log/zabbix \
+ ${ROOT}var/run/zabbix
+ chmod 0750 \
+ ${ROOT}etc/zabbix \
+ ${ROOT}var/lib/zabbix \
+ ${ROOT}var/lib/zabbix/home \
+ ${ROOT}var/lib/zabbix/scripts \
+ ${ROOT}var/log/zabbix \
+ ${ROOT}var/run/zabbix
+ if useq server; then
+ chown zabbix:zabbix \
+ ${ROOT}etc/zabbix/zabbix_server.conf
+ chmod 0640 \
+ ${ROOT}etc/zabbix/zabbix_server.conf
+ fi
+ if useq agent; then
+ chown zabbix:zabbix \
+ ${ROOT}etc/zabbix/zabbix_agent.conf \
+ ${ROOT}etc/zabbix/zabbix_agentd.conf
+ chmod 0640 \
+ ${ROOT}etc/zabbix/zabbix_agent.conf \
+ ${ROOT}etc/zabbix/zabbix_agentd.conf
+ fi
+
+ if useq server; then
+ # check for fping
+ fping_perms=$(stat -c %a /usr/sbin/fping 2>/dev/null)
+ case "${fping_perms}" in
+ 4[157][157][157])
+ ;;
+ *)
+ ewarn
+ ewarn "If you want to use the checks 'icmpping' and 'icmppingsec',"
+ ewarn "you have to make /usr/sbin/fping setuid root and executable"
+ ewarn "by everyone. Run the following command to fix it:"
+ ewarn
+ ewarn " chmod u=rwsx,g=rx,o=rx /usr/sbin/fping"
+ ewarn
+ ewarn "Please be aware that this might impose a security risk,"
+ ewarn "depending on the code quality of fping."
+ ewarn
+ ebeep 3
+ epause 5
+ ;;
+ esac
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${PV}/initgroups.patch
+}
+
+src_compile() {
+ econf \
+ $(use_enable server) \
+ $(use_enable agent) \
+ $(use_with ldap) \
+ $(use_with snmp net-snmp) \
+ $(use_with mysql) \
+ $(use_with postgres pgsql) \
+ $(use_with oracle) \
+ $(use_with sqlite3) \
+ $(use_with jabber) \
+ $(use_with curl libcurl) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir \
+ /etc/zabbix \
+ /var/lib/zabbix \
+ /var/lib/zabbix/home \
+ /var/lib/zabbix/scripts \
+ /var/log/zabbix \
+ /var/run/zabbix
+
+ keepdir \
+ /etc/zabbix \
+ /var/lib/zabbix \
+ /var/lib/zabbix/home \
+ /var/lib/zabbix/scripts \
+ /var/log/zabbix \
+ /var/run/zabbix
+
+ if useq server; then
+ insinto /etc/zabbix
+ doins \
+ ${FILESDIR}/${PV}/zabbix_server.conf
+ doinitd \
+ ${FILESDIR}/${PV}/init.d/zabbix-server
+ dosbin \
+ src/zabbix_server/zabbix_server
+ dodir \
+ /usr/share/zabbix/database
+ insinto /usr/share/zabbix/database
+ doins -r \
+ upgrades \
+ create
+ fowners zabbix:zabbix \
+ /etc/zabbix/zabbix_server.conf
+ fperms 0640 \
+ /etc/zabbix/zabbix_server.conf
+ fi
+
+ if useq agent; then
+ insinto /etc/zabbix
+ doins \
+ ${FILESDIR}/${PV}/zabbix_agent.conf \
+ ${FILESDIR}/${PV}/zabbix_agentd.conf
+ doinitd \
+ ${FILESDIR}/${PV}/init.d/zabbix-agentd
+ dosbin \
+ src/zabbix_agent/zabbix_agent \
+ src/zabbix_agent/zabbix_agentd
+ dobin \
+ src/zabbix_sender/zabbix_sender \
+ src/zabbix_get/zabbix_get
+ fowners zabbix:zabbix \
+ /etc/zabbix/zabbix_agent.conf \
+ /etc/zabbix/zabbix_agentd.conf
+ fperms 0640 \
+ /etc/zabbix/zabbix_agent.conf \
+ /etc/zabbix/zabbix_agentd.conf
+ fi
+
+ fowners zabbix:zabbix \
+ /etc/zabbix \
+ /var/lib/zabbix \
+ /var/lib/zabbix/home \
+ /var/lib/zabbix/scripts \
+ /var/log/zabbix \
+ /var/run/zabbix
+ fperms 0750 \
+ /etc/zabbix \
+ /var/lib/zabbix \
+ /var/lib/zabbix/home \
+ /var/lib/zabbix/scripts \
+ /var/log/zabbix \
+ /var/run/zabbix
+
+ dodoc README INSTALL NEWS ChangeLog
+
+ if useq frontend; then
+ webapp_src_preinst
+ cp -R frontends/php/* "${D}/${MY_HTDOCSDIR}"
+ webapp_postinst_txt en ${FILESDIR}/${PV}/postinstall-en.txt
+ webapp_configfile \
+ ${MY_HTDOCSDIR}/include/db.inc.php \
+ ${MY_HTDOCSDIR}/include/config.inc.php
+ webapp_src_install
+ fi
+}