summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-10-27 20:54:28 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-10-27 20:54:28 +0000
commit891044684834d71e322f30cc76e23b69f7445363 (patch)
tree403833781dc1e84af17f4c976e9f134b964142a3 /net-analyzer/w3af
parentVersion bump (diff)
downloadgentoo-2-891044684834d71e322f30cc76e23b69f7445363.tar.gz
gentoo-2-891044684834d71e322f30cc76e23b69f7445363.tar.bz2
gentoo-2-891044684834d71e322f30cc76e23b69f7445363.zip
Multiple QA fixes. Thanks to Anton Bolshakov and montjoie for the fixes and patches. Bug #272200
(Portage version: 2.2.0_alpha1/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/w3af')
-rw-r--r--net-analyzer/w3af/ChangeLog10
-rw-r--r--net-analyzer/w3af/files/use_simplejson_instead_of_jsonpy.patch105
-rw-r--r--net-analyzer/w3af/files/w3af_console3
-rw-r--r--net-analyzer/w3af/files/w3af_gui3
-rw-r--r--net-analyzer/w3af/w3af-1.0_rc3-r2.ebuild (renamed from net-analyzer/w3af/w3af-1.0_rc3-r1.ebuild)14
5 files changed, 130 insertions, 5 deletions
diff --git a/net-analyzer/w3af/ChangeLog b/net-analyzer/w3af/ChangeLog
index d61e4638b66c..1ae32a854249 100644
--- a/net-analyzer/w3af/ChangeLog
+++ b/net-analyzer/w3af/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-analyzer/w3af
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/w3af/ChangeLog,v 1.3 2010/09/06 17:37:25 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/w3af/ChangeLog,v 1.4 2010/10/27 20:54:28 hwoarang Exp $
+
+*w3af-1.0_rc3-r2 (27 Oct 2010)
+
+ 27 Oct 2010; Markos Chandras <hwoarang@gentoo.org>
+ +w3af-1.0_rc3-r2.ebuild, +files/use_simplejson_instead_of_jsonpy.patch,
+ +files/w3af_console, +files/w3af_gui, -w3af-1.0_rc3-r1.ebuild:
+ Multiple QA fixes. Thanks to Anton Bolshakov and montjoie for the fixes
+ and patches. Bug #272200
06 Sep 2010; Jeroen Roovers <jer@gentoo.org> metadata.xml:
Fix empty herd tag.
diff --git a/net-analyzer/w3af/files/use_simplejson_instead_of_jsonpy.patch b/net-analyzer/w3af/files/use_simplejson_instead_of_jsonpy.patch
new file mode 100644
index 000000000000..306c24a59f8a
--- /dev/null
+++ b/net-analyzer/w3af/files/use_simplejson_instead_of_jsonpy.patch
@@ -0,0 +1,105 @@
+--- ./core/controllers/misc/dependencyCheck.py.old 2010-10-19 09:58:19.000000000 +0200
++++ ./core/controllers/misc/dependencyCheck.py 2010-10-19 09:58:32.000000000 +0200
+@@ -95,15 +95,6 @@
+ except:
+ print 'You have to install pyPdf lib. Debian based distributions: apt-get install python-pypdf'
+ sys.exit( 1 )
+-
+- try:
+- from extlib.jsonpy import json as json
+- except:
+- try:
+- import json
+- except:
+- print 'You have to install python-json lib. Debian based distributions: apt-get install python-json'
+- sys.exit( 1 )
+
+ try:
+ from OpenSSL import SSL
+--- core/data/fuzzer/fuzzer.py.old 2010-10-19 10:00:59.000000000 +0200
++++ core/data/fuzzer/fuzzer.py 2010-10-19 10:02:14.000000000 +0200
+@@ -38,9 +38,9 @@
+ from core.data.dc.cookie import cookie as cookie
+ from core.data.dc.dataContainer import dataContainer as dc
+ try:
+- from extlib.jsonpy import json as json
++ import extlib.simplejson as json
+ except:
+- import json
++ import simplejson as json
+ from core.data.request.httpPostDataRequest import httpPostDataRequest
+ from core.data.request.httpQsRequest import httpQsRequest
+
+@@ -210,7 +210,7 @@
+
+ # Now, fuzz the parsed JSON data...
+ postdata = freq.getData()
+- jsonPostData = json.read( postdata )
++ jsonPostData = json.loads( postdata )
+ return _makeMutants( freq, mutantClass, mutant_str_list, fuzzableParamList , append, jsonPostData )
+
+ def isJSON( freq ):
+@@ -222,7 +222,7 @@
+ # We have something that's not URL encoded in the postdata, it could be something
+ # like JSON, XML, or multipart encoding. Let's try with JSON
+ try:
+- jsonPostData = json.read( postdata )
++ jsonPostData = json.loads( postdata )
+ except:
+ # It's not json, maybe XML or multipart, I don't really care ( at least not in this section of the code )
+ return False
+--- core/data/request/frFactory.py.old 2010-10-19 10:03:50.000000000 +0200
++++ core/data/request/frFactory.py 2010-10-19 10:04:38.000000000 +0200
+@@ -37,9 +37,9 @@
+
+ # for json
+ try:
+- from extlib.jsonpy import json as json
++ import extlib.simplejson as json
+ except:
+- import json
++ import simplejson as json
+
+ from core.controllers.w3afException import w3afException
+ import core.controllers.outputManager as om
+@@ -200,7 +200,7 @@
+ # Case #2, JSON request
+ #
+ try:
+- dc = json.read( postData )
++ dc = json.loads( postData )
+ except:
+ pass
+ else:
+--- core/data/request/jsonPostDataRequest.py.old 2010-10-19 10:12:22.000000000 +0200
++++ core/data/request/jsonPostDataRequest.py 2010-10-19 10:15:05.000000000 +0200
+@@ -25,9 +25,9 @@
+ from core.data.request.httpPostDataRequest import httpPostDataRequest
+ import core.data.dc.dataContainer as dc
+ try:
+- from extlib.jsonpy import json as json
++ import extlib.simplejson as json
+ except:
+- import json
++ import simplejson
+
+ class jsonPostDataRequest(httpPostDataRequest):
+ '''
+@@ -43,7 +43,7 @@
+ '''
+ @return: A string that represents the JSON data saved in the dc.
+ '''
+- res = json.write(self._dc)
++ res = json.dumps(self._dc)
+ return res
+
+ def __str__( self ):
+@@ -54,7 +54,7 @@
+ strRes += self._url
+ strRes += ' | Method: ' + self._method
+ strRes += ' | JSON: ('
+- strRes += json.write(self._dc)
++ strRes += json.dumps(self._dc)
+ strRes += ')'
+ return strRes
+
diff --git a/net-analyzer/w3af/files/w3af_console b/net-analyzer/w3af/files/w3af_console
new file mode 100644
index 000000000000..93212cefb237
--- /dev/null
+++ b/net-analyzer/w3af/files/w3af_console
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd /usr/lib/w3af
+./w3af_console $*
diff --git a/net-analyzer/w3af/files/w3af_gui b/net-analyzer/w3af/files/w3af_gui
new file mode 100644
index 000000000000..41f4802e3ae1
--- /dev/null
+++ b/net-analyzer/w3af/files/w3af_gui
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd /usr/lib/w3af
+./w3af_gui $*
diff --git a/net-analyzer/w3af/w3af-1.0_rc3-r1.ebuild b/net-analyzer/w3af/w3af-1.0_rc3-r2.ebuild
index 88ad5703eb10..8f76e9b49d20 100644
--- a/net-analyzer/w3af/w3af-1.0_rc3-r1.ebuild
+++ b/net-analyzer/w3af/w3af-1.0_rc3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/w3af/w3af-1.0_rc3-r1.ebuild,v 1.1 2010/08/31 12:29:41 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/w3af/w3af-1.0_rc3-r2.ebuild,v 1.1 2010/10/27 20:54:28 hwoarang Exp $
EAPI=2
@@ -25,6 +25,9 @@ RDEPEND="dev-python/beautifulsoup
dev-python/pyopenssl
dev-python/pyPdf
dev-python/pysqlite
+ dev-python/python-cluster
+ dev-python/pyyaml
+ dev-python/simplejson
dev-python/soappy
net-analyzer/scapy
gtk? ( media-gfx/graphviz
@@ -33,16 +36,19 @@ RDEPEND="dev-python/beautifulsoup
S=${WORKDIR}/${PN}
src_prepare(){
- rm -r extlib/{BeautifulSoup.py,fpconst-0.7.2,nltk,nltk_contrib,pyPdf,scapy,SOAPpy,yaml} || die
+ rm -r extlib/{BeautifulSoup.py,cluster,fpconst-0.7.2,jsonpy,nltk,nltk_contrib,pyPdf,scapy,SOAPpy,yaml} || die
rm readme/{GPL,INSTALL} || die
+ epatch "${FILESDIR}"/use_simplejson_instead_of_jsonpy.patch
}
src_install() {
insinto /usr/$(get_libdir)/w3af
doins -r core extlib locales plugins profiles scripts tools w3af_gui w3af_console || die
- dosym /usr/$(get_libdir)/w3af/w3af_gui usr/bin/w3af_gui || die
- dosym /usr/$(get_libdir)/w3af/w3af_console usr/bin/w3af_console || die
fperms +x /usr/$(get_libdir)/w3af/w3af_{gui,console} || die
+ dobin "${FILESDIR}"/w3af_console || die
+ if use gtk ; then
+ dobin "${FILESDIR}"/w3af_gui || die
+ fi
#use flag doc is here because doc is bigger than 3 Mb
if use doc ; then
insinto /usr/share/doc/${PF}/