summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-06-04 20:17:14 +0000
committerSven Wegener <swegener@gentoo.org>2005-06-04 20:17:14 +0000
commitaf10e924299dfeb2abbdd00346478b95813be8ae (patch)
tree6da6689ae0ab7434540c02ac9a83689a3a443dc1 /net-analyzer/thrulay
parentcosmectic changes (diff)
downloadgentoo-2-af10e924299dfeb2abbdd00346478b95813be8ae.tar.gz
gentoo-2-af10e924299dfeb2abbdd00346478b95813be8ae.tar.bz2
gentoo-2-af10e924299dfeb2abbdd00346478b95813be8ae.zip
Added cross-compile support and error checking.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'net-analyzer/thrulay')
-rw-r--r--net-analyzer/thrulay/ChangeLog5
-rw-r--r--net-analyzer/thrulay/thrulay-0.6.ebuild17
2 files changed, 13 insertions, 9 deletions
diff --git a/net-analyzer/thrulay/ChangeLog b/net-analyzer/thrulay/ChangeLog
index e0bd677e8379..267ba98f3318 100644
--- a/net-analyzer/thrulay/ChangeLog
+++ b/net-analyzer/thrulay/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-analyzer/thrulay
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/thrulay/ChangeLog,v 1.1 2005/06/04 19:28:50 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/thrulay/ChangeLog,v 1.2 2005/06/04 20:17:14 swegener Exp $
+
+ 04 Jun 2005; Sven Wegener <swegener@gentoo.org> thrulay-0.6.ebuild:
+ Added cross-compile support and error checking.
*thrulay-0.6 (04 Jun 2005)
diff --git a/net-analyzer/thrulay/thrulay-0.6.ebuild b/net-analyzer/thrulay/thrulay-0.6.ebuild
index 71e8541cf995..8b20eb0c5b03 100644
--- a/net-analyzer/thrulay/thrulay-0.6.ebuild
+++ b/net-analyzer/thrulay/thrulay-0.6.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/thrulay/thrulay-0.6.ebuild,v 1.1 2005/06/04 19:28:50 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/thrulay/thrulay-0.6.ebuild,v 1.2 2005/06/04 20:17:14 swegener Exp $
+
+inherit toolchain-funcs
DESCRIPTION="Measure the capacity of a network by sending a bulk TCP stream over it."
HOMEPAGE="http://www.internet2.edu/~shalunov/thrulay/"
@@ -10,16 +12,15 @@ SLOT="0"
KEYWORDS="~x86"
IUSE=""
DEPEND=""
-#RDEPEND=""
src_compile() {
- emake OPT="${CFLAGS}"
+ emake CC="$(tc-getCC)" OPT="${CFLAGS}" || die "emake failed"
}
src_install() {
- dobin thrulay
- dosbin thrulayd
- dodoc LICENSE README TODO thrulay-protocol.txt
- newinitd ${FILESDIR}/thrulayd-init.d thrulayd
- newconfd ${FILESDIR}/thrulayd-conf.d thrulayd
+ dobin thrulay || die "dobin failed"
+ dosbin thrulayd || die "dosbin failed"
+ dodoc LICENSE README TODO thrulay-protocol.txt || die "dodoc failed"
+ newinitd "${FILESDIR}"/thrulayd-init.d thrulayd || die "newinitd failed"
+ newconfd "${FILESDIR}"/thrulayd-conf.d thrulayd || die "newconfd failed"
}