summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-10-02 07:25:53 +0000
committerMike Frysinger <vapier@gentoo.org>2003-10-02 07:25:53 +0000
commit96e2fafe22fa62bc00b03cfc66f0e61d5528c2eb (patch)
tree85f50ed2a1eeab4080d69bfdec501e1990ec63bf /net-analyzer/thcrut/thcrut-1.2.5.ebuild
parentmmm stable (diff)
downloadgentoo-2-96e2fafe22fa62bc00b03cfc66f0e61d5528c2eb.tar.gz
gentoo-2-96e2fafe22fa62bc00b03cfc66f0e61d5528c2eb.tar.bz2
gentoo-2-96e2fafe22fa62bc00b03cfc66f0e61d5528c2eb.zip
initial ebuild #21848
Diffstat (limited to 'net-analyzer/thcrut/thcrut-1.2.5.ebuild')
-rw-r--r--net-analyzer/thcrut/thcrut-1.2.5.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-analyzer/thcrut/thcrut-1.2.5.ebuild b/net-analyzer/thcrut/thcrut-1.2.5.ebuild
new file mode 100644
index 000000000000..7506deb5a948
--- /dev/null
+++ b/net-analyzer/thcrut/thcrut-1.2.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc., Copyright 2003 The Hackers Choice - http://www.thc.org
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/thcrut/thcrut-1.2.5.ebuild,v 1.1 2003/10/02 07:25:53 vapier Exp $
+
+DESCRIPTION="Network discovery and fingerprinting tool"
+HOMEPAGE="http://www.thc.org/thc-rut/"
+SRC_URI="http://www.thc.org/thc-rut/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+
+DEPEND="net-libs/libpcap
+ <net-libs/libnet-1.1
+ >=net-libs/libnet-1.0.2a-r3"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ rm -rf Libnet-1.0.2a
+ epatch ${FILESDIR}/${PV}-libnet.patch
+}
+
+src_compile() {
+ econf || die "./configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+ dodoc ChangeLog FAQ README TODO thcrutlogo.txt
+}