summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2004-07-05 12:20:02 +0000
committerEldad Zack <eldad@gentoo.org>2004-07-05 12:20:02 +0000
commitb1614760d749b1afb30ace07dcb1b47d99064aaf (patch)
tree323077a7172bc60e30dd3edc4d3666c494dca977 /net-analyzer/snort_inline/snort_inline-2.1.1.ebuild
parentadd gimp-print-5.0.0_beta1 (diff)
downloadgentoo-2-b1614760d749b1afb30ace07dcb1b47d99064aaf.tar.gz
gentoo-2-b1614760d749b1afb30ace07dcb1b47d99064aaf.tar.bz2
gentoo-2-b1614760d749b1afb30ace07dcb1b47d99064aaf.zip
Added a search for the location of libipq includes. Closes #49492.
Diffstat (limited to 'net-analyzer/snort_inline/snort_inline-2.1.1.ebuild')
-rw-r--r--net-analyzer/snort_inline/snort_inline-2.1.1.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/net-analyzer/snort_inline/snort_inline-2.1.1.ebuild b/net-analyzer/snort_inline/snort_inline-2.1.1.ebuild
index 8c50d8612a58..9e4e180b0750 100644
--- a/net-analyzer/snort_inline/snort_inline-2.1.1.ebuild
+++ b/net-analyzer/snort_inline/snort_inline-2.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort_inline/snort_inline-2.1.1.ebuild,v 1.4 2004/07/01 20:19:11 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort_inline/snort_inline-2.1.1.ebuild,v 1.5 2004/07/05 12:20:02 eldad Exp $
inherit eutils
@@ -50,14 +50,20 @@ src_unpack() {
}
src_compile() {
- econf \
+ local myconf
+
+ if [ -r /usr/include/libipq/libipq.h ]; then
+ myconf="${myconf} --with-libipq-includes=/usr/include/libipq/"
+ fi
+
+ econf ${myconf} \
`use_with postgres postgresql` \
`use_with mysql` \
`use_with ssl openssl` \
--without-odbc \
- --without-oracle || die "bad ./configure"
+ --without-oracle || die "configure failed"
- emake || die "compile problem"
+ emake || die "make failed"
}
src_install() {