summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-01-26 21:28:49 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-01-26 21:28:49 +0000
commite493cbda8abd3e1ea1d5b312dd9f57d95a31a33a (patch)
tree471c09a04c8bd30568a05bdabdf3826bb939d14e /net-analyzer/rrdtool
parentnew: gltt library - use truetype fonts in opengl apps, needed for upcoming k3... (diff)
downloadgentoo-2-e493cbda8abd3e1ea1d5b312dd9f57d95a31a33a.tar.gz
gentoo-2-e493cbda8abd3e1ea1d5b312dd9f57d95a31a33a.tar.bz2
gentoo-2-e493cbda8abd3e1ea1d5b312dd9f57d95a31a33a.zip
added tcl support to a updated ebuild submitted by ceed@xrc.de (Christian Rubbert)
Diffstat (limited to 'net-analyzer/rrdtool')
-rw-r--r--net-analyzer/rrdtool/files/digest-rrdtool-1.0.331
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.0.33.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/net-analyzer/rrdtool/files/digest-rrdtool-1.0.33 b/net-analyzer/rrdtool/files/digest-rrdtool-1.0.33
new file mode 100644
index 000000000000..62c57bf2273d
--- /dev/null
+++ b/net-analyzer/rrdtool/files/digest-rrdtool-1.0.33
@@ -0,0 +1 @@
+MD5 54bb6daf131cdc4bbe2bcf005bf583a5 rrdtool-1.0.33.tar.gz 1118208
diff --git a/net-analyzer/rrdtool/rrdtool-1.0.33.ebuild b/net-analyzer/rrdtool/rrdtool-1.0.33.ebuild
new file mode 100644
index 000000000000..635c8ea434c6
--- /dev/null
+++ b/net-analyzer/rrdtool/rrdtool-1.0.33.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jerry Alexandratos <jerry@gentoo.org>
+# $HEADER $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A system to store and display time-series data"
+SRC_URI="http://ee-staff.ethz.ch/~oetiker/webtools/rrdtool/pub/${A}"
+HOMEPAGE="http://ee-staff.ethz.ca/~oetiker/webtools/rrdtool/"
+
+DEPEND="virtual/glibc sys-devel/perl
+ >=media-libs/libgd-1.8.3
+ tcl? ( dev-lang/tcl )"
+
+RDEPEND="virtual/glibc sys-devel/perl tcl? ( dev-lang/tcl )"
+
+src_compile() {
+
+ local myconf
+ use tcl && myconf="--with-tcllib=/usr/lib"
+
+ try ./configure --prefix=/opt/rrdtool ${myconf} --host=${CHOST} --with-perl-options='INSTALLMAN1DIR=${D}/usr/share/man/man1 INSTALLMAN3DIR=${D}/usr/share/man/man3'
+ try make
+}
+
+src_install () {
+ try make prefix=${D}/opt/rrdtool install
+ try make PREFIX=${D}/usr site-perl-install
+}