summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-12-21 17:53:14 +0000
committerPeter Volkov <pva@gentoo.org>2008-12-21 17:53:14 +0000
commitbe95e13468052035a108eed3e29938e6fb1365da (patch)
tree4d2242c9b15ffb1555d94b4ea3e77adb394f8e18 /net-analyzer/rrdtool
parentVersion bump. (diff)
downloadgentoo-2-be95e13468052035a108eed3e29938e6fb1365da.tar.gz
gentoo-2-be95e13468052035a108eed3e29938e6fb1365da.tar.bz2
gentoo-2-be95e13468052035a108eed3e29938e6fb1365da.zip
Version bump.
(Portage version: 2.2_rc17/cvs/Linux 2.6.26-openvz.git-89451f9 i686)
Diffstat (limited to 'net-analyzer/rrdtool')
-rw-r--r--net-analyzer/rrdtool/ChangeLog9
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.2.29.ebuild88
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.3.5.ebuild91
3 files changed, 187 insertions, 1 deletions
diff --git a/net-analyzer/rrdtool/ChangeLog b/net-analyzer/rrdtool/ChangeLog
index 58e20f086426..c9fb4638f287 100644
--- a/net-analyzer/rrdtool/ChangeLog
+++ b/net-analyzer/rrdtool/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/rrdtool
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/ChangeLog,v 1.165 2008/12/07 12:19:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/ChangeLog,v 1.166 2008/12/21 17:53:14 pva Exp $
+
+*rrdtool-1.3.5 (21 Dec 2008)
+*rrdtool-1.2.29 (21 Dec 2008)
+
+ 21 Dec 2008; Peter Volkov <pva@gentoo.org> +rrdtool-1.2.29.ebuild,
+ +rrdtool-1.3.5.ebuild:
+ Version bump.
07 Dec 2008; Mike Frysinger <vapier@gentoo.org> rrdtool-1.3.4.ebuild:
Add back s390 #228025.
diff --git a/net-analyzer/rrdtool/rrdtool-1.2.29.ebuild b/net-analyzer/rrdtool/rrdtool-1.2.29.ebuild
new file mode 100644
index 000000000000..62116c7d2f7d
--- /dev/null
+++ b/net-analyzer/rrdtool/rrdtool-1.2.29.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.2.29.ebuild,v 1.1 2008/12/21 17:53:14 pva Exp $
+
+inherit eutils flag-o-matic multilib perl-module
+
+DESCRIPTION="A system to store and display time-series data"
+HOMEPAGE="http://oss.oetiker.ch/rrdtool/"
+SRC_URI="http://oss.oetiker.ch/rrdtool/pub/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc perl python ruby rrdcgi tcl"
+
+RDEPEND="tcl? ( dev-lang/tcl )
+ >=sys-libs/zlib-1.2.1
+ >=media-libs/freetype-2.1.5
+ >=media-libs/libart_lgpl-2.3.16
+ >=media-libs/libpng-1.2.5
+ rrdcgi? ( >=dev-libs/cgilib-0.5 )
+ ruby? ( !dev-ruby/ruby-rrd )"
+
+DEPEND="${RDEPEND}
+ perl? ( dev-lang/perl )
+ python? ( dev-lang/python )
+ ruby? ( dev-lang/ruby )
+ sys-apps/gawk"
+
+TCLVER=""
+
+HTMLDOC_DIR="${PF}/html"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-1.2.15-newstyle-resize.patch"
+}
+
+pkg_setup() {
+ use perl && perl-module_pkg_setup
+}
+
+src_compile() {
+ filter-mfpmath sse
+ filter-flags -ffast-math
+
+ export RRDDOCDIR=/usr/share/doc/${PF}
+
+ econf $(use_enable rrdcgi) \
+ $(use_enable ruby) \
+ $(use_enable ruby ruby-site-install) \
+ $(use_enable perl) \
+ $(use_enable perl perl-site-install) \
+ $(use_enable tcl) \
+ $(use_with tcl tcllib /usr/$(get_libdir)) \
+ $(use_enable python) || die "econf failed."
+
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ if ! use doc ; then
+ rm -rf "${D}"/usr/share/doc/${PF}/{html,txt}
+ fi
+
+ use perl && fixlocalpod
+
+ dodoc CHANGES CONTRIBUTORS NEWS README THREADS TODO
+}
+
+pkg_preinst() {
+ use perl && perl-module_pkg_preinst
+}
+
+pkg_postinst() {
+ use perl && perl-module_pkg_postinst
+}
+
+pkg_prerm() {
+ use perl && perl-module_pkg_prerm
+}
+
+pkg_postrm() {
+ use perl && perl-module_pkg_postrm
+}
diff --git a/net-analyzer/rrdtool/rrdtool-1.3.5.ebuild b/net-analyzer/rrdtool/rrdtool-1.3.5.ebuild
new file mode 100644
index 000000000000..3b40449c4730
--- /dev/null
+++ b/net-analyzer/rrdtool/rrdtool-1.3.5.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.3.5.ebuild,v 1.1 2008/12/21 17:53:14 pva Exp $
+
+inherit eutils flag-o-matic multilib perl-module
+
+DESCRIPTION="A system to store and display time-series data"
+HOMEPAGE="http://oss.oetiker.ch/rrdtool/"
+SRC_URI="http://oss.oetiker.ch/rrdtool/pub/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc perl python ruby rrdcgi tcl"
+
+# This versions are minimal versions upstream tested with.
+RDEPEND="
+ >=media-libs/libpng-1.2.10
+ >=dev-libs/libxml2-2.6.31
+ >=x11-libs/cairo-1.4.6
+ >=dev-libs/glib-2.12.12
+ >=x11-libs/pango-1.17
+ tcl? ( dev-lang/tcl )
+ perl? ( dev-lang/perl )
+ python? ( dev-lang/python )
+ ruby? ( dev-lang/ruby
+ !dev-ruby/ruby-rrd )"
+
+DEPEND="${RDEPEND}
+ sys-apps/gawk"
+
+pkg_setup() {
+ if ! built_with_use x11-libs/cairo svg; then
+ eerror "${PN} requires x11-libs/cairo to be built with svg USE flag."
+ die "Rebuild x11-libs/cairo with svg USE flag enabled."
+ fi
+ use perl && perl-module_pkg_setup
+}
+
+src_compile() {
+ filter-flags -ffast-math
+
+ export RRDDOCDIR=/usr/share/doc/${PF}
+
+ econf $(use_enable rrdcgi) \
+ $(use_enable ruby) \
+ $(use_enable ruby ruby-site-install) \
+ $(use_enable perl) \
+ $(use_enable perl perl-site-install) \
+ $(use_enable tcl) \
+ $(use_with tcl tcllib /usr/$(get_libdir)) \
+ $(use_enable python)
+
+ emake || die "make failed"
+}
+
+src_install() {
+ # -j1 see bug #239101 for details
+ emake -j1 DESTDIR="${D}" install || die "make install failed"
+
+ if ! use doc ; then
+ rm -rf "${D}"/usr/share/doc/${PF}/{html,txt}
+ fi
+
+ use perl && fixlocalpod
+
+ dodoc CHANGES CONTRIBUTORS NEWS README THREADS TODO
+}
+
+pkg_preinst() {
+ use perl && perl-module_pkg_preinst
+}
+
+pkg_postinst() {
+ use perl && perl-module_pkg_postinst
+ ewarn "rrdtool dump 1.3 does emit completely legal xml. Basically this means that"
+ ewarn "it contains an xml header and a DOCTYPE definition. Unfortunately this"
+ ewarn "causes older versions of rrdtool restore to be unhappy."
+ ewarn
+ ewarn "To restore a new dump with ann old rrdtool restore version, either remove"
+ ewarn "the xml header and the doctype by hand (both on the first line of the dump)"
+ ewarn "or use rrdtool dump --no-header."
+}
+
+pkg_prerm() {
+ use perl && perl-module_pkg_prerm
+}
+
+pkg_postrm() {
+ use perl && perl-module_pkg_postrm
+}