summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-05-07 12:27:55 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-05-07 12:27:55 +0000
commitab11af89e2161e6539b6b3d2d9812a67907399fb (patch)
tree1c0438ae0952f6f3f293faa783cefbe45b92a477 /net-analyzer/rrdtool
parentStable on x86, fixes bug 90074. (diff)
downloadgentoo-2-ab11af89e2161e6539b6b3d2d9812a67907399fb.tar.gz
gentoo-2-ab11af89e2161e6539b6b3d2d9812a67907399fb.tar.bz2
gentoo-2-ab11af89e2161e6539b6b3d2d9812a67907399fb.zip
Add --disable-perl if USE=-perl; closes bug 91638.
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'net-analyzer/rrdtool')
-rw-r--r--net-analyzer/rrdtool/ChangeLog6
-rw-r--r--net-analyzer/rrdtool/Manifest6
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.2.0.ebuild6
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.2.1.ebuild8
4 files changed, 15 insertions, 11 deletions
diff --git a/net-analyzer/rrdtool/ChangeLog b/net-analyzer/rrdtool/ChangeLog
index 494bc1a1f0ce..176af9b12fdf 100644
--- a/net-analyzer/rrdtool/ChangeLog
+++ b/net-analyzer/rrdtool/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/rrdtool
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/ChangeLog,v 1.53 2005/05/03 23:04:43 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/ChangeLog,v 1.54 2005/05/07 12:27:55 ka0ttic Exp $
+
+ 07 May 2005; Aaron Walker <ka0ttic@gentoo.org> rrdtool-1.2.0.ebuild,
+ rrdtool-1.2.1.ebuild:
+ Add --disable-perl if USE=-perl; closes bug 91638.
*rrdtool-1.2.1 (03 May 2005)
diff --git a/net-analyzer/rrdtool/Manifest b/net-analyzer/rrdtool/Manifest
index a3cb494ec9bc..33c9f116a947 100644
--- a/net-analyzer/rrdtool/Manifest
+++ b/net-analyzer/rrdtool/Manifest
@@ -1,10 +1,10 @@
MD5 437558c61fe6b02611719beff44e9f12 rrdtool-1.0.49.ebuild 2729
MD5 177f6939c1ba72adbbd42b99ea93121f rrdtool-1.0.50.ebuild 2753
-MD5 95a9996ac7b6de4a5d3600a6c0ff59aa rrdtool-1.2.0.ebuild 2683
+MD5 06fe999dcc8736af84bcf86f6cd44781 rrdtool-1.2.0.ebuild 2699
MD5 a899bdbfc828fd8d3b6eccb20639b84b rrdtool-1.0.47.ebuild 2822
-MD5 5181a55310ab41254f98c1455fbfeb49 ChangeLog 8820
+MD5 2bcec7058843613ce826cd1e586ed4f0 ChangeLog 8969
MD5 1a739170238a1fae241a8a0df21462e9 metadata.xml 241
-MD5 709f2ace12d8ee2c050844b26c6f6132 rrdtool-1.2.1.ebuild 2683
+MD5 f6072ed8a8d08305cb4700ec485d6f04 rrdtool-1.2.1.ebuild 2689
MD5 fd937eb5e7f8eab72f05e74d1533ddab rrdtool-1.0.45-r2.ebuild 2624
MD5 cd1090ecb4ba89539e79667d88e4431c files/digest-rrdtool-1.0.47 67
MD5 5027f79618fbf229b145b204b1e595ce files/digest-rrdtool-1.0.49 67
diff --git a/net-analyzer/rrdtool/rrdtool-1.2.0.ebuild b/net-analyzer/rrdtool/rrdtool-1.2.0.ebuild
index 1bf982dea71f..a6532862e616 100644
--- a/net-analyzer/rrdtool/rrdtool-1.2.0.ebuild
+++ b/net-analyzer/rrdtool/rrdtool-1.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.2.0.ebuild,v 1.2 2005/05/03 23:04:43 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.2.0.ebuild,v 1.3 2005/05/07 12:27:55 ka0ttic Exp $
inherit perl-module flag-o-matic gnuconfig eutils
@@ -49,10 +49,10 @@ src_compile() {
&& myconf="${myconf} --with-tcllib=/usr/lib" \
|| myconf="${myconf} --without-tcllib"
- if use perl; then
+ if use perl ; then
econf ${myconf} --with-perl-options='PREFIX=/usr INSTALLDIRS=vendor DESTDIR=${D}' || die "econf failed"
else
- econf ${myconf} || die "econf failed"
+ econf ${myconf} --disable-perl || die "econf failed"
fi
make || die "make failed"
diff --git a/net-analyzer/rrdtool/rrdtool-1.2.1.ebuild b/net-analyzer/rrdtool/rrdtool-1.2.1.ebuild
index bdb1a5c2b3c1..f4a8c0ffb221 100644
--- a/net-analyzer/rrdtool/rrdtool-1.2.1.ebuild
+++ b/net-analyzer/rrdtool/rrdtool-1.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.2.1.ebuild,v 1.1 2005/05/03 23:04:43 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.2.1.ebuild,v 1.2 2005/05/07 12:27:55 ka0ttic Exp $
inherit perl-module flag-o-matic gnuconfig eutils
@@ -43,16 +43,16 @@ src_compile() {
filter-flags -ffast-math
local myconf
- myconf="${myconf} --datadir=/usr/share --enable-shared"
+ myconf="--datadir=/usr/share --enable-shared"
use tcltk \
&& myconf="${myconf} --with-tcllib=/usr/lib" \
|| myconf="${myconf} --without-tcllib"
- if use perl; then
+ if use perl ; then
econf ${myconf} --with-perl-options='PREFIX=/usr INSTALLDIRS=vendor DESTDIR=${D}' || die "econf failed"
else
- econf ${myconf} || die "econf failed"
+ econf ${myconf} --disable-perl || die "econf failed"
fi
make || die "make failed"