summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-01-31 19:35:07 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-01-31 19:35:07 +0000
commit05030d748bcba8af5072d2a7c360a49cf9c01069 (patch)
tree5be211ce2212c26c0de651f65b14fc3c54ee9ac9 /net-analyzer/rrdtool
parentppc/ppc64 stable wrt #387171 (diff)
downloadgentoo-2-05030d748bcba8af5072d2a7c360a49cf9c01069.tar.gz
gentoo-2-05030d748bcba8af5072d2a7c360a49cf9c01069.tar.bz2
gentoo-2-05030d748bcba8af5072d2a7c360a49cf9c01069.zip
old
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/rrdtool')
-rw-r--r--net-analyzer/rrdtool/ChangeLog6
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.0.50.ebuild119
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.3.8.ebuild98
3 files changed, 5 insertions, 218 deletions
diff --git a/net-analyzer/rrdtool/ChangeLog b/net-analyzer/rrdtool/ChangeLog
index caa9ec181b09..22f46ca2bc67 100644
--- a/net-analyzer/rrdtool/ChangeLog
+++ b/net-analyzer/rrdtool/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/rrdtool
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/ChangeLog,v 1.220 2012/01/31 19:33:29 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/ChangeLog,v 1.221 2012/01/31 19:35:07 ssuominen Exp $
+
+ 31 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> -rrdtool-1.0.50.ebuild,
+ -rrdtool-1.3.8.ebuild:
+ old
31 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> rrdtool-1.4.5-r1.ebuild:
ppc/ppc64 stable wrt #387171
diff --git a/net-analyzer/rrdtool/rrdtool-1.0.50.ebuild b/net-analyzer/rrdtool/rrdtool-1.0.50.ebuild
deleted file mode 100644
index 6e9e66f7c853..000000000000
--- a/net-analyzer/rrdtool/rrdtool-1.0.50.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.0.50.ebuild,v 1.7 2011/10/02 00:00:11 radhermit Exp $
-
-inherit perl-module flag-o-matic eutils
-
-DESCRIPTION="A system to store and display time-series data"
-HOMEPAGE="http://oss.oetiker.ch/rrdtool/"
-SRC_URI="ftp://ftp.bit.nl/mirror/rrdtool/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc sparc x86"
-IUSE="perl tcl"
-
-DEPEND="perl? ( dev-lang/perl )
- sys-apps/gawk
- >=media-libs/gd-1.8.3"
-RDEPEND="tcl? ( dev-lang/tcl )"
-
-TCL_VER=""
-
-pkg_setup() {
- use perl && perl-module_pkg_setup
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -e 's/^LTCOMPILE = $(LIBTOOL) --tag=CC --mode=compile $(CC)/& -prefer-pic/' -i src/Makefile.in
-
- if [[ ! $(grep '^LTCOMPILE = $(LIBTOOL) --tag=CC --mode=compile $(CC) -prefer-pic' src/Makefile.in) ]]; then
- die "Makefile.in sed failed"
- fi
-}
-
-src_compile() {
- filter-mfpmath sse
- filter-flags -ffast-math
-
- local myconf
- myconf="${myconf} --datadir=/usr/share --enable-shared"
-
- if use tcl ; then
- myconf="${myconf} --with-tcllib=/usr/lib"
- else
- myconf="${myconf} --without-tcllib"
- fi
-
- if use perl; then
- econf ${myconf} --with-perl-options='PREFIX=/usr INSTALLDIRS=vendor DESTDIR=${D}' || die "econf failed"
-
- # libraries without -fPIC? feh!
- for libdir in cgilib* gd* libpng* zlib*; do
- sed -i -e 's/^CFLAGS.*/& -fPIC/' ${libdir}/Makefile
- done
- else
- econf ${myconf} || die "econf failed"
- fi
-
- make || die "make failed"
-}
-
-src_install() {
- einstall || die
-
- # this package completely ignores mandir settings
-
- doman doc/*.1
- dohtml doc/*.html
- dodoc doc/*.pod
- dodoc doc/*.txt
-
- rm -rf "${D}"/usr/doc
- rm -rf "${D}"/usr/html
- rm -rf "${D}"/usr/man
- rm -rf "${D}"/usr/contrib
- rm -rf "${D}"/usr/examples
-
- insinto /usr/share/doc/${PF}/examples
- doins examples/*
- insinto /usr/share/doc/${PF}/contrib
- doins contrib/*
-
- if use perl ; then
- perlinfo
- mytargets="site-perl-install"
- perl-module_src_install || die
-
- # remove duplicate installation into /usr/lib/perl
- rm -Rf "${D}"/usr/lib/perl
- fi
-
- if use tcl ; then
-# mv ${S}/tcl/tclrrd.so ${S}/tcl/tclrrd${PV}.so
-# insinto /usr/lib/tcl${TCL_VER}/tclrrd${PV}
-# doins ${S}/tcl/tclrrd${PV}.so
- echo "package ifneeded Rrd ${PV} [list load [file join \$$dir .. tclrrd${PV}.so]]" \
- >> "${D}"/usr/lib/tcl${TCL_VER}/tclrrd${PV}/pkgIndex.tcl
- fi
-
- dodoc COPY* CONTR* README TODO
-}
-
-pkg_preinst() {
- use perl && perl-module_pkg_preinst
-}
-
-pkg_postinst() {
- use perl && perl-module_pkg_postinst
-}
-
-pkg_prerm() {
- use perl && perl-module_pkg_prerm
-}
-
-pkg_postrm() {
- use perl && perl-module_pkg_postrm
-}
diff --git a/net-analyzer/rrdtool/rrdtool-1.3.8.ebuild b/net-analyzer/rrdtool/rrdtool-1.3.8.ebuild
deleted file mode 100644
index 1b3cfbe41540..000000000000
--- a/net-analyzer/rrdtool/rrdtool-1.3.8.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.3.8.ebuild,v 1.14 2011/10/01 06:59:07 radhermit Exp $
-
-EAPI="2"
-
-inherit eutils flag-o-matic multilib perl-module
-
-DESCRIPTION="A system to store and display time-series data"
-HOMEPAGE="http://oss.oetiker.ch/rrdtool/"
-SRC_URI="http://oss.oetiker.ch/rrdtool/pub/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
-IUSE="doc nls perl python ruby rrdcgi tcl"
-
-# This versions are minimal versions upstream tested with.
-RDEPEND="
- >=media-libs/libpng-1.2.10
- >=dev-libs/libxml2-2.6.31
- >=x11-libs/cairo-1.4.6[svg]
- >=dev-libs/glib-2.12.12
- >=x11-libs/pango-1.17
- tcl? ( dev-lang/tcl )
- perl? ( dev-lang/perl )
- python? ( dev-lang/python )
- ruby? ( >=dev-lang/ruby-1.8.6_p287-r13 )"
-
-DEPEND="${RDEPEND}
- nls? ( >=dev-util/intltool-0.35
- sys-devel/gettext )
- dev-util/pkgconfig
- sys-apps/gawk"
-
-pkg_setup() {
- use perl && perl-module_pkg_setup
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-1.4.3-ruby-ldflags.patch"
-}
-
-src_configure() {
- filter-flags -ffast-math
-
- export RRDDOCDIR=/usr/share/doc/${PF}
-
- econf $(use_enable rrdcgi) \
- $(use_enable nls) \
- $(use_enable nls libintl) \
- $(use_enable ruby) \
- $(use_enable ruby ruby-site-install) \
- $(use_enable perl) \
- $(use_enable perl perl-site-install) \
- $(use_enable tcl) \
- $(use_with tcl tcllib /usr/$(get_libdir)) \
- $(use_enable python)
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
-
- if ! use doc ; then
- rm -rf "${D}"/usr/share/doc/${PF}/{html,txt}
- fi
-
- use perl && fixlocalpod
-
- dodoc CHANGES CONTRIBUTORS NEWS README THREADS TODO
-}
-
-pkg_preinst() {
- use perl && perl-module_pkg_preinst
-}
-
-pkg_postinst() {
- use perl && perl-module_pkg_postinst
- ewarn "rrdtool dump 1.3 does emit completely legal xml. Basically this means that"
- ewarn "it contains an xml header and a DOCTYPE definition. Unfortunately this"
- ewarn "causes older versions of rrdtool restore to be unhappy."
- ewarn
- ewarn "To restore a new dump with an old rrdtool restore version, either remove"
- ewarn "the xml header and the doctype by hand (both on the first line of the dump)"
- ewarn "or use rrdtool dump --no-header."
- ewarn
- ewarn "Note: rrdtool-1.3.x doesn't have any default font bundled. Thus if you've"
- ewarn "upgraded from rrdtool-1.2.x and don't have any font installed to make"
- ewarn "lables visible, please, install some font, e.g. media-fonts/dejavu."
-}
-
-pkg_prerm() {
- use perl && perl-module_pkg_prerm
-}
-
-pkg_postrm() {
- use perl && perl-module_pkg_postrm
-}