summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2008-04-12 18:42:37 +0000
committerCaleb Tennis <caleb@gentoo.org>2008-04-12 18:42:37 +0000
commit9c4cec076c6079c64f6840ece05006c0fe533b87 (patch)
tree82f85ffb77c3baddf0b0ff75fdb1179bc9cca15b /net-analyzer/pnp4nagios
parentFixed tools installation (bug #217313, and swap checks between int64 and fort... (diff)
downloadgentoo-2-9c4cec076c6079c64f6840ece05006c0fe533b87.tar.gz
gentoo-2-9c4cec076c6079c64f6840ece05006c0fe533b87.tar.bz2
gentoo-2-9c4cec076c6079c64f6840ece05006c0fe533b87.zip
Initial commit
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-analyzer/pnp4nagios')
-rw-r--r--net-analyzer/pnp4nagios/ChangeLog10
-rw-r--r--net-analyzer/pnp4nagios/Manifest4
-rw-r--r--net-analyzer/pnp4nagios/metadata.xml10
-rw-r--r--net-analyzer/pnp4nagios/pnp4nagios-0.4.7.ebuild30
4 files changed, 54 insertions, 0 deletions
diff --git a/net-analyzer/pnp4nagios/ChangeLog b/net-analyzer/pnp4nagios/ChangeLog
new file mode 100644
index 000000000000..31a8274d44c5
--- /dev/null
+++ b/net-analyzer/pnp4nagios/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-analyzer/pnp4nagios
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pnp4nagios/ChangeLog,v 1.1 2008/04/12 18:42:37 caleb Exp $
+
+*pnp4nagios-0.4.7 (12 Apr 2008)
+
+ 12 Apr 2008; Caleb Tennis <caleb@gentoo.org> +metadata.xml,
+ +pnp4nagios-0.4.7.ebuild:
+ Initial import
+
diff --git a/net-analyzer/pnp4nagios/Manifest b/net-analyzer/pnp4nagios/Manifest
new file mode 100644
index 000000000000..fadf08e0a775
--- /dev/null
+++ b/net-analyzer/pnp4nagios/Manifest
@@ -0,0 +1,4 @@
+DIST pnp-0.4.7.tar.gz 299261 RMD160 d1c8bc1a4b6a97e13ffb686d99dc41c333a0b4d9 SHA1 a326149d0a449c9c9af718c622d80a3b4c40f6e3 SHA256 34307d9e7a045b921403d98ea52149296ebf988de93834ad40e922d298ae703c
+EBUILD pnp4nagios-0.4.7.ebuild 757 RMD160 43782728ca2363ee8a6f91a9196e3599349f243e SHA1 a13d566d5e8aca9a1740200d2ad6a350ff215dfe SHA256 f8158891aad0c11703bc72eeb700765e3cd0f3ca3ff008fa21d02f5763e32285
+MISC ChangeLog 265 RMD160 746181a5593d3ecc1f7ad68183c6d40864d59f54 SHA1 7c37333f0795a399d856a805390b2b9878b6afee SHA256 5a0c4021423ab7a025f13df2652fecda4fdfd2524f26e5c197cf9cafecfaf431
+MISC metadata.xml 253 RMD160 4e50c93f565251de34e9e3a11855049e27003980 SHA1 1749d68550fe9c9cfc589ed8698a0540f5398b83 SHA256 d1c9e3db952314c276bfa0f4bfecd9a44965d23b88e2796e377bb84694d373b4
diff --git a/net-analyzer/pnp4nagios/metadata.xml b/net-analyzer/pnp4nagios/metadata.xml
new file mode 100644
index 000000000000..c4fdf08ad514
--- /dev/null
+++ b/net-analyzer/pnp4nagios/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>caleb@gentoo.org</email>
+ <name>Caleb Tennis</name>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/net-analyzer/pnp4nagios/pnp4nagios-0.4.7.ebuild b/net-analyzer/pnp4nagios/pnp4nagios-0.4.7.ebuild
new file mode 100644
index 000000000000..3684c3f5a710
--- /dev/null
+++ b/net-analyzer/pnp4nagios/pnp4nagios-0.4.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pnp4nagios/pnp4nagios-0.4.7.ebuild,v 1.1 2008/04/12 18:42:37 caleb Exp $
+
+MY_P=pnp-${PV}
+
+DESCRIPTION="A performance data analyzer for nagios"
+HOMEPAGE="http://www.pnp4nagios.org"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND=">=dev-lang/php-4.3
+ >=net-analyzer/rrdtool-1.2
+ net-analyzer/nagios-core"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ econf --prefix=/usr/nagios --datadir=/usr/nagios/share/pnp \
+ --sysconfdir=/usr/nagios/etc/pnp \
+ --with-perfdata-dir=/usr/nagios/share/perfdata || die "econf failed"
+ emake all || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" fullinstall || die "emake install failed"
+}