summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2011-07-30 21:07:54 +0000
committerPatrick Lauer <patrick@gentoo.org>2011-07-30 21:07:54 +0000
commite7060de099401e0e8e05db263cec9d48288c175c (patch)
treea4dbff74fa24faf5196f454152a4dcc43c1ce49e /net-analyzer/pmacct
parentInitial import. (diff)
downloadgentoo-2-e7060de099401e0e8e05db263cec9d48288c175c.tar.gz
gentoo-2-e7060de099401e0e8e05db263cec9d48288c175c.tar.bz2
gentoo-2-e7060de099401e0e8e05db263cec9d48288c175c.zip
Config file location fix for #354649
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/pmacct')
-rw-r--r--net-analyzer/pmacct/ChangeLog9
-rw-r--r--net-analyzer/pmacct/pmacct-0.12.5-r1.ebuild62
2 files changed, 69 insertions, 2 deletions
diff --git a/net-analyzer/pmacct/ChangeLog b/net-analyzer/pmacct/ChangeLog
index 2fe5b95db45a..94c8fae4a2b2 100644
--- a/net-analyzer/pmacct/ChangeLog
+++ b/net-analyzer/pmacct/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/pmacct
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/ChangeLog,v 1.73 2010/12/29 16:57:29 jer Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/ChangeLog,v 1.74 2011/07/30 21:07:54 patrick Exp $
+
+*pmacct-0.12.5-r1 (30 Jul 2011)
+
+ 30 Jul 2011; Patrick Lauer <patrick@gentoo.org> +pmacct-0.12.5-r1.ebuild:
+ Config file location fix for #354649
*pmacct-0.12.5 (29 Dec 2010)
diff --git a/net-analyzer/pmacct/pmacct-0.12.5-r1.ebuild b/net-analyzer/pmacct/pmacct-0.12.5-r1.ebuild
new file mode 100644
index 000000000000..1ad511033eba
--- /dev/null
+++ b/net-analyzer/pmacct/pmacct-0.12.5-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/pmacct-0.12.5-r1.ebuild,v 1.1 2011/07/30 21:07:54 patrick Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A network tool to gather IP traffic information"
+HOMEPAGE="http://www.pmacct.net/"
+SRC_URI="http://www.pmacct.net/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="64bit debug ipv6 mysql postgres sqlite threads ulog"
+
+RDEPEND="net-libs/libpcap
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql-base )
+ sqlite? ( =dev-db/sqlite-3* )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-0.12.0-gentoo.patch \
+ "${FILESDIR}"/${PN}-0.12.5-sin6_addr.patch
+}
+
+src_configure() {
+ tc-export CC
+ econf \
+ $(use_enable 64bit) \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_enable mysql) \
+ $(use_enable postgres pgsql) \
+ $(use_enable sqlite sqlite3) \
+ $(use_enable threads) \
+ $(use_enable ulog) \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog CONFIG-KEYS EXAMPLES FAQS KNOWN-BUGS README UPGRADE \
+ docs/SIGNALS docs/PLUGINS docs/INTERNALS TODO TOOLS \
+ || die "dodoc failed"
+
+ for dirname in examples sql; do
+ docinto ${dirname}
+ dodoc ${dirname}/* || die "dodoc ${dirname} failed"
+ done
+
+ newinitd "${FILESDIR}"/pmacctd-init.d pmacctd || die "newinitd failed"
+ newconfd "${FILESDIR}"/pmacctd-conf.d pmacctd || die "newconfd failed"
+
+ mkdir -p "${D}"/etc/pmacctd
+ insinto /etc/pmacctd
+ newins "${S}/examples/pmacctd-imt.conf.example" pmacctd.conf || \
+ die "newins failed"
+}