summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-06-01 09:48:41 +0000
committerPeter Volkov <pva@gentoo.org>2009-06-01 09:48:41 +0000
commitb9a6deca64527318f804de80f1203053ead582b2 (patch)
tree0c4d17bf57805d8a3d051d134cfb55b10c691d26 /net-analyzer/pmacct
parentRemove old. (diff)
downloadgentoo-2-b9a6deca64527318f804de80f1203053ead582b2.tar.gz
gentoo-2-b9a6deca64527318f804de80f1203053ead582b2.tar.bz2
gentoo-2-b9a6deca64527318f804de80f1203053ead582b2.zip
Remove old. Renamed pmacctd-init.d.1 into pmacctd-init.d
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'net-analyzer/pmacct')
-rw-r--r--net-analyzer/pmacct/ChangeLog7
-rw-r--r--net-analyzer/pmacct/files/pmacctd-init.d13
-rw-r--r--net-analyzer/pmacct/files/pmacctd-init.d.129
-rw-r--r--net-analyzer/pmacct/pmacct-0.11.3.ebuild56
-rw-r--r--net-analyzer/pmacct/pmacct-0.11.4.ebuild56
-rw-r--r--net-analyzer/pmacct/pmacct-0.11.5-r1.ebuild4
6 files changed, 14 insertions, 151 deletions
diff --git a/net-analyzer/pmacct/ChangeLog b/net-analyzer/pmacct/ChangeLog
index 655f6aaa3221..a62215f71fb3 100644
--- a/net-analyzer/pmacct/ChangeLog
+++ b/net-analyzer/pmacct/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/pmacct
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/ChangeLog,v 1.60 2009/05/30 18:20:13 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/ChangeLog,v 1.61 2009/06/01 09:48:36 pva Exp $
+
+ 01 Jun 2009; Peter Volkov <pva@gentoo.org> -pmacct-0.11.3.ebuild,
+ -pmacct-0.11.4.ebuild, pmacct-0.11.5-r1.ebuild, files/pmacctd-init.d,
+ -files/pmacctd-init.d.1:
+ Remove old. Renamed pmacctd-init.d.1 into pmacctd-init.d
30 May 2009; nixnut <nixnut@gentoo.org> pmacct-0.11.5-r1.ebuild:
ppc stable #271104
diff --git a/net-analyzer/pmacct/files/pmacctd-init.d b/net-analyzer/pmacct/files/pmacctd-init.d
index e24b097c1767..987e9c603a2a 100644
--- a/net-analyzer/pmacct/files/pmacctd-init.d
+++ b/net-analyzer/pmacct/files/pmacctd-init.d
@@ -1,13 +1,13 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/files/pmacctd-init.d,v 1.3 2007/03/28 21:17:57 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/files/pmacctd-init.d,v 1.4 2009/06/01 09:48:41 pva Exp $
depend() {
need net
}
-chekconfig() {
+checkconfig() {
if [ ! -e /etc/pmacctd.conf ] ; then
eerror "You need an /etc/pmacctd.conf file to run pmacctd"
return 1
@@ -15,16 +15,15 @@ chekconfig() {
}
start() {
- chekconfig || return 1
+ checkconfig || return 1
ebegin "Starting pmacctd"
- start-stop-daemon --start --exec /usr/sbin/pmacctd \
- -- -D -f /etc/pmacctd.conf ${OPTS}
+ start-stop-daemon --start --pidfile /var/run/pmacctd.pid --exec /usr/sbin/pmacctd \
+ -- -D -f /etc/pmacctd.conf -F /var/run/pmacctd.pid ${OPTS}
eend $?
}
stop() {
ebegin "Stopping pmacctd"
- start-stop-daemon --stop --exec /usr/sbin/pmacctd
+ start-stop-daemon --stop --pidfile /var/run/pmacctd.pid --exec /usr/sbin/pmacctd
eend $?
}
-
diff --git a/net-analyzer/pmacct/files/pmacctd-init.d.1 b/net-analyzer/pmacct/files/pmacctd-init.d.1
deleted file mode 100644
index fc75c64a8e9d..000000000000
--- a/net-analyzer/pmacct/files/pmacctd-init.d.1
+++ /dev/null
@@ -1,29 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/files/pmacctd-init.d.1,v 1.1 2008/11/16 16:00:25 pva Exp $
-
-depend() {
- need net
-}
-
-checkconfig() {
- if [ ! -e /etc/pmacctd.conf ] ; then
- eerror "You need an /etc/pmacctd.conf file to run pmacctd"
- return 1
- fi
-}
-
-start() {
- checkconfig || return 1
- ebegin "Starting pmacctd"
- start-stop-daemon --start --pidfile /var/run/pmacctd.pid --exec /usr/sbin/pmacctd \
- -- -D -f /etc/pmacctd.conf -F /var/run/pmacctd.pid ${OPTS}
- eend $?
-}
-
-stop() {
- ebegin "Stopping pmacctd"
- start-stop-daemon --stop --pidfile /var/run/pmacctd.pid --exec /usr/sbin/pmacctd
- eend $?
-}
diff --git a/net-analyzer/pmacct/pmacct-0.11.3.ebuild b/net-analyzer/pmacct/pmacct-0.11.3.ebuild
deleted file mode 100644
index f7d83240c4f4..000000000000
--- a/net-analyzer/pmacct/pmacct-0.11.3.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/pmacct-0.11.3.ebuild,v 1.6 2009/05/24 19:11:20 pva Exp $
-
-DESCRIPTION="A network tool to gather ip traffic informations"
-HOMEPAGE="http://www.pmacct.net/"
-SRC_URI="http://www.pmacct.net/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ppc x86"
-IUSE="64bit debug ipv6 mmap mysql postgres sqlite"
-
-RDEPEND="net-libs/libpcap
- mysql? ( virtual/mysql )
- postgres? ( virtual/postgresql-base )
- sqlite? ( =dev-db/sqlite-3* )"
-DEPEND="${RDEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i "s|\(CFLAGS=\).*$|\1\"${CFLAGS}\"|g" configure || die "sed failed"
-}
-
-src_compile() {
- econf \
- $(use_enable mysql) \
- $(use_enable postgres pgsql) \
- $(use_enable mmap) \
- $(use_enable ipv6) \
- $(use_enable debug) \
- $(use_enable 64bit) \
- $(use_enable sqlite sqlite3) \
- || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
- dodoc README EXAMPLES KNOWN-BUGS CONFIG-KEYS FAQS ChangeLog docs/SIGNALS \
- docs/PLUGINS docs/INTERNALS TODO TOOLS || die "dodoc failed"
-
- for dirname in examples sql; do
- docinto ${dirname}
- dodoc ${dirname}/* || die "dodoc ${dirname} failed"
- done
-
- newinitd "${FILESDIR}"/pmacctd-init.d pmacctd || die "newinitd failed"
- newconfd "${FILESDIR}"/pmacctd-conf.d pmacctd || die "newconfd failed"
-
- insinto /etc
- newins "${S}"/examples/pmacctd-imt.conf.example pmacctd.conf.example || \
- die "newins failed"
-}
diff --git a/net-analyzer/pmacct/pmacct-0.11.4.ebuild b/net-analyzer/pmacct/pmacct-0.11.4.ebuild
deleted file mode 100644
index 605436ae7e6d..000000000000
--- a/net-analyzer/pmacct/pmacct-0.11.4.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/pmacct-0.11.4.ebuild,v 1.5 2009/05/24 19:11:20 pva Exp $
-
-DESCRIPTION="A network tool to gather ip traffic informations"
-HOMEPAGE="http://www.pmacct.net/"
-SRC_URI="http://www.pmacct.net/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc x86"
-IUSE="64bit debug ipv6 mmap mysql postgres sqlite"
-
-RDEPEND="net-libs/libpcap
- mysql? ( virtual/mysql )
- postgres? ( virtual/postgresql-base )
- sqlite? ( =dev-db/sqlite-3* )"
-DEPEND="${RDEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i "s|\(CFLAGS=\).*$|\1\"${CFLAGS}\"|g" configure || die "sed failed"
-}
-
-src_compile() {
- econf \
- $(use_enable mysql) \
- $(use_enable postgres pgsql) \
- $(use_enable mmap) \
- $(use_enable ipv6) \
- $(use_enable debug) \
- $(use_enable 64bit) \
- $(use_enable sqlite sqlite3) \
- || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
- dodoc README EXAMPLES KNOWN-BUGS CONFIG-KEYS FAQS ChangeLog docs/SIGNALS \
- docs/PLUGINS docs/INTERNALS TODO TOOLS || die "dodoc failed"
-
- for dirname in examples sql; do
- docinto ${dirname}
- dodoc ${dirname}/* || die "dodoc ${dirname} failed"
- done
-
- newinitd "${FILESDIR}"/pmacctd-init.d pmacctd || die "newinitd failed"
- newconfd "${FILESDIR}"/pmacctd-conf.d pmacctd || die "newconfd failed"
-
- insinto /etc
- newins "${S}"/examples/pmacctd-imt.conf.example pmacctd.conf.example || \
- die "newins failed"
-}
diff --git a/net-analyzer/pmacct/pmacct-0.11.5-r1.ebuild b/net-analyzer/pmacct/pmacct-0.11.5-r1.ebuild
index 972abd2d9eff..02112eb66528 100644
--- a/net-analyzer/pmacct/pmacct-0.11.5-r1.ebuild
+++ b/net-analyzer/pmacct/pmacct-0.11.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/pmacct-0.11.5-r1.ebuild,v 1.5 2009/05/30 18:20:13 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/pmacct-0.11.5-r1.ebuild,v 1.6 2009/06/01 09:48:36 pva Exp $
DESCRIPTION="A network tool to gather ip traffic informations"
HOMEPAGE="http://www.pmacct.net/"
@@ -46,7 +46,7 @@ src_install() {
dodoc ${dirname}/* || die "dodoc ${dirname} failed"
done
- newinitd "${FILESDIR}"/pmacctd-init.d.1 pmacctd || die "newinitd failed"
+ newinitd "${FILESDIR}"/pmacctd-init.d pmacctd || die "newinitd failed"
newconfd "${FILESDIR}"/pmacctd-conf.d pmacctd || die "newconfd failed"
insinto /etc