summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2006-04-18 22:37:21 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2006-04-18 22:37:21 +0000
commita5ac09afb8f34c982fd6ca56d7ad588c26732108 (patch)
tree75676f8df5f142587a5f07c88d0b3e7905f8c1b0 /net-analyzer/pmacct
parentremove module when shutting down #130220 (diff)
downloadgentoo-2-a5ac09afb8f34c982fd6ca56d7ad588c26732108.tar.gz
gentoo-2-a5ac09afb8f34c982fd6ca56d7ad588c26732108.tar.bz2
gentoo-2-a5ac09afb8f34c982fd6ca56d7ad588c26732108.zip
0.10.1 version bump. New HOMEPAGE at pmacct.net.
(Portage version: 2.0.54)
Diffstat (limited to 'net-analyzer/pmacct')
-rw-r--r--net-analyzer/pmacct/ChangeLog7
-rw-r--r--net-analyzer/pmacct/Manifest2
-rw-r--r--net-analyzer/pmacct/files/digest-pmacct-0.10.11
-rw-r--r--net-analyzer/pmacct/pmacct-0.10.1.ebuild54
4 files changed, 63 insertions, 1 deletions
diff --git a/net-analyzer/pmacct/ChangeLog b/net-analyzer/pmacct/ChangeLog
index 3750a3272abb..762955f2d6bd 100644
--- a/net-analyzer/pmacct/ChangeLog
+++ b/net-analyzer/pmacct/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/pmacct
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/ChangeLog,v 1.39 2006/03/22 21:15:23 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/ChangeLog,v 1.40 2006/04/18 22:37:21 vanquirius Exp $
+
+*pmacct-0.10.1 (18 Apr 2006)
+
+ 18 Apr 2006; Marcelo Goes <vanquirius@gentoo.org> +pmacct-0.10.1.ebuild:
+ 0.10.1 version bump. New HOMEPAGE at pmacct.net.
*pmacct-0.10.0 (22 Mar 2006)
diff --git a/net-analyzer/pmacct/Manifest b/net-analyzer/pmacct/Manifest
index 344ce3f868aa..0955ee143550 100644
--- a/net-analyzer/pmacct/Manifest
+++ b/net-analyzer/pmacct/Manifest
@@ -1,8 +1,10 @@
MD5 b5550dc8ecb3616b6070fb8158d6542c ChangeLog 6262
MD5 78229027b52dbd752752b7ea8ceb2726 files/digest-pmacct-0.10.0 65
+MD5 bc18932fa11b6f71c83c45d0062991d6 files/digest-pmacct-0.10.1 65
MD5 51edce191b704cca9a48ef7745397aa1 files/digest-pmacct-0.9.5 64
MD5 50333f1c79a80df31266ce7235cbf36c files/pmacctd-conf.d 313
MD5 2afa8e97312b03f3e119c0befed9e7d3 files/pmacctd-init.d 869
MD5 808a9a788ae7955af0a3c442cafee866 metadata.xml 243
MD5 7a2e727fb473f1f1e0eb54e8df159c47 pmacct-0.10.0.ebuild 1536
+MD5 961854c65614ecc4daf8f175aedef12e pmacct-0.10.1.ebuild 1510
MD5 89257334829a6648afec1a8b3fd3d30e pmacct-0.9.5.ebuild 1560
diff --git a/net-analyzer/pmacct/files/digest-pmacct-0.10.1 b/net-analyzer/pmacct/files/digest-pmacct-0.10.1
new file mode 100644
index 000000000000..2d81d93c09cd
--- /dev/null
+++ b/net-analyzer/pmacct/files/digest-pmacct-0.10.1
@@ -0,0 +1 @@
+MD5 6a175115a086554a29e218c7db8039c8 pmacct-0.10.1.tar.gz 343794
diff --git a/net-analyzer/pmacct/pmacct-0.10.1.ebuild b/net-analyzer/pmacct/pmacct-0.10.1.ebuild
new file mode 100644
index 000000000000..70fd2d199f43
--- /dev/null
+++ b/net-analyzer/pmacct/pmacct-0.10.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/pmacct-0.10.1.ebuild,v 1.1 2006/04/18 22:37:21 vanquirius Exp $
+
+DESCRIPTION="A network tool to gather ip traffic informations"
+HOMEPAGE="http://www.pmacct.net/"
+SRC_URI="http://www.pmacct.net/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="64bit debug ipv6 mmap mysql postgres"
+
+RDEPEND="net-libs/libpcap
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-db/postgresql )"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i "s|\(CFLAGS=\).*$|\1\"${CFLAGS}\"|g" configure || die "sed failed"
+}
+
+src_compile() {
+ econf \
+ $(use_enable mysql) \
+ $(use_enable postgres pgsql) \
+ $(use_enable mmap) \
+ $(use_enable ipv6) \
+ $(use_enable debug) \
+ $(use_enable 64bit) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc README EXAMPLES KNOWN-BUGS CONFIG-KEYS FAQS ChangeLog docs/SIGNALS \
+ docs/PLUGINS docs/INTERNALS TODO TOOLS || die "dodoc failed"
+
+ for dirname in examples sql; do
+ docinto ${dirname}
+ dodoc ${dirname}/* || die "dodoc ${dirname} failed"
+ done
+
+ newinitd "${FILESDIR}"/pmacctd-init.d pmacctd || die "newinitd failed"
+ newconfd "${FILESDIR}"/pmacctd-conf.d pmacctd || die "newconfd failed"
+
+ insinto /etc
+ newins "${S}"/examples/pmacctd-imt.conf.example pmacctd.conf.example || \
+ die "newins failed"
+}