summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2006-11-17 20:49:15 +0000
committerCédric Krier <cedk@gentoo.org>2006-11-17 20:49:15 +0000
commitdffc80dfa2123cf139acd2bdae4e74d025ff2b45 (patch)
tree44875480310d6415c0913a4e0655bb561c317dee /net-analyzer/ntop
parentFix keyword sobstitution. (diff)
downloadgentoo-2-dffc80dfa2123cf139acd2bdae4e74d025ff2b45.tar.gz
gentoo-2-dffc80dfa2123cf139acd2bdae4e74d025ff2b45.tar.bz2
gentoo-2-dffc80dfa2123cf139acd2bdae4e74d025ff2b45.zip
Add RDEPEND for media-gfx/graphviz
(Portage version: 2.1.1-r1)
Diffstat (limited to 'net-analyzer/ntop')
-rw-r--r--net-analyzer/ntop/ChangeLog7
-rw-r--r--net-analyzer/ntop/files/digest-ntop-3.2-r23
-rw-r--r--net-analyzer/ntop/ntop-3.2-r2.ebuild106
3 files changed, 115 insertions, 1 deletions
diff --git a/net-analyzer/ntop/ChangeLog b/net-analyzer/ntop/ChangeLog
index f2015c7c98f0..dc845fc31eb3 100644
--- a/net-analyzer/ntop/ChangeLog
+++ b/net-analyzer/ntop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/ntop
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ChangeLog,v 1.46 2006/02/15 23:41:37 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ChangeLog,v 1.47 2006/11/17 20:49:15 cedk Exp $
+
+*ntop-3.2-r2 (17 Nov 2006)
+
+ 17 Nov 2006; Cedric Krier <cedk@gentoo.org> +ntop-3.2-r2.ebuild:
+ Add RDEPEND for media-gfx/graphviz for bug #150739
15 Feb 2006; Markus Ullmann <jokey@gentoo.org> ntop-3.0.ebuild,
ntop-3.1.ebuild, ntop-3.2-r1.ebuild:
diff --git a/net-analyzer/ntop/files/digest-ntop-3.2-r2 b/net-analyzer/ntop/files/digest-ntop-3.2-r2
new file mode 100644
index 000000000000..cca3145681a3
--- /dev/null
+++ b/net-analyzer/ntop/files/digest-ntop-3.2-r2
@@ -0,0 +1,3 @@
+MD5 cd29a876b34a7dd76555e9acd8f160bb ntop-3.2.tgz 3910593
+RMD160 18ea4b535826e6d7bdf56c071c271869653cba8d ntop-3.2.tgz 3910593
+SHA256 5b639dbcb3c8bf77824cf8aaed168864f69730b2ef41dc68d2db22b205c586d8 ntop-3.2.tgz 3910593
diff --git a/net-analyzer/ntop/ntop-3.2-r2.ebuild b/net-analyzer/ntop/ntop-3.2-r2.ebuild
new file mode 100644
index 000000000000..d4c4a677f660
--- /dev/null
+++ b/net-analyzer/ntop/ntop-3.2-r2.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-3.2-r2.ebuild,v 1.1 2006/11/17 20:49:15 cedk Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="tool that shows network usage like top"
+HOMEPAGE="http://www.ntop.org/ntop.html"
+SRC_URI="mirror://sourceforge/ntop/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ipv6 nls snmp ssl tcpd zlib"
+
+DEPEND="sys-apps/gawk
+ >=sys-devel/libtool-1.4
+ >=sys-libs/gdbm-1.8.0
+ net-libs/libpcap
+ >=media-libs/gd-2.0.22
+ >=media-libs/libpng-1.2.5
+ snmp? ( net-analyzer/net-snmp )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6-r4 )
+ zlib? ( sys-libs/zlib )"
+
+# Needed by xmldumpPlugin - couldn't get it to work
+# dev-libs/gdome2
+# >=dev-libs/glib-2"
+
+RDEPEND="${DEPEND}
+ media-gfx/graphviz"
+
+pkg_setup() {
+ if use snmp ; then
+ ewarn "snmp plugin is under development and upstream does not recommend"
+ ewarn "it for usage in production environment."
+ if ! use ipv6 ; then
+ echo
+ eerror "snmp plugin has compilation problems without ipv6 support."
+ eerror "For additional information see bug #121497."
+ die "snmp without ipv6 is broken"
+ else
+ if ! built_with_use net-analyzer/net-snmp ipv6 ; then
+ echo
+ eerror "You have both ipv6 and snmp enabled."
+ eerror "This require ipv6 support in net-analyzer/net-snmp."
+ eerror "However, net-analyzer/net-snmp was compiled with ipv6 flag disabled."
+ eerror "Please, reemrege net-analyzer/net-snmp with USE=\"ipv6\"."
+ die "net-analyzer/net-snmp was build without ipv6."
+ fi
+ fi
+ fi
+ enewgroup ntop
+ enewuser ntop -1 -1 /var/lib/ntop ntop
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/globals-core.c.diff
+ epatch "${FILESDIR}"/${P}-build.patch
+ epatch "${FILESDIR}"/${P}-snmp.patch
+ eautoreconf
+
+ sed -i \
+ -e "s@/usr/local/bin/dot@/usr/bin/dot@" report.c || die "sed failed"
+}
+
+src_compile() {
+ # force disable xmldumpPlugin
+ export \
+ ac_cv_header_glib_h=no \
+ ac_cv_header_glibconfig_h=no \
+ ac_cv_header_gdome_h=no \
+ ac_cv_lib_glib_g_date_julian=no \
+ ac_cv_lib_xml2_xmlCheckVersion=no \
+ ac_cv_lib_gdome_gdome_di_saveDocToFile=no
+
+ econf \
+ $(use_enable ipv6) \
+ $(use_enable nls i18n) \
+ $(use_enable snmp) \
+ $(use_with ssl) $(use_enable ssl sslv3) $(use_enable sslwatchdog) \
+ $(use_with tcpd) \
+ $(use_with zlib) \
+ || die "configure problem"
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install problem"
+
+ keepdir /var/lib/ntop
+
+ dodoc AUTHORS CONTENTS ChangeLog MANIFESTO NEWS
+ dodoc PORTING README SUPPORT_NTOP.txt THANKS $(find docs -type f)
+
+ newinitd "${FILESDIR}"/ntop-init ntop
+ newconfd "${FILESDIR}"/ntop-confd ntop
+}
+
+pkg_postinst() {
+ fowners ntop:ntop /var/lib/ntop
+ fperms 750 /var/lib/ntop
+}