summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2010-09-24 19:39:45 +0000
committerAlin Năstac <mrness@gentoo.org>2010-09-24 19:39:45 +0000
commit877aff2b69d6d44bdfdf25977752955c34418704 (patch)
treed53d6fafa7da0fd411e633adc33a245c9a75e2c0 /net-analyzer/ntop
parentStable on amd64 wrt bug #338113 (diff)
downloadgentoo-2-877aff2b69d6d44bdfdf25977752955c34418704.tar.gz
gentoo-2-877aff2b69d6d44bdfdf25977752955c34418704.tar.bz2
gentoo-2-877aff2b69d6d44bdfdf25977752955c34418704.zip
Version bump (#329577).
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/ntop')
-rw-r--r--net-analyzer/ntop/ChangeLog8
-rw-r--r--net-analyzer/ntop/files/ntop-4.0.1-gentoo.patch246
-rw-r--r--net-analyzer/ntop/ntop-4.0.1.ebuild126
3 files changed, 379 insertions, 1 deletions
diff --git a/net-analyzer/ntop/ChangeLog b/net-analyzer/ntop/ChangeLog
index 1bc8f31b623b..47870d40d255 100644
--- a/net-analyzer/ntop/ChangeLog
+++ b/net-analyzer/ntop/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/ntop
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ChangeLog,v 1.93 2010/01/31 13:37:03 rich0 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ChangeLog,v 1.94 2010/09/24 19:39:45 mrness Exp $
+
+*ntop-4.0.1 (24 Sep 2010)
+
+ 24 Sep 2010; Alin Năstac <mrness@gentoo.org> +ntop-4.0.1.ebuild,
+ +files/ntop-4.0.1-gentoo.patch:
+ Version bump (#329577).
31 Jan 2010; Richard Freeman <rich0@gentoo.org> ntop-3.3.10-r2.ebuild:
amd64 stable - 281956
diff --git a/net-analyzer/ntop/files/ntop-4.0.1-gentoo.patch b/net-analyzer/ntop/files/ntop-4.0.1-gentoo.patch
new file mode 100644
index 000000000000..a68c664d2994
--- /dev/null
+++ b/net-analyzer/ntop/files/ntop-4.0.1-gentoo.patch
@@ -0,0 +1,246 @@
+diff -Nru ntop-4.0.1.orig/configure.in ntop-4.0.1/configure.in
+--- ntop-4.0.1.orig/configure.in 2010-08-07 00:44:41.000000000 +0200
++++ ntop-4.0.1/configure.in 2010-09-24 01:42:46.000000000 +0200
+@@ -57,6 +57,7 @@
+ dnl>
+ umask 002
+ AM_CONFIG_HEADER(config.h)
++AM_MAINTAINER_MODE
+
+ HAS_ERROR=
+ HAS_WARNING=
+@@ -497,11 +498,6 @@
+ LOCALEDIR="/usr/lib/locale"
+ fi
+
+-dnl> Add /usr/local/ /opt/local
+-CFLAGS="${CFLAGS} -I/usr/local/include -I/opt/local/include"
+-CPPFLAGS="${CPPFLAGS} -I/usr/local/include -I/opt/local/include"
+-LDFLAGS="${LDFLAGS} -L/usr/local/lib -L/opt/local/lib"
+-
+ PWD=`pwd`
+
+ echo
+@@ -1809,39 +1805,17 @@
+
+ if test ".${ac_cv_lib_GeoIP_GeoIP_record_by_ipnum}" = ".yes"; then
+ LIBS="$LIBS -lGeoIP"
+-
+-if test -f "GeoLiteCity.dat"; then
+- echo "GeoLiteCity.dat already present"
+-else
+- if test -f "3rd_party/GeoLiteCity.dat.gz"; then
+- cp 3rd_party/GeoLiteCity.dat.gz .
+- else
+- wget http://www.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz
+- fi
+-
+- gunzip GeoLiteCity.dat.gz
+-fi
+-
+-dnl> --------
+-
+-if test -f "GeoIPASNum.dat"; then
+- echo "GeoIPASNum.dat already present"
+-else
+- if test -f "3rd_party/GeoIPASNum.dat.gz"; then
+- cp 3rd_party/GeoIPASNum.dat.gz .
+- else
+- wget http://www.maxmind.com/download/geoip/database/asnum/GeoIPASNum.dat.gz
+- fi
+-
+- gunzip GeoIPASNum.dat.gz
+-fi
+ else
+ AC_MSG_RESULT(Please install GeoIP (http://www.maxmind.com/))
+ exit 1
+ fi
+
+-cp "3rd_party/oui.txt.gz" .
+-cp "3rd_party/specialMAC.txt.gz" .
++gunzip 3rd_party/GeoIPASNum.dat.gz &&
++gunzip 3rd_party/GeoLiteCity.dat.gz &&
++mv "3rd_party/etter.finger.os.gz" . &&
++mv "3rd_party/oui.txt.gz" . &&
++mv "3rd_party/specialMAC.txt.gz" . ||
++ exit 1
+
+ if test -d ./configureextra; then
+
+@@ -2002,7 +1976,6 @@
+ AC_SUBST(SO_VERSION_PATCH)
+ AC_SUBST(RRD_LIB)
+ AC_SUBST(RRD_INC)
+-AC_SUBST(GEO_DIR)
+ AC_SUBST(GETOPT_H)
+ AC_SUBST(GETOPT_C)
+
+diff -Nru ntop-4.0.1.orig/globals-core.c ntop-4.0.1/globals-core.c
+--- ntop-4.0.1.orig/globals-core.c 2010-04-25 14:52:28.000000000 +0200
++++ ntop-4.0.1/globals-core.c 2010-09-24 01:42:46.000000000 +0200
+@@ -372,7 +372,7 @@
+ _mtuSize[DLT_ATM_RFC1483] = 9180 /* LLC/SNAP encapsulated atm */;
+ _headerSize[DLT_ATM_RFC1483] = 0;
+
+- /* _mtuSize[DLT_RAW] = ? raw IP */
++ _mtuSize[DLT_RAW] = 1500 /* raw IP */;
+ _headerSize[DLT_RAW] = 0;
+
+ /* Others defined in bpf.h at tcpdump.org as of the resync - it would be NICE
+@@ -491,19 +491,18 @@
+ struct stat statbuf;
+
+ /* Initialize GeoIP databases */
+- for(i=0; myGlobals.configFileDirs[i] != NULL; i++) {
++ {
+ char path[256];
+
+ safe_snprintf(__FILE__, __LINE__, path, sizeof(path),
+ "%s%c%s",
+- myGlobals.configFileDirs[i],
++ myGlobals.dbPath,
+ CONST_PATH_SEP, GEO_IP_FILE);
+ revertSlashIfWIN32(path, 0);
+
+ if(stat(path, &statbuf) == 0) {
+ if((myGlobals.geo_ip_db = GeoIP_open(path, GEOIP_CHECK_CACHE)) != NULL) {
+ traceEvent(CONST_TRACE_INFO, "GeoIP: loaded config file %s", path);
+- break;
+ }
+ }
+ }
+@@ -513,19 +512,18 @@
+
+ /* *************************** */
+
+- for(i=0; myGlobals.configFileDirs[i] != NULL; i++) {
++ {
+ char path[256];
+
+ safe_snprintf(__FILE__, __LINE__, path, sizeof(path),
+ "%s%c%s",
+- myGlobals.configFileDirs[i],
++ myGlobals.dbPath,
+ CONST_PATH_SEP, GEO_IP_ASN_FILE);
+ revertSlashIfWIN32(path, 0);
+
+ if(stat(path, &statbuf) == 0) {
+ if((myGlobals.geo_ip_asn_db = GeoIP_open(path, GEOIP_CHECK_CACHE)) != NULL) {
+ traceEvent(CONST_TRACE_INFO, "GeoIP: loaded ASN config file %s", path);
+- break;
+ }
+ }
+ }
+diff -Nru ntop-4.0.1.orig/Makefile.am ntop-4.0.1/Makefile.am
+--- ntop-4.0.1.orig/Makefile.am 2010-04-25 14:52:28.000000000 +0200
++++ ntop-4.0.1/Makefile.am 2010-09-24 01:43:07.000000000 +0200
+@@ -43,7 +43,6 @@
+
+ #AM_CFLAGS =
+ #AM_LDFLAGS=
+-ACLOCAL_AMFLAGS=-I m4
+
+ DISTCLEANFILES = trivialcompilemessage *.db #* *~ *.log
+ CLEANFILES = $(DISTCLEANFILES) stamp-h1
+@@ -74,9 +73,7 @@
+ NTOPDATA = ntop-cert.pem \
+ $(ETTER_PASSIVE) \
+ oui.txt.gz \
+- specialMAC.txt.gz \
+- GeoIPASNum.dat \
+- GeoLiteCity.dat
++ specialMAC.txt.gz
+
+ NTOPHTML = html html/*.js html/*.html html/*.gif html/*.jpg html/*.ico html/*.png \
+ html/*.css html/*.dtd \
+@@ -370,30 +367,7 @@
+
+ # download the vendor information table
+ dnvt:
+- @echo ""
+- @echo ""
+- @echo -n "Preparing "
+- @if test -f oui.txt; then \
+- rm -rf oui.txt; \
+- fi
+- @if test -f oui.txt.gz.old; then \
+- rm -rf oui.txt.gz.old; \
+- fi;
+- @mv oui.txt.gz oui.txt.gz.old
+- @echo "(old oui.txt.gz file is now oui.txt.gz.old)"
+- @echo ""
+- @wget -c http://standards.ieee.org/regauth/oui/oui.txt
+- @gzip oui.txt
+- @echo ""
+- @echo ""
+- @echo -n "Old file lines were: "
+- @gunzip -c oui.txt.gz.old | wc -l
+- @echo -n "New file lines are: "
+- @gunzip -c oui.txt.gz | wc -l
+- @echo ""
+- @echo ""
+- @echo "New file is:"
+- @ls -l oui.txt.gz
++ @echo "Use included oui.txt.gz"
+
+ # download the Novell SAP Protocol information table
+ #dnsapt:
+@@ -401,45 +375,7 @@
+
+ # download the passive ethernet fingerprint database
+ dnetter:
+- @echo ""
+- @echo ""
+- @echo "Preparing "
+- @echo ""
+-
+- @if test -f $(ETTER_PASSIVE).old; then \
+- echo "...Deleting prior file, $(ETTER_PASSIVE).old..."; \
+- rm -rf $(ETTER_PASSIVE).old; \
+- fi;
+- @if test -f $(ETTER_PASSIVE); then \
+- echo "...Moving current $(ETTER_PASSIVE) to $(ETTER_PASSIVE).old"; \
+- mv $(ETTER_PASSIVE) $(ETTER_PASSIVE).old; \
+- fi;
+- @for file in $(ETTER_PASSIVE) $(ETTER_PASSIVE).gz \
+- $(ETTER_PASSIVE_FILE) $(ETTER_PASSIVE_FILE).gz; do \
+- if test -f $$file; then \
+- echo "...Deleting prior file, $$file..."; \
+- rm -rf $$file; \
+- fi; \
+- done
+- @echo ""
+- @echo "...Downloading new file..."
+- @wget -O $(ETTER_PASSIVE_FILE) \
+- $(ETTER_PASSIVE_DOWNLOAD_FROM)/$(ETTER_PASSIVE_FILE)?$(ETTER_PASSIVE_DOWNLOAD_PARMS)
+- @echo ""
+- @echo "gziping downloaded file..."
+- @gzip $(ETTER_PASSIVE_FILE)
+- @echo ""
+- @echo ""
+- @if test -f $(ETTER_PASSIVE).old; then \
+- echo -n "Old file lines were: "; \
+- gunzip -c $(ETTER_PASSIVE).old | wc -l; \
+- fi;
+- @echo -n "New file lines are: "
+- @gunzip -c $(ETTER_PASSIVE) | wc -l
+- @echo ""
+- @echo ""
+- @echo "New file is:"
+- @ls -l $(ETTER_PASSIVE)
++ @echo "Use included $(ETTER_PASSIVE)"
+
+ # ntop census
+ census-fail:
+diff -Nru ntop-4.0.1.orig/report.c ntop-4.0.1/report.c
+--- ntop-4.0.1.orig/report.c 2010-08-07 00:22:05.000000000 +0200
++++ ntop-4.0.1/report.c 2010-09-24 01:42:46.000000000 +0200
+@@ -2353,7 +2353,7 @@
+ if(fetchPrefsValue("dot.path", buf, sizeof(buf)) != -1) {
+ snprintf(dotPath, sizeof(dotPath), "%s", buf);
+ } else {
+- snprintf(dotPath, sizeof(dotPath), "/usr/local/bin/dot");
++ snprintf(dotPath, sizeof(dotPath), "/usr/bin/dot");
+ storePrefsValue("dot.path", dotPath); /* Set the default */
+ }
+
diff --git a/net-analyzer/ntop/ntop-4.0.1.ebuild b/net-analyzer/ntop/ntop-4.0.1.ebuild
new file mode 100644
index 000000000000..05a7e081c9a3
--- /dev/null
+++ b/net-analyzer/ntop/ntop-4.0.1.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-4.0.1.ebuild,v 1.1 2010/09/24 19:39:45 mrness Exp $
+
+EAPI="2"
+
+inherit eutils autotools
+
+DESCRIPTION="Network traffic analyzer with web interface"
+HOMEPAGE="http://www.ntop.org/ntop.html"
+SRC_URI="mirror://sourceforge/ntop/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ipv6 ssl"
+#snmp support is disabled
+
+#snmp? ( net-analyzer/net-snmp )
+COMMON_DEPEND="sys-apps/gawk
+ dev-lang/perl
+ sys-libs/gdbm
+ dev-libs/libevent
+ net-libs/libpcap
+ media-libs/gd
+ media-libs/libpng
+ net-analyzer/rrdtool
+ ssl? ( dev-libs/openssl )
+ sys-libs/zlib
+ >=dev-libs/geoip-1.4.5
+ >=dev-lang/lua-5.1.4"
+DEPEND="${COMMON_DEPEND}
+ >=sys-devel/libtool-1.4"
+
+# Needed by xmldumpPlugin - couldn't get it to work
+# dev-libs/gdome2
+# >=dev-libs/glib-2"
+RDEPEND="${COMMON_DEPEND}
+ media-fonts/corefonts
+ media-gfx/graphviz
+ net-misc/wget
+ app-arch/gzip"
+
+pkg_setup() {
+ # snmp doesn't compile in this release, disabled for now
+ #if use snmp ; then
+ # ewarn "snmp plugin is under development and upstream does not recommend"
+ # ewarn "it for usage in production environment."
+ # if ! use ipv6 ; then
+ # echo
+ # eerror "snmp plugin has compilation problems without ipv6 support."
+ # eerror "For additional information see bug #121497."
+ # die "snmp without ipv6 is broken"
+ # else
+ # if ! built_with_use net-analyzer/net-snmp ipv6 ; then
+ # echo
+ # eerror "You have both ipv6 and snmp enabled."
+ # eerror "This require ipv6 support in net-analyzer/net-snmp."
+ # eerror "However, net-analyzer/net-snmp was compiled with ipv6 flag disabled."
+ # eerror "Please, re-emerge net-analyzer/net-snmp with USE=\"ipv6\"."
+ # die "net-analyzer/net-snmp was build without ipv6."
+ # fi
+ # fi
+ #fi
+
+ enewgroup ntop
+ enewuser ntop -1 -1 /var/lib/ntop ntop
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ cat acinclude.m4.in acinclude.m4.ntop > acinclude.m4
+ eautoreconf
+}
+
+src_configure() {
+ # force disable xmldumpPlugin
+ export \
+ ac_cv_header_glib_h=no \
+ ac_cv_header_glibconfig_h=no \
+ ac_cv_header_gdome_h=no \
+ ac_cv_lib_glib_g_date_julian=no \
+ ac_cv_lib_xml2_xmlCheckVersion=no \
+ ac_cv_lib_gdome_gdome_di_saveDocToFile=no
+
+ econf \
+ $(use_enable ipv6) \
+ $(use_with ssl) \
+ --with-rrd-home=/usr/lib \
+ --disable-snmp \
+ || die "configure problem"
+ # $(use_enable snmp)
+}
+
+src_install() {
+ LC_ALL=C # apparently doesn't work with some locales (#191576 and #205382)
+ emake DESTDIR="${D}" install || die "install problem"
+
+ keepdir /var/lib/ntop &&
+ fowners ntop:ntop /var/lib/ntop &&
+ fperms 750 /var/lib/ntop ||
+ die "failed to prepare /var/lib/ntop dir"
+ insinto /var/lib/ntop
+ local f
+ for f in GeoIPASNum.dat GeoLiteCity.dat; do
+ # Don't install included GeoIP files if newer versions are available
+ [ -f "${ROOT}/var/lib/ntop/${f}" ] ||
+ doins "3rd_party/${f}" ||
+ die "failed to install ${f}"
+ done
+
+ dodoc AUTHORS CONTENTS ChangeLog MANIFESTO NEWS
+ dodoc PORTING README SUPPORT_NTOP.txt THANKS $(find docs -type f)
+
+ newinitd "${FILESDIR}"/ntop-initd ntop
+ newconfd "${FILESDIR}"/ntop-confd ntop
+
+ exeinto /etc/cron.monthly
+ doexe "${FILESDIR}"/ntop-update-geoip-db
+}
+
+pkg_postinst() {
+ elog "If this is the first time you install ntop, you need to run"
+ elog "following command before starting ntop service:"
+ elog " ntop --set-admin-password"
+}