summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-09-06 09:18:21 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-09-06 09:18:21 +0000
commit3b3780c64d6411590e6ec73395874e4d24937ac5 (patch)
tree549f884f8ff46b039f583ab4cdf4b02e9208965d /net-analyzer/ntop
parentFix man page wrt bug #191293 thanks to Mikael Magnusson. Also fix prestripped... (diff)
downloadgentoo-2-3b3780c64d6411590e6ec73395874e4d24937ac5.tar.gz
gentoo-2-3b3780c64d6411590e6ec73395874e4d24937ac5.tar.bz2
gentoo-2-3b3780c64d6411590e6ec73395874e4d24937ac5.zip
Disabling snmp as it doesn't compile, see bug #190448
(Portage version: 2.1.3.7)
Diffstat (limited to 'net-analyzer/ntop')
-rw-r--r--net-analyzer/ntop/ChangeLog5
-rw-r--r--net-analyzer/ntop/ntop-3.3.ebuild47
2 files changed, 29 insertions, 23 deletions
diff --git a/net-analyzer/ntop/ChangeLog b/net-analyzer/ntop/ChangeLog
index 8ff9b7442a2c..49504bd528d5 100644
--- a/net-analyzer/ntop/ChangeLog
+++ b/net-analyzer/ntop/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-analyzer/ntop
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ChangeLog,v 1.59 2007/08/26 07:31:41 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ChangeLog,v 1.60 2007/09/06 09:18:21 jokey Exp $
+
+ 06 Sep 2007; Markus Ullmann <jokey@gentoo.org> ntop-3.3.ebuild:
+ Disabling snmp as it doesn't compile, see bug #190448
*ntop-3.3 (26 Aug 2007)
diff --git a/net-analyzer/ntop/ntop-3.3.ebuild b/net-analyzer/ntop/ntop-3.3.ebuild
index ec49b55c075f..7e3dc8fb36d9 100644
--- a/net-analyzer/ntop/ntop-3.3.ebuild
+++ b/net-analyzer/ntop/ntop-3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-3.3.ebuild,v 1.1 2007/08/26 07:31:41 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-3.3.ebuild,v 1.2 2007/09/06 09:18:21 jokey Exp $
inherit eutils autotools
@@ -11,7 +11,8 @@ SRC_URI="mirror://sourceforge/ntop/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="ipv6 nls snmp ssl tcpd zlib"
+IUSE="ipv6 nls ssl tcpd zlib"
+#IUSE="ipv6 nls snmp ssl tcpd zlib"
DEPEND="sys-apps/gawk
>=sys-devel/libtool-1.4
@@ -33,25 +34,27 @@ RDEPEND="${DEPEND}
media-gfx/graphviz"
pkg_setup() {
- if use snmp ; then
- ewarn "snmp plugin is under development and upstream does not recommend"
- ewarn "it for usage in production environment."
- if ! use ipv6 ; then
- echo
- eerror "snmp plugin has compilation problems without ipv6 support."
- eerror "For additional information see bug #121497."
- die "snmp without ipv6 is broken"
- else
- if ! built_with_use net-analyzer/net-snmp ipv6 ; then
- echo
- eerror "You have both ipv6 and snmp enabled."
- eerror "This require ipv6 support in net-analyzer/net-snmp."
- eerror "However, net-analyzer/net-snmp was compiled with ipv6 flag disabled."
- eerror "Please, re-emerge net-analyzer/net-snmp with USE=\"ipv6\"."
- die "net-analyzer/net-snmp was build without ipv6."
- fi
- fi
- fi
+ # snmp doesn't compile in this release, disabled for now
+
+ #if use snmp ; then
+ # ewarn "snmp plugin is under development and upstream does not recommend"
+ # ewarn "it for usage in production environment."
+ # if ! use ipv6 ; then
+ # echo
+ # eerror "snmp plugin has compilation problems without ipv6 support."
+ # eerror "For additional information see bug #121497."
+ # die "snmp without ipv6 is broken"
+ # else
+ # if ! built_with_use net-analyzer/net-snmp ipv6 ; then
+ # echo
+ # eerror "You have both ipv6 and snmp enabled."
+ # eerror "This require ipv6 support in net-analyzer/net-snmp."
+ # eerror "However, net-analyzer/net-snmp was compiled with ipv6 flag disabled."
+ # eerror "Please, re-emerge net-analyzer/net-snmp with USE=\"ipv6\"."
+ # die "net-analyzer/net-snmp was build without ipv6."
+ # fi
+ # fi
+ #fi
enewgroup ntop
enewuser ntop -1 -1 /var/lib/ntop ntop
}
@@ -80,12 +83,12 @@ src_compile() {
econf \
$(use_enable ipv6) \
$(use_enable nls i18n) \
- $(use_enable snmp) \
$(use_with ssl) $(use_enable ssl sslv3) $(use_enable ssl sslwatchdog) \
$(use_with tcpd) \
$(use_with zlib) \
--with-rrd-home=/usr/lib \
|| die "configure problem"
+ # $(use_enable snmp) \
emake || die "compile problem"
}