summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-01 14:00:14 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-01 14:00:14 +0000
commit357a1b39d2aa6d172a908d805edab80d716fb7ee (patch)
tree0a62bacc29615a8ea4c7e1c1e17ca85df2cb0c66 /net-analyzer/ntop
parentnew TODO comments (extensive) (diff)
downloadgentoo-2-357a1b39d2aa6d172a908d805edab80d716fb7ee.tar.gz
gentoo-2-357a1b39d2aa6d172a908d805edab80d716fb7ee.tar.bz2
gentoo-2-357a1b39d2aa6d172a908d805edab80d716fb7ee.zip
*** empty log message ***
Diffstat (limited to 'net-analyzer/ntop')
-rw-r--r--net-analyzer/ntop/ntop-1.3.1-r2.ebuild40
1 files changed, 27 insertions, 13 deletions
diff --git a/net-analyzer/ntop/ntop-1.3.1-r2.ebuild b/net-analyzer/ntop/ntop-1.3.1-r2.ebuild
index b62e62484bd7..ad1e4cb9464c 100644
--- a/net-analyzer/ntop/ntop-1.3.1-r2.ebuild
+++ b/net-analyzer/ntop/ntop-1.3.1-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-1.3.1-r2.ebuild,v 1.2 2001/04/29 16:51:55 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-1.3.1-r2.ebuild,v 1.3 2001/06/01 14:00:14 achim Exp $
P=ntop-1.3.1
A="${P}.tar.gz"
@@ -10,33 +10,47 @@ DESCRIPTION="Unix Tool that shows networkusage like top"
SRC_URI="ftp://ftp.it.ntop.org/pub/local/ntop/snapshots/${A}"
HOMEPAGE="http://www.ntop.org/ntop.html"
-DEPEND=">=sys-apps/bash-2.04
+DEPEND="virtual/glibc sys-devel/gcc
>=sys-libs/gdbm-1.8.0
- >=sys-libs/glibc-2.1.3
- >=sys-libs/gpm-1.19.3
- >=sys-libs/ncurses-5.1
- >=dev-libs/openssl-0.9.6
+ ssl? ( >=dev-libs/openssl-0.9.6 )
>=net-libs/libpcap-0.5.2"
+RDEPEND="virtual/glibc sys-devel/gcc
+ >=sys-libs/gdbm-1.8.0
+ >=sys-libs/ncurses-5.1
+ >=sys-libs/readline-4.1
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+# tcpd? ( >=sys-apps/tcp-wrappers-7.6 ) does not work atm
+
src_unpack() {
unpack ${A}
cp ${FILESDIR}/main.c ${S}/main.c
}
src_compile() {
- cd ${S}
- cp configure configure.orig
- sed -e "s:/usr/local/ssl:/usr:" configure.orig > configure
- CFLAGS="$CFLAGS -I/usr/include/openssl" try ./configure --prefix=/usr --sysconfdir=/usr/share --host=${CHOST}
+
+ local myconf
+ if [ -z "`use ssl`" ] ; then
+ myconf="--disable-ssl"
+ else
+ cp configure configure.orig
+ sed -e "s:/usr/local/ssl:/usr:" configure.orig > configure
+ export CFLAGS="$CFLAGS -I/usr/include/openssl"
+ fi
+ #if [ "`use tcpd`" ] ; then
+ # myconf="$myconf --enable-tcpwrap"
+ #fi
+ try ./configure --prefix=/usr --sysconfdir=/usr/share --mandir=/usr/share/man --host=${CHOST} $myconf
try make
}
src_install () {
- cd ${S}
- try make prefix=${D}/usr sysconfdir=/${D}/usr/share install
+
+ try make prefix=${D}/usr sysconfdir=/${D}/usr/share mandir=${D}/usr/share/man install
mv ${D}/usr/bin/plugins ${D}/usr/share/ntop
- prepman
+
dodoc AUTHORS ChangeLog CONTENTS COPYING FAQ FILES HACKING
dodoc KNOWN_BUGS MANIFESTO NEWS ntop.txt PORTING README*
dodoc SUPPORT* THANKS THREADS-FAQ TODO