summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2009-02-16 22:17:29 +0000
committerAlin Năstac <mrness@gentoo.org>2009-02-16 22:17:29 +0000
commit67a6a23ee2a4b5b0c710523529615ed1dbf2a2fd (patch)
tree6a8dacd7c5bd33bdac96f07a74570eddd7c8fdfa /net-analyzer/ntop/files
parentwhitespace (diff)
downloadgentoo-2-67a6a23ee2a4b5b0c710523529615ed1dbf2a2fd.tar.gz
gentoo-2-67a6a23ee2a4b5b0c710523529615ed1dbf2a2fd.tar.bz2
gentoo-2-67a6a23ee2a4b5b0c710523529615ed1dbf2a2fd.zip
Version bump. Install /var/lib/ntop with the right owner (#254868).
(Portage version: 2.1.6.4/cvs/Linux 2.6.25-gentoo-r6 x86_64)
Diffstat (limited to 'net-analyzer/ntop/files')
-rw-r--r--net-analyzer/ntop/files/ntop-3.3.9-external-geoip.patch97
-rw-r--r--net-analyzer/ntop/files/ntop-3.3.9-gentoo.patch47
2 files changed, 144 insertions, 0 deletions
diff --git a/net-analyzer/ntop/files/ntop-3.3.9-external-geoip.patch b/net-analyzer/ntop/files/ntop-3.3.9-external-geoip.patch
new file mode 100644
index 000000000000..99efd615c171
--- /dev/null
+++ b/net-analyzer/ntop/files/ntop-3.3.9-external-geoip.patch
@@ -0,0 +1,97 @@
+diff -Nru ntop-3.3.9.orig/configure.in ntop-3.3.9/configure.in
+--- ntop-3.3.9.orig/configure.in 2009-02-16 19:43:57.000000000 +0000
++++ ntop-3.3.9/configure.in 2009-02-16 19:47:10.000000000 +0000
+@@ -1882,20 +1882,6 @@
+ fi
+
+ dnl> GeoIP (http://www.maxmind.com/)
+-if test -f "GeoIP.tar.gz"; then
+- echo "GeoIP already present on this machine"
+-else
+- wget http://www.maxmind.com/download/geoip/api/c/GeoIP.tar.gz
+- tar xvfz GeoIP.tar.gz
+- GEO_DIR=`find $PWD -type d -name "GeoIP-*"`
+- cd $GEO_DIR; ./configure; make; cd ..
+- # OSX Fix
+- GEO_DYLIB="$GEO_DIR/libGeoIP/.libs/libGeoIP.dylib"
+- if test -f $GEO_DYLIB; then
+- ln -s $GEO_DYLIB .
+- fi
+-fi
+-
+ if test -f "GeoLiteCity.dat"; then
+ echo "GeoLiteCity.dat already present"
+ else
+@@ -1911,10 +1897,7 @@
+ fi
+
+
+-GEO_DIR=`find $PWD -type d -name "GeoIP-*"`
+-GEO_IP="$GEO_DIR/libGeoIP/"
+-CFLAGS="$CFLAGS -I$GEO_IP"
+-LDFLAGS="$LDFLAGS -L$GEO_IP.libs/ -lGeoIP"
++LDFLAGS="$LDFLAGS -lGeoIP"
+
+ dnl> NTOPCONFIGDEBUG_SETTINGS([precet])
+
+@@ -2079,7 +2062,6 @@
+ AC_SUBST(SO_VERSION_PATCH)
+ AC_SUBST(RRD_LIB)
+ AC_SUBST(RRD_INC)
+-AC_SUBST(GEO_DIR)
+
+ AC_CONFIG_FILES([Makefile])
+
+diff -Nru ntop-3.3.9.orig/initialize.c ntop-3.3.9/initialize.c
+--- ntop-3.3.9.orig/initialize.c 2008-12-03 22:00:22.000000000 +0000
++++ ntop-3.3.9/initialize.c 2009-02-16 22:04:34.000000000 +0000
+@@ -467,16 +467,15 @@
+ #endif
+
+ /* Initialize GeoIP databases */
+- for(i=0; myGlobals.configFileDirs[i] != NULL; i++) {
++ {
+ char path[256];
+
+ safe_snprintf(__FILE__, __LINE__, path, sizeof(path),
+ "%s%c%s",
+- myGlobals.configFileDirs[i], CONST_PATH_SEP, GEO_IP_FILE);
++ myGlobals.dbPath, CONST_PATH_SEP, GEO_IP_FILE);
+ revertSlashIfWIN32(path, 0);
+ if((myGlobals.geo_ip_db = GeoIP_open(path, GEOIP_CHECK_CACHE)) != NULL) {
+ traceEvent(CONST_TRACE_INFO, "GeoIP: loaded config file %s", path);
+- break;
+ }
+ }
+
+@@ -485,16 +484,15 @@
+
+ /* *************************** */
+
+- for(i=0; myGlobals.configFileDirs[i] != NULL; i++) {
++ {
+ char path[256];
+
+ safe_snprintf(__FILE__, __LINE__, path, sizeof(path),
+ "%s%c%s",
+- myGlobals.configFileDirs[i], CONST_PATH_SEP, GEO_IP_ASN_FILE);
++ myGlobals.dbPath, CONST_PATH_SEP, GEO_IP_ASN_FILE);
+ revertSlashIfWIN32(path, 0);
+ if((myGlobals.geo_ip_asn_db = GeoIP_open(path, GEOIP_CHECK_CACHE)) != NULL) {
+ traceEvent(CONST_TRACE_INFO, "GeoIP: loaded ASN config file %s", path);
+- break;
+ }
+ }
+
+diff -Nru ntop-3.3.9.orig/Makefile.am ntop-3.3.9/Makefile.am
+--- ntop-3.3.9.orig/Makefile.am 2008-12-03 22:00:22.000000000 +0000
++++ ntop-3.3.9/Makefile.am 2009-02-16 19:47:25.000000000 +0000
+@@ -270,8 +270,6 @@
+
+ install: install-recursive
+
+- cd @GEO_DIR@; make install
+-
+ @mkdir -p $(DESTDIR)/$(CFG_DBFILE_DIR)
+
+ @echo ""
diff --git a/net-analyzer/ntop/files/ntop-3.3.9-gentoo.patch b/net-analyzer/ntop/files/ntop-3.3.9-gentoo.patch
new file mode 100644
index 000000000000..fb0268fed30a
--- /dev/null
+++ b/net-analyzer/ntop/files/ntop-3.3.9-gentoo.patch
@@ -0,0 +1,47 @@
+diff -Nru ntop-3.3.9.orig/configure.in ntop-3.3.9/configure.in
+--- ntop-3.3.9.orig/configure.in 2008-12-03 22:00:22.000000000 +0000
++++ ntop-3.3.9/configure.in 2009-02-15 18:19:26.000000000 +0000
+@@ -57,6 +57,7 @@
+ dnl>
+ umask 002
+ AM_CONFIG_HEADER(config.h)
++AM_MAINTAINER_MODE
+
+ HAS_ERROR=
+ HAS_WARNING=
+@@ -504,11 +504,6 @@
+ LOCALEDIR="/usr/lib/locale"
+ fi
+
+-dnl> Add /usr/local/
+-CFLAGS="${CFLAGS} -I/usr/local/include -I/opt/local/include"
+-CPPFLAGS="${CPPFLAGS} -I/usr/local/include -I/opt/local/include"
+-LDFLAGS="${LDFLAGS} -L/usr/local/lib -L/opt/local/lib"
+-
+ PWD=`pwd`
+
+ echo
+diff -Nru ntop-3.3.9.orig/globals-core.c ntop-3.3.9/globals-core.c
+--- ntop-3.3.9.orig/globals-core.c 2008-12-03 22:00:22.000000000 +0000
++++ ntop-3.3.9/globals-core.c 2009-02-15 18:18:55.000000000 +0000
+@@ -424,7 +424,7 @@
+ _mtuSize[DLT_ATM_RFC1483] = 9180 /* LLC/SNAP encapsulated atm */;
+ _headerSize[DLT_ATM_RFC1483] = 0;
+
+- /* _mtuSize[DLT_RAW] = ? raw IP */
++ _mtuSize[DLT_RAW] = 1500 /* raw IP */;
+ _headerSize[DLT_RAW] = 0;
+
+ /* Others defined in bpf.h at tcpdump.org as of the resync - it would be NICE
+diff -Nru ntop-3.3.9.orig/report.c ntop-3.3.9/report.c
+--- ntop-3.3.9.orig/report.c 2008-12-09 11:41:47.000000000 +0000
++++ ntop-3.3.9/report.c 2009-02-15 18:18:55.000000000 +0000
+@@ -2301,7 +2301,7 @@
+ if(fetchPrefsValue("dot.path", buf, sizeof(buf)) != -1) {
+ snprintf(dotPath, sizeof(dotPath), "%s", buf);
+ } else {
+- snprintf(dotPath, sizeof(dotPath), "/usr/local/bin/dot");
++ snprintf(dotPath, sizeof(dotPath), "/usr/bin/dot");
+ storePrefsValue("dot.path", dotPath); /* Set the default */
+ }
+