summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2010-01-31 09:08:52 +0000
committerMichael Januszewski <spock@gentoo.org>2010-01-31 09:08:52 +0000
commit79feb32674ed0ac70b63ace68c2b3a6c46b875c2 (patch)
treee17406aaf0150367877e6d66d72e488a582a1041 /net-analyzer/nmap
parentBug #296186: Revbump with fix to use SHOW GLOBAL STATUS for QPS count, like s... (diff)
downloadgentoo-2-79feb32674ed0ac70b63ace68c2b3a6c46b875c2.tar.gz
gentoo-2-79feb32674ed0ac70b63ace68c2b3a6c46b875c2.tar.bz2
gentoo-2-79feb32674ed0ac70b63ace68c2b3a6c46b875c2.zip
Fix bug #302636.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/nmap')
-rw-r--r--net-analyzer/nmap/ChangeLog6
-rw-r--r--net-analyzer/nmap/files/nmap-5.21-python.patch21
-rw-r--r--net-analyzer/nmap/nmap-5.21.ebuild3
3 files changed, 28 insertions, 2 deletions
diff --git a/net-analyzer/nmap/ChangeLog b/net-analyzer/nmap/ChangeLog
index d2a1271a2f3b..010dbd5d8a98 100644
--- a/net-analyzer/nmap/ChangeLog
+++ b/net-analyzer/nmap/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/nmap
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.216 2010/01/29 23:20:38 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.217 2010/01/31 09:08:52 spock Exp $
+
+ 31 Jan 2010; Michał Januszewski <spock@gentoo.org> nmap-5.21.ebuild,
+ +files/nmap-5.21-python.patch:
+ Fix bug #302636.
*nmap-5.21 (29 Jan 2010)
diff --git a/net-analyzer/nmap/files/nmap-5.21-python.patch b/net-analyzer/nmap/files/nmap-5.21-python.patch
new file mode 100644
index 000000000000..aa0d4f9db953
--- /dev/null
+++ b/net-analyzer/nmap/files/nmap-5.21-python.patch
@@ -0,0 +1,21 @@
+diff -Naurp nmap-5.21-orig/Makefile.in nmap-5.21/Makefile.in
+--- nmap-5.21-orig/Makefile.in 2010-01-31 09:53:53.000000000 +0100
++++ nmap-5.21/Makefile.in 2010-01-31 09:54:48.000000000 +0100
+@@ -253,7 +253,7 @@ build-zenmap: $(ZENMAPDIR)/setup.py $(ZE
+
+ install-zenmap: $(ZENMAPDIR)/setup.py
+ $(INSTALL) -d $(DESTDIR)$(bindir) $(DESTDIR)$(mandir)/man1
+- cd $(ZENMAPDIR) && $(PYTHON) setup.py --quiet install --prefix "$(prefix)" --force $(if $(DESTDIR),--root "$(DESTDIR)")
++ cd $(ZENMAPDIR) && $(PYTHON) setup.py --quiet install --prefix "$(prefix)" --force $(if $(DESTDIR),--root "$(DESTDIR)") --no-compile
+ $(INSTALL) -c -m 644 docs/zenmap.1 $(DESTDIR)$(mandir)/man1/
+ # Create a symlink from nmapfe to zenmap if nmapfe doesn't exist or is
+ # already a link.
+@@ -267,7 +267,7 @@ build-ndiff:
+ cd $(NDIFFDIR) && $(PYTHON) setup.py build $(if $(DESTDIR),--executable "$(DEFAULT_PYTHON_PATH)")
+
+ install-ndiff:
+- cd $(NDIFFDIR) && $(PYTHON) setup.py install --prefix "$(prefix)" $(if $(DESTDIR),--root "$(DESTDIR)")
++ cd $(NDIFFDIR) && $(PYTHON) setup.py install --prefix "$(prefix)" $(if $(DESTDIR),--root "$(DESTDIR)") --no-compile
+
+ NSE_FILES = scripts/script.db scripts/*.nse
+ NSE_LIB_LUA_FILES = nselib/*.lua
diff --git a/net-analyzer/nmap/nmap-5.21.ebuild b/net-analyzer/nmap/nmap-5.21.ebuild
index 142dc54eaba3..96715b3a3a78 100644
--- a/net-analyzer/nmap/nmap-5.21.ebuild
+++ b/net-analyzer/nmap/nmap-5.21.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-5.21.ebuild,v 1.1 2010/01/29 23:20:38 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-5.21.ebuild,v 1.2 2010/01/31 09:08:52 spock Exp $
EAPI="2"
@@ -33,6 +33,7 @@ src_prepare() {
epatch "${FILESDIR}/${PN}-4.75-include.patch"
epatch "${FILESDIR}/${PN}-4.75-nolua.patch"
epatch "${FILESDIR}/${PN}-5.10_beta1-string.patch"
+ epatch "${FILESDIR}/${PN}-5.21-python.patch"
sed -i -e 's/-m 755 -s ncat/-m 755 ncat/' ncat/Makefile.in
}