summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2009-09-26 22:01:06 +0000
committerMichael Januszewski <spock@gentoo.org>2009-09-26 22:01:06 +0000
commitfd1f1cc71185a4d009e2d0d119b4531d6d513040 (patch)
tree4a4bea0727530799a791132ab0eb8d8c9b8b7788 /net-analyzer/nmap/nmap-5.00-r2.ebuild
parentKeywording for ppc. (diff)
downloadgentoo-2-fd1f1cc71185a4d009e2d0d119b4531d6d513040.tar.gz
gentoo-2-fd1f1cc71185a4d009e2d0d119b4531d6d513040.tar.bz2
gentoo-2-fd1f1cc71185a4d009e2d0d119b4531d6d513040.zip
Do not allow usage of the bundled liblua (see bug #280772 for more info).
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/nmap/nmap-5.00-r2.ebuild')
-rw-r--r--net-analyzer/nmap/nmap-5.00-r2.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/net-analyzer/nmap/nmap-5.00-r2.ebuild b/net-analyzer/nmap/nmap-5.00-r2.ebuild
new file mode 100644
index 000000000000..2161a9e5fb9d
--- /dev/null
+++ b/net-analyzer/nmap/nmap-5.00-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-5.00-r2.ebuild,v 1.1 2009/09/26 22:01:06 spock Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic
+
+MY_P=${P//_rc1/RC1}
+
+DESCRIPTION="A utility for network exploration or security auditing"
+HOMEPAGE="http://nmap.org/"
+SRC_URI="http://download.insecure.org/nmap/dist/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="gtk lua ssl"
+
+DEPEND="dev-libs/libpcre
+ net-libs/libpcap
+ gtk? ( >=x11-libs/gtk+-2.6
+ >=dev-python/pygtk-2.6
+ || ( >=dev-lang/python-2.5[sqlite]
+ >=dev-python/pysqlite-2 )
+ )
+ lua? ( >=dev-lang/lua-5.1.4-r1[deprecated] )
+ ssl? ( dev-libs/openssl )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-4.75-include.patch"
+ epatch "${FILESDIR}/${PN}-4.75-nolua.patch"
+ sed -i -e 's/-m 755 -s ncat/-m 755 ncat/' ncat/Makefile.in
+}
+
+src_configure() {
+ # The bundled libdnet is incompatible with the version available in the
+ # tree, so we cannot use the system library here.
+ econf --with-libdnet=included \
+ $(use_with gtk zenmap) \
+ $(use_with lua liblua) \
+ $(use_with ssl openssl) || die
+}
+
+src_install() {
+ LC_ALL=C emake DESTDIR="${D}" -j1 STRIP=: nmapdatadir=/usr/share/nmap install || die
+ dodoc CHANGELOG HACKING docs/README docs/*.txt || die
+
+ use gtk && doicon "${FILESDIR}/nmap-logo-64.png"
+}