summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-01-06 14:41:31 +0000
committerMichael Januszewski <spock@gentoo.org>2008-01-06 14:41:31 +0000
commit1ebe9814f9ea796fe3d52fc3af6fd92d377a03cb (patch)
tree0a5dd3696451bd2143907abcf18b7a3c52285aaf /net-analyzer/nmap/nmap-4.52.ebuild
parentAdded an upstream patch provided by Vanya to fix bug 204289. Thanks, Vanya! (diff)
downloadgentoo-2-1ebe9814f9ea796fe3d52fc3af6fd92d377a03cb.tar.gz
gentoo-2-1ebe9814f9ea796fe3d52fc3af6fd92d377a03cb.tar.bz2
gentoo-2-1ebe9814f9ea796fe3d52fc3af6fd92d377a03cb.zip
Version bump (bug #204555).
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'net-analyzer/nmap/nmap-4.52.ebuild')
-rw-r--r--net-analyzer/nmap/nmap-4.52.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-analyzer/nmap/nmap-4.52.ebuild b/net-analyzer/nmap/nmap-4.52.ebuild
new file mode 100644
index 000000000000..1ce6ee827825
--- /dev/null
+++ b/net-analyzer/nmap/nmap-4.52.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-4.52.ebuild,v 1.1 2008/01/06 14:41:30 spock Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="A utility for network exploration or security auditing"
+HOMEPAGE="http://www.insecure.org/nmap/"
+SRC_URI="http://download.insecure.org/nmap/dist/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="gtk ssl"
+
+DEPEND="dev-libs/libpcre
+ net-libs/libpcap
+ gtk? ( >=x11-libs/gtk+-2.6
+ >=dev-python/pygtk-2.6
+ || ( >=dev-lang/python-2.5
+ >=dev-python/pysqlite-2 )
+ )
+ ssl? ( dev-libs/openssl )"
+
+pkg_setup() {
+ if use gtk && has_version ">=dev-lang/python-2.5" &&
+ ! has_version ">=dev-python/pysqlite-2" &&
+ ! built_with_use dev-lang/python sqlite ; then
+ eerror "In order to use the nmap GUI you have to either emerge dev-lang/python"
+ eerror "with the 'sqlite' USE flag, or install dev-python/pysqlite-2*."
+ die "sqlite support missing"
+ fi
+}
+
+src_compile() {
+ use ppc-macos && filter-flags -fstrict-aliasing -O2
+ econf \
+ --with-libdnet=included \
+ $(use_with gtk zenmap) \
+ $(use_with ssl openssl) || die
+ emake -j1 || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" -j1 nmapdatadir=/usr/share/nmap install || die
+ dodoc CHANGELOG HACKING docs/README docs/*.txt || die
+
+ use gtk && doicon "${FILESDIR}/nmap-logo-64.png"
+}