summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-02-21 16:34:20 +0000
committerJeroen Roovers <jer@gentoo.org>2012-02-21 16:34:20 +0000
commit86ca1d6597c0e7130e5a8637ac1fbcdb5708ab1d (patch)
tree410a70505cf02e436a4caf7c5c72cc86f0a6819d /net-analyzer/nfdump
parentVersion bump. Headers have changed in new Firefox version. (diff)
downloadgentoo-2-86ca1d6597c0e7130e5a8637ac1fbcdb5708ab1d.tar.gz
gentoo-2-86ca1d6597c0e7130e5a8637ac1fbcdb5708ab1d.tar.bz2
gentoo-2-86ca1d6597c0e7130e5a8637ac1fbcdb5708ab1d.zip
Version bump. Fix building against net-analyzer/flow-tools[-static-libs] (bug #405157).
(Portage version: 2.2.0_alpha88/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/nfdump')
-rw-r--r--net-analyzer/nfdump/ChangeLog10
-rw-r--r--net-analyzer/nfdump/nfdump-1.6.5.ebuild55
2 files changed, 63 insertions, 2 deletions
diff --git a/net-analyzer/nfdump/ChangeLog b/net-analyzer/nfdump/ChangeLog
index be6ca555f155..157f1a3384b6 100644
--- a/net-analyzer/nfdump/ChangeLog
+++ b/net-analyzer/nfdump/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/nfdump
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nfdump/ChangeLog,v 1.19 2011/06/06 12:05:44 jer Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nfdump/ChangeLog,v 1.20 2012/02/21 16:34:20 jer Exp $
+
+*nfdump-1.6.5 (21 Feb 2012)
+
+ 21 Feb 2012; Jeroen Roovers <jer@gentoo.org> +nfdump-1.6.5.ebuild:
+ Version bump. Fix building against net-analyzer/flow-tools[-static-libs] (bug
+ #405157).
*nfdump-1.6.3_p1 (06 Jun 2011)
diff --git a/net-analyzer/nfdump/nfdump-1.6.5.ebuild b/net-analyzer/nfdump/nfdump-1.6.5.ebuild
new file mode 100644
index 000000000000..728c2beddd2c
--- /dev/null
+++ b/net-analyzer/nfdump/nfdump-1.6.5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nfdump/nfdump-1.6.5.ebuild,v 1.1 2012/02/21 16:34:20 jer Exp $
+
+EAPI=4
+inherit autotools eutils
+
+MY_P="${P/_/}"
+DESCRIPTION="A set of tools to collect and process netflow data"
+HOMEPAGE="http://nfdump.sourceforge.net/"
+SRC_URI="mirror://sourceforge/nfdump/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# Fails to build readpcap:
+# https://sourceforge.net/tracker/?func=detail&aid=2996582&group_id=119350&atid=683752
+IUSE="compat15 debug ftconv nfprofile sflow"
+
+CDEPEND="
+ ftconv? ( sys-libs/zlib net-analyzer/flow-tools )
+ nfprofile? ( net-analyzer/rrdtool )"
+# readpcap? ( net-libs/libpcap )"
+DEPEND="${CDEPEND}
+ sys-devel/flex"
+RDEPEND=${CDEPEND}"
+ dev-lang/perl"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+cp -av configure.in{,.org}
+ if use ftconv; then
+ sed -e '/ftbuild.h/d' -i bin/ft2nfdump.c || die
+ sed \
+ -e 's:lib\(/ftlib.h\):include\1:' \
+ -e 's:libft.a:libft.so:' \
+ \-i configure.in || die
+ fi
+ sed -i bin/Makefile.am -e '/^AM_CFLAGS/d' || die
+ eautoreconf
+}
+
+src_configure() {
+ # --without-ftconf is not handled well #322201
+ econf \
+ $(use ftconv && echo "--enable-ftconv --with-ftpath=/usr") \
+ $(use nfprofile && echo "--enable-nfprofile") \
+ $(use_enable sflow) \
+ $(use_enable debug devel) \
+ $(use_enable compat15)
+ # $(use_enable readpcap) \
+}