summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-03-07 10:36:30 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-03-07 10:36:30 +0000
commit34aef9771844dcde65fc3c4267d55b6edb2b035b (patch)
tree032289720ee6ad02d06548137b98e57f17a955d4 /net-analyzer/nfdump
parentStop using "modprobe -l" which went away with sys-apps/kmod wrt #409931 (diff)
downloadgentoo-2-34aef9771844dcde65fc3c4267d55b6edb2b035b.tar.gz
gentoo-2-34aef9771844dcde65fc3c4267d55b6edb2b035b.tar.bz2
gentoo-2-34aef9771844dcde65fc3c4267d55b6edb2b035b.zip
Version bump, bring back USE='readpcap'
(Portage version: 2.2.0_alpha165/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'net-analyzer/nfdump')
-rw-r--r--net-analyzer/nfdump/ChangeLog10
-rw-r--r--net-analyzer/nfdump/metadata.xml2
-rw-r--r--net-analyzer/nfdump/nfdump-1.6.9.ebuild60
3 files changed, 69 insertions, 3 deletions
diff --git a/net-analyzer/nfdump/ChangeLog b/net-analyzer/nfdump/ChangeLog
index 1e2d2746c808..a0eca7fc6f3e 100644
--- a/net-analyzer/nfdump/ChangeLog
+++ b/net-analyzer/nfdump/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/nfdump
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nfdump/ChangeLog,v 1.31 2012/11/05 12:53:20 jer Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nfdump/ChangeLog,v 1.32 2013/03/07 10:36:30 pinkbyte Exp $
+
+*nfdump-1.6.9 (07 Mar 2013)
+
+ 07 Mar 2013; Sergey Popov <pinkbyte@gentoo.org> +nfdump-1.6.9.ebuild,
+ metadata.xml:
+ Version bump, bring back USE='readpcap'
05 Nov 2012; Jeroen Roovers <jer@gentoo.org> nfdump-1.6.8.ebuild:
USE=nftrack requires net-analyzer/rrdtool.
diff --git a/net-analyzer/nfdump/metadata.xml b/net-analyzer/nfdump/metadata.xml
index 111793109bae..5204c2aa2aab 100644
--- a/net-analyzer/nfdump/metadata.xml
+++ b/net-analyzer/nfdump/metadata.xml
@@ -3,7 +3,7 @@
<pkgmetadata>
<herd>netmon</herd>
<use>
- <!--<flag name='readpcap'>Build nfcapd collector to read from pcap file instead ofnetwork data</flag>-->
+ <flag name='readpcap'>Build nfcapd collector to read from pcap file instead ofnetwork data</flag>
<flag name='compat15'>Enable read support for nfdump data files created with nfdump 1.5.x</flag>
<flag name='ftconv'>Build the flow-tools to nfdump converter</flag>
<flag name='nfprofile'>Build nfprofile used by NfSen</flag>
diff --git a/net-analyzer/nfdump/nfdump-1.6.9.ebuild b/net-analyzer/nfdump/nfdump-1.6.9.ebuild
new file mode 100644
index 000000000000..89a3b144e5d5
--- /dev/null
+++ b/net-analyzer/nfdump/nfdump-1.6.9.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nfdump/nfdump-1.6.9.ebuild,v 1.1 2013/03/07 10:36:30 pinkbyte Exp $
+
+EAPI=5
+inherit autotools eutils
+
+MY_P="${P/_/}"
+DESCRIPTION="A set of tools to collect and process netflow data"
+HOMEPAGE="http://nfdump.sourceforge.net/"
+SRC_URI="mirror://sourceforge/nfdump/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="compat15 debug ftconv nfprofile nftrack readpcap sflow"
+
+CDEPEND="
+ ftconv? ( sys-libs/zlib net-analyzer/flow-tools )
+ nfprofile? ( net-analyzer/rrdtool )
+ nftrack? ( net-analyzer/rrdtool )
+ readpcap? ( net-libs/libpcap )
+"
+DEPEND="
+ ${CDEPEND}
+ sys-devel/flex
+ virtual/yacc
+"
+RDEPEND="
+ ${CDEPEND}
+ dev-lang/perl
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ if use ftconv; then
+ sed -e '/ftbuild.h/d' -i bin/ft2nfdump.c || die
+ sed \
+ -e 's:lib\(/ftlib.h\):include\1:' \
+ -e 's:libft.a:libft.so:' \
+ \-i configure.in || die
+ fi
+ sed -i bin/Makefile.am -e '/^AM_CFLAGS/d' || die
+ eautoreconf
+}
+
+src_configure() {
+ # --without-ftconf is not handled well #322201
+ econf \
+ $(use ftconv && echo "--enable-ftconv --with-ftpath=/usr") \
+ $(use nfprofile && echo --enable-nfprofile) \
+ $(use nftrack && echo --enable-nftrack) \
+ $(use_enable compat15) \
+ $(use_enable debug devel) \
+ $(use_enable readpcap) \
+ $(use_enable sflow)
+}