summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-03-10 20:30:49 +0000
committerJeroen Roovers <jer@gentoo.org>2013-03-10 20:30:49 +0000
commitef8f944bdce6da1643b12847f2376bc0379ed84f (patch)
tree46e5da96be4fd59f820cf9a17302a91d9f1e82b7 /net-analyzer/netselect
parentinitial import wrt #460716 (diff)
downloadgentoo-2-ef8f944bdce6da1643b12847f2376bc0379ed84f.tar.gz
gentoo-2-ef8f944bdce6da1643b12847f2376bc0379ed84f.tar.bz2
gentoo-2-ef8f944bdce6da1643b12847f2376bc0379ed84f.zip
Do not inject -g. size_t -> socklen_t.
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/netselect')
-rw-r--r--net-analyzer/netselect/ChangeLog6
-rw-r--r--net-analyzer/netselect/files/netselect-0.3-glibc.patch11
-rw-r--r--net-analyzer/netselect/netselect-0.3-r3.ebuild7
3 files changed, 20 insertions, 4 deletions
diff --git a/net-analyzer/netselect/ChangeLog b/net-analyzer/netselect/ChangeLog
index 4aec08580faf..eaf46816cf6a 100644
--- a/net-analyzer/netselect/ChangeLog
+++ b/net-analyzer/netselect/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/netselect
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netselect/ChangeLog,v 1.41 2013/03/10 20:06:00 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netselect/ChangeLog,v 1.42 2013/03/10 20:30:49 jer Exp $
+
+ 10 Mar 2013; Jeroen Roovers <jer@gentoo.org> netselect-0.3-r3.ebuild,
+ +files/netselect-0.3-glibc.patch:
+ Do not inject -g. size_t -> socklen_t.
*netselect-0.3-r3 (10 Mar 2013)
diff --git a/net-analyzer/netselect/files/netselect-0.3-glibc.patch b/net-analyzer/netselect/files/netselect-0.3-glibc.patch
new file mode 100644
index 000000000000..053e5865b341
--- /dev/null
+++ b/net-analyzer/netselect/files/netselect-0.3-glibc.patch
@@ -0,0 +1,11 @@
+--- a/netselect.c
++++ b/netselect.c
+@@ -780,7 +780,7 @@
+ #if !defined(__GLIBC__)
+ int fromlen = sizeof(from);
+ #else /* __GLIBC__ */
+- size_t fromlen = sizeof(from);
++ socklen_t fromlen = sizeof(from);
+ #endif /* __GLIBC__ */
+
+ FD_ZERO(&fds);
diff --git a/net-analyzer/netselect/netselect-0.3-r3.ebuild b/net-analyzer/netselect/netselect-0.3-r3.ebuild
index f694ccd0ff9c..55510d04074c 100644
--- a/net-analyzer/netselect/netselect-0.3-r3.ebuild
+++ b/net-analyzer/netselect/netselect-0.3-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netselect/netselect-0.3-r3.ebuild,v 1.1 2013/03/10 20:06:00 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netselect/netselect-0.3-r3.ebuild,v 1.2 2013/03/10 20:30:49 jer Exp $
EAPI=5
inherit eutils flag-o-matic toolchain-funcs
@@ -18,11 +18,12 @@ S=${WORKDIR}/${PN}
src_prepare() {
epatch "${FILESDIR}/${P}-bsd.patch"
+ epatch "${FILESDIR}/${P}-glibc.patch"
sed -i \
-e "s:PREFIX =.*:PREFIX = ${ED}usr:" \
- -e "s:CFLAGS =.*:CFLAGS = -Wall -I. -g ${CFLAGS}:" \
- -e "s:LDFLAGS =.*:LDFLAGS = -g ${LDFLAGS}:" \
+ -e "s:CFLAGS =.*:CFLAGS = -Wall -I. ${CFLAGS}:" \
+ -e "s:LDFLAGS =.*:LDFLAGS = ${LDFLAGS}:" \
-e '23,27d' \
-e '34d' \
Makefile || die