summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-08-26 00:49:05 +0000
committerJeroen Roovers <jer@gentoo.org>2009-08-26 00:49:05 +0000
commit855b41ae424dce668dbffe80d1b3e7e77056ec75 (patch)
treeffa4af2c1784943260df200156c2c52451b8cf2a /net-analyzer/netperf
parentVersion bump (diff)
downloadgentoo-2-855b41ae424dce668dbffe80d1b3e7e77056ec75.tar.gz
gentoo-2-855b41ae424dce668dbffe80d1b3e7e77056ec75.tar.bz2
gentoo-2-855b41ae424dce668dbffe80d1b3e7e77056ec75.zip
Version bump. Drop useless MY_P. Block sci-mathematics/snns (bug #248322). Drop autotools since the gcc41 patch is no longer needed, incidentally fix maintainer-mode (bug #255896). Drop unused flag-o-matic. Depend on sed.
(Portage version: 2.2_rc40/cvs/Linux i686)
Diffstat (limited to 'net-analyzer/netperf')
-rw-r--r--net-analyzer/netperf/ChangeLog12
-rw-r--r--net-analyzer/netperf/netperf-2.4.4.ebuild6
-rw-r--r--net-analyzer/netperf/netperf-2.4.5.ebuild52
3 files changed, 66 insertions, 4 deletions
diff --git a/net-analyzer/netperf/ChangeLog b/net-analyzer/netperf/ChangeLog
index 68c4e96d53c1..02569a1721e8 100644
--- a/net-analyzer/netperf/ChangeLog
+++ b/net-analyzer/netperf/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-analyzer/netperf
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netperf/ChangeLog,v 1.42 2008/03/31 21:30:53 maekke Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netperf/ChangeLog,v 1.43 2009/08/26 00:49:05 jer Exp $
+
+*netperf-2.4.5 (26 Aug 2009)
+
+ 26 Aug 2009; Jeroen Roovers <jer@gentoo.org> netperf-2.4.4.ebuild,
+ +netperf-2.4.5.ebuild:
+ Version bump. Drop useless MY_P. Block sci-mathematics/snns (bug #248322).
+ Drop autotools since the gcc41 patch is no longer needed, incidentally fix
+ maintainer-mode (bug #255896). Drop unused flag-o-matic. Depend on sed.
31 Mar 2008; Markus Meier <maekke@gentoo.org> netperf-2.4.4.ebuild:
amd64 stable, bug #209035
diff --git a/net-analyzer/netperf/netperf-2.4.4.ebuild b/net-analyzer/netperf/netperf-2.4.4.ebuild
index 92c77f64ffb1..2388615e7393 100644
--- a/net-analyzer/netperf/netperf-2.4.4.ebuild
+++ b/net-analyzer/netperf/netperf-2.4.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netperf/netperf-2.4.4.ebuild,v 1.7 2008/03/31 21:30:53 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netperf/netperf-2.4.4.ebuild,v 1.8 2009/08/26 00:49:05 jer Exp $
inherit eutils flag-o-matic autotools
@@ -17,6 +17,8 @@ LICENSE="netperf"
SLOT="0"
IUSE=""
+RDEPEND="!sci-mathematics/snns"
+
S=${WORKDIR}/${MY_P}
src_unpack() {
diff --git a/net-analyzer/netperf/netperf-2.4.5.ebuild b/net-analyzer/netperf/netperf-2.4.5.ebuild
new file mode 100644
index 000000000000..9eedb4da2420
--- /dev/null
+++ b/net-analyzer/netperf/netperf-2.4.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netperf/netperf-2.4.5.ebuild,v 1.1 2009/08/26 00:49:05 jer Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Network performance benchmark including tests for TCP, UDP, sockets, ATM and more."
+SRC_URI="ftp://ftp.netperf.org/netperf/${P}.tar.gz"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+HOMEPAGE="http://www.netperf.org/"
+LICENSE="netperf"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=sys-apps/sed-4"
+RDEPEND="!sci-mathematics/snns"
+
+src_prepare() {
+ sed -i 's:^\(#define DEBUG_LOG_FILE "\)/tmp/netperf.debug:\1/var/log/netperf.debug:' src/netserver.c
+ epatch "${FILESDIR}"/${PN}-fix-scripts.patch
+
+ # Fixing paths in scripts
+ sed -i -e 's:^\(NETHOME=\).*:\1"/usr/bin":' \
+ doc/examples/sctp_stream_script \
+ doc/examples/tcp_range_script \
+ doc/examples/tcp_rr_script \
+ doc/examples/tcp_stream_script \
+ doc/examples/udp_rr_script \
+ doc/examples/udp_stream_script
+}
+
+src_install () {
+ einstall || die
+
+ # move netserver into sbin as we had it before 2.4 was released with its
+ # autoconf goodness
+ dodir /usr/sbin
+ mv "${D}"/usr/{bin,sbin}/netserver || die
+
+ # init.d / conf.d
+ newinitd "${FILESDIR}"/${PN}-2.2-init netperf
+ newconfd "${FILESDIR}"/${PN}-2.2-conf netperf
+
+ # documentation and example scripts
+ dodoc AUTHORS ChangeLog NEWS README Release_Notes
+ dodir /usr/share/doc/${PF}/examples
+ #Scripts no longer get installed by einstall
+ cp doc/examples/*_script "${D}"/usr/share/doc/${PF}/examples
+}