summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-08-09 17:44:49 +0000
committerJeroen Roovers <jer@gentoo.org>2010-08-09 17:44:49 +0000
commit4213c3f15005ad71035e8afc753aa745446722c7 (patch)
treefc05a260b1ead335e1d990b4627ea6a085353a6c /net-analyzer/netio
parentversion bump (diff)
downloadgentoo-2-4213c3f15005ad71035e8afc753aa745446722c7.tar.gz
gentoo-2-4213c3f15005ad71035e8afc753aa745446722c7.tar.bz2
gentoo-2-4213c3f15005ad71035e8afc753aa745446722c7.zip
Respect LDFLAGS (bug #331871). Add missing include.
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'net-analyzer/netio')
-rw-r--r--net-analyzer/netio/ChangeLog8
-rw-r--r--net-analyzer/netio/files/netio-1.26-linux-include.patch13
-rw-r--r--net-analyzer/netio/netio-1.26-r1.ebuild61
3 files changed, 81 insertions, 1 deletions
diff --git a/net-analyzer/netio/ChangeLog b/net-analyzer/netio/ChangeLog
index 5cd134a27a1c..828e2ea7f130 100644
--- a/net-analyzer/netio/ChangeLog
+++ b/net-analyzer/netio/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/netio
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netio/ChangeLog,v 1.22 2010/01/01 17:41:56 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netio/ChangeLog,v 1.23 2010/08/09 17:44:49 jer Exp $
+
+*netio-1.26-r1 (09 Aug 2010)
+
+ 09 Aug 2010; Jeroen Roovers <jer@gentoo.org> +netio-1.26-r1.ebuild,
+ +files/netio-1.26-linux-include.patch:
+ Respect LDFLAGS (bug #331871). Add missing include.
01 Jan 2010; Christian Faulhammer <fauli@gentoo.org> netio-1.26.ebuild:
Transfer Prefix keywords
diff --git a/net-analyzer/netio/files/netio-1.26-linux-include.patch b/net-analyzer/netio/files/netio-1.26-linux-include.patch
new file mode 100644
index 000000000000..dc0cd9813e52
--- /dev/null
+++ b/net-analyzer/netio/files/netio-1.26-linux-include.patch
@@ -0,0 +1,13 @@
+Add missing include (see inet(3)) - JeR
+
+
+--- a/netio.c 2005-08-30 16:47:18.000000000 +0200
++++ b/netio.c 2010-08-09 19:31:51.000000000 +0200
+@@ -199,6 +199,7 @@
+ #include <sys/time.h>
+ #include <time.h>
+ #include <netinet/in.h>
++#include <arpa/inet.h>
+ #include <netdb.h>
+
+ #define psock_errno(x) perror(x)
diff --git a/net-analyzer/netio/netio-1.26-r1.ebuild b/net-analyzer/netio/netio-1.26-r1.ebuild
new file mode 100644
index 000000000000..21ba7c3eacd8
--- /dev/null
+++ b/net-analyzer/netio/netio-1.26-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netio/netio-1.26-r1.ebuild,v 1.1 2010/08/09 17:44:49 jer Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs versionator
+
+MY_P="${PN}$(get_version_component_range 1)$(get_version_component_range 2)"
+DESCRIPTION="a network benchmark for DOS, OS/2, Windows NT and Unix that measures net througput with NetBIOS and TCP/IP protocols."
+HOMEPAGE="http://www.ars.de/ars/ars.nsf/docs/netio"
+SRC_URI="mirror://gentoo/${MY_P}.zip"
+
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND="app-arch/unzip
+ >=sys-apps/sed-4"
+RDEPEND=""
+
+S="${WORKDIR}"
+
+src_prepare() {
+ edos2unix *.c *.h
+
+ sed -i Makefile \
+ -e 's|\(CFLAGS\)=|\1+=|g' \
+ -e 's|\(CC\)=|\1?=|g' \
+ -e "s|LFLAGS=\"\"|LFLAGS?=\"${LDFLAGS}\"|g" \
+ || die "sed Makefile failed"
+ epatch "${FILESDIR}"/${P}-linux-include.patch
+}
+
+src_compile() {
+ emake linux \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ dobin netio || die "dobin failed"
+
+ # to be sure to comply with the license statement in netio.doc,
+ # just install everything included in the package to doc
+ dodoc netio.doc FILE_ID.DIZ getopt.h netb_1_c.h netbios.h netio.c \
+ netb_2_c.h netio.doc getopt.c Makefile netbios.c
+
+ # also install binaries
+ dodoc bin/os2-i386.exe bin/win32-i386.exe
+}
+
+pkg_postinst() {
+ echo
+ elog "NOTE: all files included in the upstream zip file have"
+ elog "been installed to /usr/share/doc/${PF}, as required by"
+ elog "the license."
+ echo
+}