summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-04-29 06:50:47 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-04-29 06:50:47 +0000
commitfe58bf2818132439161f971ae9c37c316b6637d9 (patch)
treecdae36bd3b9c5f3c40d9b0c5db692c03cd6cb93c /net-analyzer/nethogs
parent29 Apr 2009; Zac Medico <zmedico@gentoo.org> calibre-0.5.9-r1.ebuild: (diff)
downloadgentoo-2-fe58bf2818132439161f971ae9c37c316b6637d9.tar.gz
gentoo-2-fe58bf2818132439161f971ae9c37c316b6637d9.tar.bz2
gentoo-2-fe58bf2818132439161f971ae9c37c316b6637d9.zip
Version bump.
(Portage version: 2.1.6.11/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/nethogs')
-rw-r--r--net-analyzer/nethogs/ChangeLog19
-rw-r--r--net-analyzer/nethogs/files/nethogs-0.6.0-gcc34.diff34
-rw-r--r--net-analyzer/nethogs/files/nethogs-0.7.0-Makefile.patch83
-rw-r--r--net-analyzer/nethogs/nethogs-0.6.0.ebuild40
-rw-r--r--net-analyzer/nethogs/nethogs-0.7.0.ebuild34
5 files changed, 130 insertions, 80 deletions
diff --git a/net-analyzer/nethogs/ChangeLog b/net-analyzer/nethogs/ChangeLog
index e00c193d8c40..e3db60b06c33 100644
--- a/net-analyzer/nethogs/ChangeLog
+++ b/net-analyzer/nethogs/ChangeLog
@@ -1,16 +1,23 @@
# ChangeLog for net-analyzer/nethogs
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nethogs/ChangeLog,v 1.12 2008/12/10 22:44:15 maekke Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nethogs/ChangeLog,v 1.13 2009/04/29 06:50:47 ssuominen Exp $
+
+*nethogs-0.7.0 (29 Apr 2009)
+
+ 29 Apr 2009; Samuli Suominen <ssuominen@gentoo.org> -nethogs-0.6.0.ebuild,
+ -files/nethogs-0.6.0-gcc34.diff, +nethogs-0.7.0.ebuild,
+ +files/nethogs-0.7.0-Makefile.patch:
+ Version bump.
10 Dec 2008; Markus Meier <maekke@gentoo.org> nethogs-0.6.1_pre2.ebuild:
amd64/x86 stable, bug #249898
*nethogs-0.6.1_pre2 (05 Dec 2008)
- 05 Dec 2008; <ssuominen@gentoo.org> +files/nethogs-0.6.1_pre2-gcc43.patch,
- +nethogs-0.6.1_pre2.ebuild:
- Version bump with GCC 4.3 and GLIBC 2.8 patch wrt #249898, partly thanks
- to Pro <hyrurg at gmail.com>
+ 05 Dec 2008; Samuli Suominen <ssuominen@gentoo.org>
+ +files/nethogs-0.6.1_pre2-gcc43.patch, +nethogs-0.6.1_pre2.ebuild:
+ Version bump with GCC 4.3 and GLIBC 2.8 patch wrt #249898, thanks to
+ Pro <hyrurg at gmail.com>
12 Apr 2007; <welp@gentoo.org> nethogs-0.6.0.ebuild:
Stable on amd64
diff --git a/net-analyzer/nethogs/files/nethogs-0.6.0-gcc34.diff b/net-analyzer/nethogs/files/nethogs-0.6.0-gcc34.diff
deleted file mode 100644
index c85fb464010b..000000000000
--- a/net-analyzer/nethogs/files/nethogs-0.6.0-gcc34.diff
+++ /dev/null
@@ -1,34 +0,0 @@
---- decpcap.c~ 2005-04-04 01:53:06.000000000 -0300
-+++ decpcap.c 2005-04-04 01:56:13.000000000 -0300
-@@ -76,6 +76,7 @@
- break;
- default:
- // TODO
-+ break;
- }
- }
-
-@@ -98,6 +99,7 @@
- break;
- default:
- // TODO
-+ break;
- }
- }
-
-@@ -128,6 +130,7 @@
- break;
- default:
- // TODO
-+ break;
- }
- }
-
-@@ -173,6 +176,7 @@
- break;
- default:
- // TODO
-+ break;
- }
- }
-
diff --git a/net-analyzer/nethogs/files/nethogs-0.7.0-Makefile.patch b/net-analyzer/nethogs/files/nethogs-0.7.0-Makefile.patch
new file mode 100644
index 000000000000..5a3285a1cf9a
--- /dev/null
+++ b/net-analyzer/nethogs/files/nethogs-0.7.0-Makefile.patch
@@ -0,0 +1,83 @@
+Replace CFLAGS for CXX target with CXXFLAGS. Add LDFLAGS to respect them.
+Use DESTDIR correctly, and fix typing error of sbin. - ssuominen@gentoo.org
+
+diff -ur nethogs.orig/Makefile nethogs/Makefile
+--- nethogs.orig/Makefile 2009-03-12 23:08:17.000000000 +0000
++++ nethogs/Makefile 2009-04-29 09:41:11.000000000 +0000
+@@ -2,17 +2,17 @@
+ SUBVERSION := 7
+ MINORVERSION := 0
+
+-#DESTDIR := /usr
+-DESTDIR := /usr/local
+-
+-sbin := $(DESTDIR)/sbin
+-man8 := $(DESTDIR)/share/man/man8/
++prefix := /usr
++# prefix := /usr/local
++sbin := $(prefix)/sbin
++man8 := $(prefix)/share/man/man8
+
+ all: nethogs decpcap_test
+ # nethogs_testsum
+
+-CFLAGS=-g -Wall -Wextra
+-#CFLAGS=-O2
++CFLAGS += -Wall
++CXXFLAGS += -Wall
++
+ OBJS=packet.o connection.o process.o refresh.o decpcap.o cui.o inode2prog.o conninode.o
+ .PHONY: tgz
+
+@@ -24,37 +24,37 @@
+ echo "Not implemented"
+
+ install: nethogs nethogs.8
+- install -d -m 755 $(bin)
+- install -m 755 nethogs $(bin)
+- install -d -m 755 $(man8)
+- install -m 644 nethogs.8 $(man8)
++ install -d -m 755 $(DESTDIR)$(sbin)
++ install -m 755 nethogs $(DESTDIR)$(sbin)
++ install -d -m 755 $(DESTDIR)$(man8)
++ install -m 644 nethogs.8 $(DESTDIR)$(man8)
+
+ nethogs: nethogs.cpp $(OBJS)
+- $(CXX) $(CFLAGS) nethogs.cpp $(OBJS) -o nethogs -lpcap -lm -lncurses -DVERSION=\"$(VERSION)\" -DSUBVERSION=\"$(SUBVERSION)\" -DMINORVERSION=\"$(MINORVERSION)\"
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) nethogs.cpp $(OBJS) -o nethogs -lpcap -lm -lncurses -DVERSION=\"$(VERSION)\" -DSUBVERSION=\"$(SUBVERSION)\" -DMINORVERSION=\"$(MINORVERSION)\"
+ nethogs_testsum: nethogs_testsum.cpp $(OBJS)
+- $(CXX) $(CFLAGS) -g nethogs_testsum.cpp $(OBJS) -o nethogs_testsum -lpcap -lm -lncurses -DVERSION=\"$(VERSION)\" -DSUBVERSION=\"$(SUBVERSION)\" -DMINORVERSION=\"$(MINORVERSION)\"
++ $(CXX) $(CXXFLAGS) -g $(LDFLAGS) nethogs_testsum.cpp $(OBJS) -o nethogs_testsum -lpcap -lm -lncurses -DVERSION=\"$(VERSION)\" -DSUBVERSION=\"$(SUBVERSION)\" -DMINORVERSION=\"$(MINORVERSION)\"
+
+ decpcap_test: decpcap_test.cpp decpcap.o
+- $(CXX) $(CFLAGS) decpcap_test.cpp decpcap.o -o decpcap_test -lpcap -lm
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) decpcap_test.cpp decpcap.o -o decpcap_test -lpcap -lm
+
+ #-lefence
+
+ refresh.o: refresh.cpp refresh.h nethogs.h
+- $(CXX) $(CFLAGS) -c refresh.cpp
++ $(CXX) $(CXXFLAGS) -c refresh.cpp
+ process.o: process.cpp process.h nethogs.h
+- $(CXX) $(CFLAGS) -c process.cpp
++ $(CXX) $(CXXFLAGS) -c process.cpp
+ packet.o: packet.cpp packet.h nethogs.h
+- $(CXX) $(CFLAGS) -c packet.cpp
++ $(CXX) $(CXXFLAGS) -c packet.cpp
+ connection.o: connection.cpp connection.h nethogs.h
+- $(CXX) $(CFLAGS) -c connection.cpp
++ $(CXX) $(CXXFLAGS) -c connection.cpp
+ decpcap.o: decpcap.c decpcap.h
+ $(CC) $(CFLAGS) -c decpcap.c
+ inode2prog.o: inode2prog.cpp inode2prog.h nethogs.h
+- $(CXX) $(CFLAGS) -c inode2prog.cpp
++ $(CXX) $(CXXFLAGS) -c inode2prog.cpp
+ conninode.o: conninode.cpp nethogs.h conninode.h
+- $(CXX) $(CFLAGS) -c conninode.cpp
++ $(CXX) $(CXXFLAGS) -c conninode.cpp
+ cui.o: cui.cpp cui.h nethogs.h
+- $(CXX) $(CFLAGS) -c cui.cpp -DVERSION=\"$(VERSION)\" -DSUBVERSION=\"$(SUBVERSION)\" -DMINORVERSION=\"$(MINORVERSION)\"
++ $(CXX) $(CXXFLAGS) -c cui.cpp -DVERSION=\"$(VERSION)\" -DSUBVERSION=\"$(SUBVERSION)\" -DMINORVERSION=\"$(MINORVERSION)\"
+
+ .PHONY: clean
+ clean:
diff --git a/net-analyzer/nethogs/nethogs-0.6.0.ebuild b/net-analyzer/nethogs/nethogs-0.6.0.ebuild
deleted file mode 100644
index 0e04dc0c2a47..000000000000
--- a/net-analyzer/nethogs/nethogs-0.6.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nethogs/nethogs-0.6.0.ebuild,v 1.8 2007/04/12 17:59:22 welp Exp $
-
-inherit eutils toolchain-funcs
-
-HOMEPAGE="http://nethogs.sf.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-DESCRIPTION="A small 'net top' tool, grouping bandwidth by process"
-
-LICENSE="GPL-1"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-DEPEND="net-libs/libpcap"
-
-S="${WORKDIR}/${PN}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${P}-gcc34.diff
- # fix hardcoded CFLAGS and CC
- sed -i -e "s:-O2:${CFLAGS}:g" Makefile
- sed -i -e "s:g++:$(tc-getCXX):g" Makefile
- sed -i -e "s:gcc:$(tc-getCC):g" Makefile
-}
-
-src_compile() {
- emake || die "emake failed"
-}
-
-src_install() {
- # Not using make install or einstall because of the hardcoded paths in Makefile
- dosbin nethogs
- doman nethogs.8
- dodoc Changelog DESIGN README
-}
diff --git a/net-analyzer/nethogs/nethogs-0.7.0.ebuild b/net-analyzer/nethogs/nethogs-0.7.0.ebuild
new file mode 100644
index 000000000000..d350fa998b38
--- /dev/null
+++ b/net-analyzer/nethogs/nethogs-0.7.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nethogs/nethogs-0.7.0.ebuild,v 1.1 2009/04/29 06:50:47 ssuominen Exp $
+
+EAPI=2
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A small 'net top' tool, grouping bandwidth by process"
+HOMEPAGE="http://nethogs.sf.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="net-libs/libpcap
+ sys-libs/ncurses"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+}
+
+src_compile() {
+ tc-export CC CXX
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc Changelog DESIGN README
+}