summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuy Martin <gmsoft@gentoo.org>2003-04-08 08:53:49 +0000
committerGuy Martin <gmsoft@gentoo.org>2003-04-08 08:53:49 +0000
commit0924196a2e00de2601d38772da9092b60f7db9ea (patch)
tree97d6f20f87467e47b31e951a066e8c3ec2b74b33 /net-analyzer/netcat
parentAdded ipv6 support. Removed -static from gcc's command line. Added hppa to KE... (diff)
downloadgentoo-2-0924196a2e00de2601d38772da9092b60f7db9ea.tar.gz
gentoo-2-0924196a2e00de2601d38772da9092b60f7db9ea.tar.bz2
gentoo-2-0924196a2e00de2601d38772da9092b60f7db9ea.zip
Correcetd some mistakes. Added ~hppa KEYWORDS not hppa. Added support for static use flags instead of removing static build. Updated ChangeLog.
Diffstat (limited to 'net-analyzer/netcat')
-rw-r--r--net-analyzer/netcat/ChangeLog4
-rw-r--r--net-analyzer/netcat/netcat-110-r3.ebuild7
2 files changed, 6 insertions, 5 deletions
diff --git a/net-analyzer/netcat/ChangeLog b/net-analyzer/netcat/ChangeLog
index 21d2234f1397..34fcd70efe53 100644
--- a/net-analyzer/netcat/ChangeLog
+++ b/net-analyzer/netcat/ChangeLog
@@ -1,11 +1,11 @@
# ChangeLog for net-analyzer/netcat
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netcat/ChangeLog,v 1.12 2003/04/08 08:44:58 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netcat/ChangeLog,v 1.13 2003/04/08 08:53:49 gmsoft Exp $
*netcat-110-r3 (08 Arp 2003)
08 Arp 2003; Guy Martin <gmsoft@gentoo.org> netcat-110-r3.ebuild, files/digest-netcat-110-r3 :
- Added ipv6 support. Removed -static from gcc's command line. Added hppa to KEYWORDS.
+ Added ipv6 support. Added support for the static use flag. Added ~hppa to KEYWORDS.
Added the IUSE variable.
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/net-analyzer/netcat/netcat-110-r3.ebuild b/net-analyzer/netcat/netcat-110-r3.ebuild
index 0bbdd279a632..db87c193717a 100644
--- a/net-analyzer/netcat/netcat-110-r3.ebuild
+++ b/net-analyzer/netcat/netcat-110-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netcat/netcat-110-r3.ebuild,v 1.1 2003/04/08 08:44:58 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netcat/netcat-110-r3.ebuild,v 1.2 2003/04/08 08:53:49 gmsoft Exp $
MY_P=nc${PV}
S=${WORKDIR}/nc-${PV}
@@ -9,11 +9,11 @@ SRC_URI="http://www.l0pht.com/~weld/netcat/${MY_P}.tgz
ipv6?( ftp://sith.mimuw.edu.pl/pub/users/baggins/IPv6/nc-v6-20000918.patch.gz )"
HOMEPAGE="http://www.l0pht.com/~weld/netcat"
-IUSE="ipv6"
+IUSE="ipv6 static"
SLOT="0"
LICENSE="as-is"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha hppa"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa"
DEPEND="virtual/glibc"
@@ -35,6 +35,7 @@ src_compile() {
export XFLAGS="-DLINUX"
[ -n "`use ipv6`" ] && XFLAGS="${XFLAGS} -DINET6"
+ [ -n "`use static`" ] && export STATIC="-static"
CC="gcc ${CFLAGS}" make -e nc || die
}