summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-08-22 14:38:12 +0000
committerNick Hadaway <raker@gentoo.org>2002-08-22 14:38:12 +0000
commit38ebfef483e22d1f7feafba401bbd7d1b013fe4a (patch)
tree5c30ed8aafa22445543d3a6766ca8f7629c0527d /net-analyzer/nessus-core/nessus-core-1.2.4.ebuild
parentadded less (diff)
downloadgentoo-2-38ebfef483e22d1f7feafba401bbd7d1b013fe4a.tar.gz
gentoo-2-38ebfef483e22d1f7feafba401bbd7d1b013fe4a.tar.bz2
gentoo-2-38ebfef483e22d1f7feafba401bbd7d1b013fe4a.zip
New stable version of nessus released. Modified ebuild files to be more
upgrade friendly. Now using ${PV} for setting source directory and dependancies.
Diffstat (limited to 'net-analyzer/nessus-core/nessus-core-1.2.4.ebuild')
-rw-r--r--net-analyzer/nessus-core/nessus-core-1.2.4.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/net-analyzer/nessus-core/nessus-core-1.2.4.ebuild b/net-analyzer/nessus-core/nessus-core-1.2.4.ebuild
new file mode 100644
index 000000000000..5fd7688dad8d
--- /dev/null
+++ b/net-analyzer/nessus-core/nessus-core-1.2.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2000-2002 Achim Gottinger
+# Distributed under the GPL by Gentoo Technologies, Inc.
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-core/nessus-core-1.2.4.ebuild,v 1.1 2002/08/22 14:38:12 raker Exp $
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="A remote security scanner for Linux (nessus-core)"
+HOMEPAGE="http://www.nessus.org/"
+
+SRC_URI="ftp://ftp.nessus.org/pub/nessus/nessus-${PV}/src/${P}.tar.gz"
+
+DEPEND="=net-analyzer/libnasl-${PV}
+ X? ( x11-base/xfree )
+ gtk? ( =x11-libs/gtk+-1.2* )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc -sparc -sparc64"
+
+src_compile() {
+
+ use X && myconf="--with-x" || myconf="--without-x"
+
+ use gtk && myconf="--enable-gtk" || myconf="--disable-gtk"
+
+ econf || die "configure failed"
+
+ emake || die "emake failed"
+
+}
+
+src_install() {
+
+ make \
+ prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/state \
+ mandir=${D}/usr/share/man \
+ install || die "Install failed nessus-core"
+
+ cp ${ROOT}/config/nessusd.conf ${D}/etc/nessus/
+
+ cd ${S}
+ docinto nessus-core
+ dodoc README* UPGRADE_README CHANGES
+ dodoc doc/*.txt doc/ntp/*
+
+ insinto /etc/init.d
+ insopts -m 755
+ newins ${FILESDIR}/nessusd-r6 nessusd
+}