summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2006-10-29 17:02:11 +0000
committerPeter Volkov <pva@gentoo.org>2006-10-29 17:02:11 +0000
commit1e49df95628809cb018aad8aa7c328e30817ec9f (patch)
tree158621226785fb964a1cc48d8411ccea4efc541a /net-analyzer/ndsad
parentBump (finally). No ASP.NET support yet, need to get this in now to handle the... (diff)
downloadgentoo-2-1e49df95628809cb018aad8aa7c328e30817ec9f.tar.gz
gentoo-2-1e49df95628809cb018aad8aa7c328e30817ec9f.tar.bz2
gentoo-2-1e49df95628809cb018aad8aa7c328e30817ec9f.zip
Use autoools.eclass to take care of autotools stuff. Fixed bug #153255. Thank Evil Compile Person for report.
(Portage version: 2.1.1)
Diffstat (limited to 'net-analyzer/ndsad')
-rw-r--r--net-analyzer/ndsad/ChangeLog6
-rw-r--r--net-analyzer/ndsad/files/digest-ndsad-1.332
-rw-r--r--net-analyzer/ndsad/ndsad-1.33.ebuild17
3 files changed, 16 insertions, 9 deletions
diff --git a/net-analyzer/ndsad/ChangeLog b/net-analyzer/ndsad/ChangeLog
index 5787f43fb1eb..02a0fdc210f8 100644
--- a/net-analyzer/ndsad/ChangeLog
+++ b/net-analyzer/ndsad/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/ndsad
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ndsad/ChangeLog,v 1.5 2006/06/27 18:13:46 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ndsad/ChangeLog,v 1.6 2006/10/29 17:02:11 pva Exp $
+
+ 29 Oct 2006; Peter Volkov <pva@gentoo.org> ndsad-1.33.ebuild:
+ Use autoools.eclass to take care of autotools stuff. Fixed bug #153255.
+ Thank Evil Compile Person for report.
27 Jun 2006; Peter Volkov <pva@gentoo.org> ndsad-1.33.ebuild:
Removed system packages from DEPEND (autoconf/automake). Fix for bug 138202.
diff --git a/net-analyzer/ndsad/files/digest-ndsad-1.33 b/net-analyzer/ndsad/files/digest-ndsad-1.33
index 3531c16c4579..b55acc4fbe8c 100644
--- a/net-analyzer/ndsad/files/digest-ndsad-1.33
+++ b/net-analyzer/ndsad/files/digest-ndsad-1.33
@@ -1 +1,3 @@
MD5 18cd6d8c8959b4cbbaa4c940260b4d3f ndsad-1.33.tgz 214614
+RMD160 a968b431fb99a0947ee969a44809afce61c695a2 ndsad-1.33.tgz 214614
+SHA256 a46403ff15c03b45b479832f5e6d861ec4d6474ef953f7965ae0239c90b9026b ndsad-1.33.tgz 214614
diff --git a/net-analyzer/ndsad/ndsad-1.33.ebuild b/net-analyzer/ndsad/ndsad-1.33.ebuild
index 20ba9b86efb1..c2548500e10f 100644
--- a/net-analyzer/ndsad/ndsad-1.33.ebuild
+++ b/net-analyzer/ndsad/ndsad-1.33.ebuild
@@ -1,6 +1,10 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ndsad/ndsad-1.33.ebuild,v 1.4 2006/06/27 18:13:46 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ndsad/ndsad-1.33.ebuild,v 1.5 2006/10/29 17:02:11 pva Exp $
+
+WANT_AUTOCONF=2.5
+WANT_AUTOMAKE=1.9
+inherit autotools
DESCRIPTION="Cisco netflow probe from libpcap, ULOG, tee/divert sources."
HOMEPAGE="http://sourceforge.net/projects/ndsad"
@@ -14,15 +18,10 @@ IUSE=""
DEPEND=">=net-libs/libpcap-0.8"
src_unpack() {
- einfo "Regenerating autotools files..."
- export WANT_AUTOCONF=2.5
- export WANT_AUTOMAKE=1.7
-
unpack ${A}
-
cd ${S}
- # Puttind ndsad binary in sbin.
+ # Put ndsad binary in sbin.
sed -i "s/bin_PROGRAMS = ndsad/sbin_PROGRAMS = ndsad/" Makefile.am || \
die "Can not change bin->sbin in Makefile.am... sed failed"
@@ -33,7 +32,9 @@ src_unpack() {
sed -i "s:log /tmp/ndsad.log:log /var/log/ndsad.log:" ndsad.conf || \
die "Can not fix logging path in ndsad.conf... sed failed"
- ./preconf
+ aclocal
+ eautomake
+ eautoconf
}
src_compile() {