summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-27 12:46:06 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-27 12:46:06 +0000
commitd426cc6db1a7aedf6608740fdc8e95d757c49dfb (patch)
treec4fd63e444d275e5f4189a162e33566c5768f685 /net-analyzer/nbaudit/nbaudit-1.0.ebuild
parentcleanup (diff)
downloadgentoo-2-d426cc6db1a7aedf6608740fdc8e95d757c49dfb.tar.gz
gentoo-2-d426cc6db1a7aedf6608740fdc8e95d757c49dfb.tar.bz2
gentoo-2-d426cc6db1a7aedf6608740fdc8e95d757c49dfb.zip
cleanup
Diffstat (limited to 'net-analyzer/nbaudit/nbaudit-1.0.ebuild')
-rw-r--r--net-analyzer/nbaudit/nbaudit-1.0.ebuild21
1 files changed, 10 insertions, 11 deletions
diff --git a/net-analyzer/nbaudit/nbaudit-1.0.ebuild b/net-analyzer/nbaudit/nbaudit-1.0.ebuild
index 2eec12507227..fc7c83f94b9b 100644
--- a/net-analyzer/nbaudit/nbaudit-1.0.ebuild
+++ b/net-analyzer/nbaudit/nbaudit-1.0.ebuild
@@ -1,17 +1,16 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Bruce A. Locke <blocke@shivan.org>
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nbaudit/nbaudit-1.0.ebuild,v 1.5 2002/02/14 05:09:36 blocke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nbaudit/nbaudit-1.0.ebuild,v 1.6 2002/04/27 12:41:09 seemant Exp $
# Its officially called nat10 but the name conflicts with other projects
# so I'm following the *BSDs suggestion of calling it nbaudit
-A=nat10.tgz
-P=nat10
-S=${WORKDIR}/${P}
+MY_P=nat10
+S=${WORKDIR}/${MY_P}
DESCRIPTION="NetBIOS file sharing services scanner (nat10)"
-SRC_URI="http://www.tux.org/pub/security/secnet/tools/nat10/${A}"
+SRC_URI="http://www.tux.org/pub/security/secnet/tools/nat10/${MY_P}.tgz"
HOMEPAGE="http://www.tux.org/pub/security/secnet/tools/nat10"
DEPEND=""
@@ -22,17 +21,17 @@ src_compile() {
sed -e "s/# FLAGSM = -DLINUX -DSHADOW_PWD/FLAGSM = -DLINUX -DSHADOW_PWD -DNO_ASMSIGNALH/" -e "s/# LIBSM = -lshadow/LIBSM = -lshadow/" Makefile.old > Makefile
# NOTE: DO NOT SET CFLAGS OR THE PROGRAM WILL SEGFAULT
- try make all
+ make all || die
}
src_install () {
- mv nat nbaudit
- dobin nbaudit
+ mv nat nbaudit
+ dobin nbaudit
- mv nat.1 nbaudit.1
- doman nbaudit.1
+ mv nat.1 nbaudit.1
+ doman nbaudit.1
- dodoc README COPYING
+ dodoc README COPYING
}