summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2010-04-02 17:04:31 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2010-04-02 17:04:31 +0000
commit35bd4383fc890b855567dd394ea99293f13955ff (patch)
treee432e33f60b978f0a59d71fd6b72676e58d52327 /net-analyzer/nagios
parentVersion bump, plus remove old 2.x series (diff)
downloadgentoo-2-35bd4383fc890b855567dd394ea99293f13955ff.tar.gz
gentoo-2-35bd4383fc890b855567dd394ea99293f13955ff.tar.bz2
gentoo-2-35bd4383fc890b855567dd394ea99293f13955ff.zip
Version bump, plus remove old 2.x series
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/nagios')
-rw-r--r--net-analyzer/nagios/ChangeLog10
-rw-r--r--net-analyzer/nagios/nagios-2.12.ebuild29
-rw-r--r--net-analyzer/nagios/nagios-3.2.1.ebuild53
3 files changed, 61 insertions, 31 deletions
diff --git a/net-analyzer/nagios/ChangeLog b/net-analyzer/nagios/ChangeLog
index 208b0b461d9d..cc7088ed3060 100644
--- a/net-analyzer/nagios/ChangeLog
+++ b/net-analyzer/nagios/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/nagios
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios/ChangeLog,v 1.85 2009/08/13 14:51:20 dertobi123 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios/ChangeLog,v 1.86 2010/04/02 17:04:31 dertobi123 Exp $
+
+*nagios-3.2.1 (02 Apr 2010)
+
+ 02 Apr 2010; Tobias Scherbaum <dertobi123@gentoo.org> -nagios-2.12.ebuild,
+ +nagios-3.2.1.ebuild:
+ Version bump, plus remove old 2.x series
*nagios-3.2.0 (13 Aug 2009)
diff --git a/net-analyzer/nagios/nagios-2.12.ebuild b/net-analyzer/nagios/nagios-2.12.ebuild
deleted file mode 100644
index a66e36ce71de..000000000000
--- a/net-analyzer/nagios/nagios-2.12.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios/nagios-2.12.ebuild,v 1.5 2008/05/22 18:34:52 maekke Exp $
-
-DESCRIPTION="The Nagios metapackage - merge this to pull install all of the
-nagios packages"
-HOMEPAGE="http://www.nagios.org"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~ppc ppc64 sparc x86"
-IUSE=""
-
-RDEPEND="~net-analyzer/nagios-core-${PV}
- >=net-analyzer/nagios-plugins-1.4
- >=net-analyzer/nagios-nrpe-1.8
- >=net-analyzer/nagios-nsca-2.3
- >=net-analyzer/nagios-imagepack-1.0"
-
-pkg_postrm() {
- elog "Note: this is a META ebuild for ${P}."
- elog "to remove it completely or before re-emerging"
- elog "either use 'depclean', or remove/re-emerge these packages:"
- elog
- for dep in ${RDEPEND}; do
- elog " ${dep}"
- done
- echo
-}
diff --git a/net-analyzer/nagios/nagios-3.2.1.ebuild b/net-analyzer/nagios/nagios-3.2.1.ebuild
new file mode 100644
index 000000000000..f500ae3775a0
--- /dev/null
+++ b/net-analyzer/nagios/nagios-3.2.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios/nagios-3.2.1.ebuild,v 1.1 2010/04/02 17:04:31 dertobi123 Exp $
+
+inherit multilib
+
+DESCRIPTION="The Nagios metapackage - merge this to pull install all of the nagios packages"
+HOMEPAGE="http://www.nagios.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="~net-analyzer/nagios-core-${PV}
+ >=net-analyzer/nagios-plugins-1.4.13-r1
+ >=net-analyzer/nagios-imagepack-1.0-r100"
+
+pkg_setup() {
+ # Avoid upgrading from Nagios <3 as the directory structure has changed
+ if has_version '<net-analyzer/nagios-3.0' ; then
+ if [[ "${FORCE_UPGRADE}" ]] ; then
+ echo
+ ewarn "you are upgrading from an incompatible version and have"
+ ewarn "FORCE_UPGRADE set, will build this package while Nagios is running."
+ echo
+ else
+ echo
+ eerror "You are upgrading from an incompatible version."
+ eerror "Please be advised that installation paths have changed to a more FHS"
+ eerror "compliant structure and you won't be able to easily upgrade to"
+ eerror "Nagios 3 therefore. You will have to change your configuration"
+ eerror "to reflect this change, for example Nagios plugins are now installed"
+ eerror "into /usr/$(get_libdir)/nagios/plugins/ instead of /usr/nagios/libexec."
+ echo
+ eerror "If you want to upgrade now, emerge nagios with:"
+ eerror " FORCE_UPGRADE=1 emerge nagios"
+ die "Upgrading from an incompatible version!"
+ echo
+ fi
+ fi
+}
+
+pkg_postrm() {
+ elog "Note: this is a META ebuild for ${P}."
+ elog "to remove it completely or before re-emerging"
+ elog "either use 'depclean', or remove/re-emerge these packages:"
+ elog
+ for dep in ${RDEPEND}; do
+ elog " ${dep}"
+ done
+ echo
+}