summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-10-19 23:36:01 +0000
committerJeroen Roovers <jer@gentoo.org>2010-10-19 23:36:01 +0000
commitae31ef10e8a4c30d58e2cdd18650f5eaa0df8aeb (patch)
tree102f0c933377850358a381a9efb386f594fb6281 /net-analyzer/nagios-sap-ccms-plugin
parentVersion bump to add patch for CVE-2010-3904 priviledge escalation (diff)
downloadgentoo-2-ae31ef10e8a4c30d58e2cdd18650f5eaa0df8aeb.tar.gz
gentoo-2-ae31ef10e8a4c30d58e2cdd18650f5eaa0df8aeb.tar.bz2
gentoo-2-ae31ef10e8a4c30d58e2cdd18650f5eaa0df8aeb.zip
Version bump by Elias Probst (bug #283557). Fix quoting issue. Use system iniparser (bug #259717). Respect LDFLAGS (bug #337888), CC.
(Portage version: 2.2_rc98/cvs/Linux i686)
Diffstat (limited to 'net-analyzer/nagios-sap-ccms-plugin')
-rw-r--r--net-analyzer/nagios-sap-ccms-plugin/ChangeLog12
-rw-r--r--net-analyzer/nagios-sap-ccms-plugin/files/nagios-sap-ccms-plugin-0.8-gentoo.patch61
-rw-r--r--net-analyzer/nagios-sap-ccms-plugin/nagios-sap-ccms-plugin-0.8.ebuild63
3 files changed, 134 insertions, 2 deletions
diff --git a/net-analyzer/nagios-sap-ccms-plugin/ChangeLog b/net-analyzer/nagios-sap-ccms-plugin/ChangeLog
index 85620a0d52bc..52ba1a00f315 100644
--- a/net-analyzer/nagios-sap-ccms-plugin/ChangeLog
+++ b/net-analyzer/nagios-sap-ccms-plugin/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-analyzer/nagios-sap-ccms-plugin
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-sap-ccms-plugin/ChangeLog,v 1.6 2009/03/07 14:34:57 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-sap-ccms-plugin/ChangeLog,v 1.7 2010/10/19 23:36:01 jer Exp $
+
+*nagios-sap-ccms-plugin-0.8 (19 Oct 2010)
+
+ 19 Oct 2010; Jeroen Roovers <jer@gentoo.org>
+ +nagios-sap-ccms-plugin-0.8.ebuild,
+ +files/nagios-sap-ccms-plugin-0.8-gentoo.patch:
+ Version bump by Elias Probst (bug #283557). Fix quoting issue. Use system
+ iniparser (bug #259717). Respect LDFLAGS (bug #337888), CC.
07 Mar 2009; Markus Meier <maekke@gentoo.org>
nagios-sap-ccms-plugin-0.7.3-r1.ebuild:
diff --git a/net-analyzer/nagios-sap-ccms-plugin/files/nagios-sap-ccms-plugin-0.8-gentoo.patch b/net-analyzer/nagios-sap-ccms-plugin/files/nagios-sap-ccms-plugin-0.8-gentoo.patch
new file mode 100644
index 000000000000..8ded76b3b7d1
--- /dev/null
+++ b/net-analyzer/nagios-sap-ccms-plugin/files/nagios-sap-ccms-plugin-0.8-gentoo.patch
@@ -0,0 +1,61 @@
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -1,5 +1,5 @@
+
+-VERSION=0.7.3
++VERSION=0.8
+ PLATFORM=$(shell uname -m)
+
+
+@@ -33,12 +33,10 @@
+ SUBDIRS = sap_moni
+ #C-Compiler
+
+-CC=gcc -DSAP_RFC_TIME
+-X_CFLAGS = $(CFLAGS)
++X_CFLAGS = $(CFLAGS) $(LDFLAGS) -DSAP_RFC_TIME
+ SHARED_OBJECTS=libs/$(PLATFORM)/librfccm.so
+
+ ifeq ($(patsubst i%86,x86,$(PLATFORM)), x86)
+- CC=gcc -DSAP_RFC_TIME
+ SHARED_OBJECTS=libs/x86/librfccm.so
+ endif
+
+--- a/src/sap_moni/Makefile 2009-03-16 12:34:26.000000000 +0100
++++ b/src/sap_moni/Makefile 2010-10-20 01:24:14.000000000 +0200
+@@ -1,23 +1,16 @@
+-PLATFORM=$(shell uname -m)
+-
+ #used files
+-SRC_INI = iniparser.c dictionary.c strlib.c
++SRC_INI = dictionary.c strlib.c
+ OBJ_INI = $(SRC_INI:.c=.o)
+ OBJ=ctype_b.o agnt_rfc.o agnt_mon.o $(OBJ_INI)
+
+ SHARED = sap_moni.so
+
+ #C-Compiler
+-CC=gcc -DSAP_RFC_TIME
+-X_CFLAGS=$(CFLAGS) -fPIC
+-
+-ifeq ($(PLATFORM),ppc64)
+- CC=gcc -m64 -DSAP_RFC_TIME
+-endif
++X_CFLAGS=$(CFLAGS) -fPIC -DSAP_RFC_TIME
+
+ #Rules
+ shared: $(OBJ)
+- $(CC) -shared $ $(X_CFLAGS) -o $(SHARED) $(OBJ) -ldl -lm
++ $(CC) -shared $ $(X_CFLAGS) $(LDFLAGS) -o $(SHARED) $(OBJ) -ldl -lm -liniparser
+
+
+ .SUFFIXES: .c .o
+@@ -26,7 +19,7 @@
+
+ #Dependencies
+ agnt_rfc.o: saprfc.h sapitab.h agnt_def.h
+-agnt_mon.o: agnt_def.h iniparser.h sapitab.h
++agnt_mon.o: agnt_def.h sapitab.h
+
+
+ #------
diff --git a/net-analyzer/nagios-sap-ccms-plugin/nagios-sap-ccms-plugin-0.8.ebuild b/net-analyzer/nagios-sap-ccms-plugin/nagios-sap-ccms-plugin-0.8.ebuild
new file mode 100644
index 000000000000..8492e0beba51
--- /dev/null
+++ b/net-analyzer/nagios-sap-ccms-plugin/nagios-sap-ccms-plugin-0.8.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-sap-ccms-plugin/nagios-sap-ccms-plugin-0.8.ebuild,v 1.1 2010/10/19 23:36:01 jer Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+MY_P="sap-ccms-plugin-${PV}"
+
+DESCRIPTION="Nagios plugin that provides an interface to SAP CCMS
+Infrastructure"
+HOMEPAGE="http://sourceforge.net/projects/nagios-sap-ccms/"
+SRC_URI="mirror://sourceforge/nagios-sap-ccms/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="
+ net-analyzer/nagios-core
+ dev-libs/iniparser
+"
+RDEPEND=${DEPEND}
+
+S="${WORKDIR}/${PN/-plugin*}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i src/sap_moni/* \
+ -e 's|#include "iniparser.h"|#include <iniparser.h>|g' \
+ || die "sed sap_moni/"
+}
+
+src_compile() {
+ emake -C src CC=$(tc-getCC) || die "emake failed"
+}
+
+src_install() {
+ cd "${S}/src"
+ exeinto /usr/$(get_libdir)/nagios/plugins
+
+ for file in {check_sap{,_cons,_instance,_instance_cons,_mult_no_thr,_multiple,_system,_system_cons},create_cfg,sap_change_thr}
+ do
+ doexe ${file}
+ done
+
+ chown -R root:nagios "${D}"/usr/$(get_libdir)/nagios/plugins || die "Failed Chown of ${D}usr/$(get_libdir)/nagios/plugins"
+
+ dolib.so sap_moni.so
+ cd "${S}/config"
+
+ dodir /etc/sapmon
+ insinto /etc/sapmon
+ doins "${S}"/config/*
+}
+
+pkg_postinst() {
+ elog "Have a look at /etc/sapmon for configuring ${PN}"
+ elog "Further information can be found at"
+ elog "http://nagios-sap-ccms.sourceforge.net/"
+}