summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2008-06-28 09:48:18 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2008-06-28 09:48:18 +0000
commit455928512e97e671e9e40db3a561c725f863ac6f (patch)
treecbc43abf6eb72771b6618cbe9780ec6979b158c8 /net-analyzer/nagios-plugins-snmp
parentAdd a warning to satisfy bug #225769. (diff)
downloadgentoo-2-455928512e97e671e9e40db3a561c725f863ac6f.tar.gz
gentoo-2-455928512e97e671e9e40db3a561c725f863ac6f.tar.bz2
gentoo-2-455928512e97e671e9e40db3a561c725f863ac6f.zip
Version bump, added ~amd64, added eautoreconf run due to maintainer mode, migrated to nagios-3, fix quotation.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r5 x86_64)
Diffstat (limited to 'net-analyzer/nagios-plugins-snmp')
-rw-r--r--net-analyzer/nagios-plugins-snmp/ChangeLog11
-rw-r--r--net-analyzer/nagios-plugins-snmp/nagios-plugins-snmp-0.6.0.ebuild48
2 files changed, 57 insertions, 2 deletions
diff --git a/net-analyzer/nagios-plugins-snmp/ChangeLog b/net-analyzer/nagios-plugins-snmp/ChangeLog
index 5067883d6598..5c1209e88c70 100644
--- a/net-analyzer/nagios-plugins-snmp/ChangeLog
+++ b/net-analyzer/nagios-plugins-snmp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/nagios-plugins-snmp
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins-snmp/ChangeLog,v 1.3 2007/06/30 16:37:45 dertobi123 Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins-snmp/ChangeLog,v 1.4 2008/06/28 09:48:18 dertobi123 Exp $
+
+*nagios-plugins-snmp-0.6.0 (28 Jun 2008)
+
+ 28 Jun 2008; Tobias Scherbaum <dertobi123@gentoo.org>
+ +nagios-plugins-snmp-0.6.0.ebuild:
+ Version bump, added ~amd64, added eautoreconf run due to maintainer mode,
+ migrated to nagios-3, fix quotation.
30 Jun 2007; Tobias Scherbaum <dertobi123@gentoo.org>
nagios-plugins-snmp-0.5.5.ebuild:
diff --git a/net-analyzer/nagios-plugins-snmp/nagios-plugins-snmp-0.6.0.ebuild b/net-analyzer/nagios-plugins-snmp/nagios-plugins-snmp-0.6.0.ebuild
new file mode 100644
index 000000000000..49f6c020c9d2
--- /dev/null
+++ b/net-analyzer/nagios-plugins-snmp/nagios-plugins-snmp-0.6.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins-snmp/nagios-plugins-snmp-0.6.0.ebuild,v 1.1 2008/06/28 09:48:18 dertobi123 Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="Additional Nagios plugins for monitoring SNMP capable devices"
+HOMEPAGE="http://nagios.manubulon.com"
+SRC_URI="http://nagios.manubulon.com/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="net-analyzer/net-snmp"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/nagios-plugins-snmp
+
+pkg_setup() {
+ enewgroup nagios
+ enewuser nagios -1 /bin/bash /var/nagios/home nagios
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ --libexecdir=/usr/$(get_libdir)/nagios/plugins \
+ --sysconfdir=/etc/nagios || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ chown -R root:nagios "${D}"/usr/$(get_libdir)/nagios/plugins || die "Failed Chown of ${D}usr/$(get_libdir)/nagios/plugins"
+ chmod -R o-rwx "${D}"/usr/$(get_libdir)/nagios/plugins || "Failed Chmod of ${D}usr/$(get_libdir)/nagios/plugins"
+
+ dodoc README NEWS AUTHORS
+}