summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-05-20 17:20:49 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-05-20 17:20:49 +0000
commit8c9cedbbdac3637c595e4a9db3f6c7c8be755310 (patch)
treea51afad1c5d70e4c167620fded1049ceaf0905a6 /net-analyzer/nagios-check_fail2ban
parentReverting x86 stabilisation (bug #316453). (diff)
downloadgentoo-2-8c9cedbbdac3637c595e4a9db3f6c7c8be755310.tar.gz
gentoo-2-8c9cedbbdac3637c595e4a9db3f6c7c8be755310.tar.bz2
gentoo-2-8c9cedbbdac3637c595e4a9db3f6c7c8be755310.zip
Bug #320749: Fix multilib-strict usage.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/nagios-check_fail2ban')
-rw-r--r--net-analyzer/nagios-check_fail2ban/ChangeLog6
-rw-r--r--net-analyzer/nagios-check_fail2ban/nagios-check_fail2ban-2.ebuild10
2 files changed, 12 insertions, 4 deletions
diff --git a/net-analyzer/nagios-check_fail2ban/ChangeLog b/net-analyzer/nagios-check_fail2ban/ChangeLog
index 197e1415e5fb..3e60d4177587 100644
--- a/net-analyzer/nagios-check_fail2ban/ChangeLog
+++ b/net-analyzer/nagios-check_fail2ban/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/nagios-check_fail2ban
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-check_fail2ban/ChangeLog,v 1.1 2010/05/12 08:47:16 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-check_fail2ban/ChangeLog,v 1.2 2010/05/20 17:20:49 robbat2 Exp $
+
+ 20 May 2010; Robin H. Johnson <robbat2@gentoo.org>
+ nagios-check_fail2ban-2.ebuild:
+ Bug #320749: Fix multilib-strict usage.
*nagios-check_fail2ban-2 (12 May 2010)
diff --git a/net-analyzer/nagios-check_fail2ban/nagios-check_fail2ban-2.ebuild b/net-analyzer/nagios-check_fail2ban/nagios-check_fail2ban-2.ebuild
index ca800134873c..6873de536d60 100644
--- a/net-analyzer/nagios-check_fail2ban/nagios-check_fail2ban-2.ebuild
+++ b/net-analyzer/nagios-check_fail2ban/nagios-check_fail2ban-2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-check_fail2ban/nagios-check_fail2ban-2.ebuild,v 1.1 2010/05/12 08:47:16 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-check_fail2ban/nagios-check_fail2ban-2.ebuild,v 1.2 2010/05/20 17:20:49 robbat2 Exp $
EAPI="2"
-inherit autotools
+inherit multilib autotools
DESCRIPTION="A nagios plugin for checking the fail2ban daemon"
HOMEPAGE="http://bb.xnull.de/projects/check_fail2ban/"
@@ -25,5 +25,9 @@ src_prepare() {
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ emake \
+ DESTDIR="${D}" \
+ nagiosdir="/usr/$(get_libdir)/nagios/plugins/" \
+ install \
+ || die "emake install failed"
}