summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2010-05-30 06:31:01 +0000
committerBenedikt Boehm <hollow@gentoo.org>2010-05-30 06:31:01 +0000
commitcc805e9a6b9d6d065791c51f754f2a57491c0cca (patch)
treeeac9984ef0740c7d25053b921ec2baef66568a94 /net-analyzer/nagios-check_fail2ban/nagios-check_fail2ban-3.ebuild
parentversion bump (fixes #320239) (diff)
downloadgentoo-2-cc805e9a6b9d6d065791c51f754f2a57491c0cca.tar.gz
gentoo-2-cc805e9a6b9d6d065791c51f754f2a57491c0cca.tar.bz2
gentoo-2-cc805e9a6b9d6d065791c51f754f2a57491c0cca.zip
fix #320749
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'net-analyzer/nagios-check_fail2ban/nagios-check_fail2ban-3.ebuild')
-rw-r--r--net-analyzer/nagios-check_fail2ban/nagios-check_fail2ban-3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-analyzer/nagios-check_fail2ban/nagios-check_fail2ban-3.ebuild b/net-analyzer/nagios-check_fail2ban/nagios-check_fail2ban-3.ebuild
new file mode 100644
index 000000000000..7d190eb9efbd
--- /dev/null
+++ b/net-analyzer/nagios-check_fail2ban/nagios-check_fail2ban-3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-check_fail2ban/nagios-check_fail2ban-3.ebuild,v 1.1 2010/05/30 06:31:01 hollow Exp $
+
+EAPI="2"
+
+inherit multilib autotools
+
+DESCRIPTION="A nagios plugin for checking the fail2ban daemon"
+HOMEPAGE="http://bb.xnull.de/projects/check_fail2ban/"
+SRC_URI="http://bb.xnull.de/projects/check_fail2ban/dist/check_fail2ban-${PV}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=net-analyzer/nagios-plugins-1.4.13-r1"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/check_fail2ban-${PV}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}