summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2006-02-24 13:58:51 +0000
committerChris White <chriswhite@gentoo.org>2006-02-24 13:58:51 +0000
commit9034ace5dff1f79106012dc5a4b144a73ef3dc57 (patch)
tree04eb39c5ed57d4f79d07cacc77802f6b4ac3978c /net-analyzer/mwcollect/mwcollect-3.0.4.ebuild
parentStable on hppa (preparation for bug #119461). (diff)
downloadgentoo-2-9034ace5dff1f79106012dc5a4b144a73ef3dc57.tar.gz
gentoo-2-9034ace5dff1f79106012dc5a4b144a73ef3dc57.tar.bz2
gentoo-2-9034ace5dff1f79106012dc5a4b144a73ef3dc57.zip
Version bump to 3.0.4.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'net-analyzer/mwcollect/mwcollect-3.0.4.ebuild')
-rw-r--r--net-analyzer/mwcollect/mwcollect-3.0.4.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/net-analyzer/mwcollect/mwcollect-3.0.4.ebuild b/net-analyzer/mwcollect/mwcollect-3.0.4.ebuild
new file mode 100644
index 000000000000..d40f13574d17
--- /dev/null
+++ b/net-analyzer/mwcollect/mwcollect-3.0.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mwcollect/mwcollect-3.0.4.ebuild,v 1.1 2006/02/24 13:58:51 chriswhite Exp $
+
+inherit eutils
+
+DESCRIPTION="mwcollect collects worms and other autonomous spreading malware"
+HOMEPAGE="http://www.mwcollect.org/"
+SRC_URI="http://download.mwcollect.org/${P}.tar.bz2"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="debug"
+# has issues right now
+#IUSE="debug prelude"
+
+DEPEND="dev-libs/libpcre
+ net-misc/curl
+ >=sys-libs/libcap-1"
+ # has issues right now
+ # prelude?( >=dev-libs/libprelude-0.9 )"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e "s:CXXFLAGS += -I./src/include:CXXFLAGS += ${CXXFLAGS} -I./src/include:" \
+ Makefile || die "custom CFLAGS patching failed"
+
+ sed -i \
+ -e "s:%loadModule(\":%loadModule(\"\/usr\/$(get_libdir)\/mwcollect\/:g" \
+ conf/mwcollect.conf || die "module load directory failed"
+}
+
+src_compile() {
+ use debug && export DEBUG="y"
+ # has issues right now
+ #use prelude && export MODULES="log-prelude"
+ emake || die "Make failed"
+}
+
+src_install() {
+ dosbin bin/mwcollectd
+ insinto /usr/$(get_libdir)/mwcollect
+ doins bin/modules/*
+
+ insinto /etc/mwcollect
+ doins conf/* \
+ || die "config file installation failed"
+
+ dodoc README* doc/core-design.txt
+ doman doc/mwcollectd.1
+
+ newinitd ${FILESDIR}/initd mwcollectd
+ insinto /etc/conf.d
+ newins ${FILESDIR}/confd mwcollectd
+}