summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2006-07-09 21:19:18 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2006-07-09 21:19:18 +0000
commit3340ee48ea4cf8e7c76628270f46d24e36f9fb4f (patch)
treef28683d274ffe28c63362f8782a00eec386325d5 /net-analyzer/mtr/mtr-0.71.ebuild
parentRemove old versions. (diff)
downloadgentoo-2-3340ee48ea4cf8e7c76628270f46d24e36f9fb4f.tar.gz
gentoo-2-3340ee48ea4cf8e7c76628270f46d24e36f9fb4f.tar.bz2
gentoo-2-3340ee48ea4cf8e7c76628270f46d24e36f9fb4f.zip
0.71 version bump. Both patches are now in upstream. Fixes bug 139781. Thanks to Taku Murakami <murakami.taku at gmail at com>.
(Portage version: 2.1-r1)
Diffstat (limited to 'net-analyzer/mtr/mtr-0.71.ebuild')
-rw-r--r--net-analyzer/mtr/mtr-0.71.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-analyzer/mtr/mtr-0.71.ebuild b/net-analyzer/mtr/mtr-0.71.ebuild
new file mode 100644
index 000000000000..7a59b63c67ef
--- /dev/null
+++ b/net-analyzer/mtr/mtr-0.71.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mtr/mtr-0.71.ebuild,v 1.1 2006/07/09 21:19:18 vanquirius Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="My TraceRoute. Excellent network diagnostic tool."
+HOMEPAGE="http://www.bitwizard.nl/mtr/"
+SRC_URI="ftp://ftp.bitwizard.nl/mtr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc-macos ~s390 ~sparc ~x86"
+IUSE="gtk ipv6"
+
+DEPEND="dev-util/pkgconfig
+ >=sys-libs/ncurses-5.2
+ gtk? ( >=x11-libs/gtk+-2 )"
+
+src_compile() {
+ autoconf || die "autoconf failed"
+
+ local myconf
+ use gtk || myconf="${myconf} --without-gtk"
+
+ use ppc-macos && append-flags "-DBIND_8_COMPAT"
+ append-ldflags $(bindnow-flags)
+
+ econf ${myconf} \
+ $(use_enable gtk gtk2) \
+ $(use_enable ipv6) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ # this binary is universal. ie: it does both console and gtk.
+ make DESTDIR="${D}" sbindir=/usr/bin install || die "make install failed"
+
+ insinto /usr/share/${PN} ; doins img/mtr_icon.xpm
+
+ fowners root:wheel /usr/bin/mtr
+ fperms 4710 /usr/bin/mtr
+
+ dodoc AUTHORS ChangeLog FORMATS NEWS README SECURITY TODO
+}