summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-11-09 17:57:07 +0000
committerPeter Volkov <pva@gentoo.org>2010-11-09 17:57:07 +0000
commitcfe63e9f9ce877a1f300014e08a7ba83c4ba847a (patch)
tree48764da6e62d00ce140e41e1e99498b7a8468e2b /net-analyzer/mrtg
parentNew package: sci-mathematics/topcom, revised import from sci overlay, fixes b... (diff)
downloadgentoo-2-cfe63e9f9ce877a1f300014e08a7ba83c4ba847a.tar.gz
gentoo-2-cfe63e9f9ce877a1f300014e08a7ba83c4ba847a.tar.bz2
gentoo-2-cfe63e9f9ce877a1f300014e08a7ba83c4ba847a.zip
Fix static linkage and rpath, bug #332287, thank Diego Elio Pettenò for report.
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/mrtg')
-rw-r--r--net-analyzer/mrtg/ChangeLog10
-rw-r--r--net-analyzer/mrtg/files/mrtg-2.16.4-disable-static.patch29
-rw-r--r--net-analyzer/mrtg/files/mrtg-2.16.4-no-rpath.patch46
-rw-r--r--net-analyzer/mrtg/mrtg-2.16.4-r1.ebuild48
4 files changed, 132 insertions, 1 deletions
diff --git a/net-analyzer/mrtg/ChangeLog b/net-analyzer/mrtg/ChangeLog
index 5233e154b5fe..29093d257ef1 100644
--- a/net-analyzer/mrtg/ChangeLog
+++ b/net-analyzer/mrtg/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-analyzer/mrtg
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mrtg/ChangeLog,v 1.102 2010/11/09 14:16:06 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mrtg/ChangeLog,v 1.103 2010/11/09 17:57:07 pva Exp $
+
+*mrtg-2.16.4-r1 (09 Nov 2010)
+
+ 09 Nov 2010; Peter Volkov <pva@gentoo.org> +mrtg-2.16.4-r1.ebuild,
+ +files/mrtg-2.16.4-disable-static.patch,
+ +files/mrtg-2.16.4-no-rpath.patch:
+ Fix static linkage and rpath, bug #332287, thank Diego Elio Pettenò for
+ report.
09 Nov 2010; Peter Volkov <pva@gentoo.org> mrtg-2.16.4.ebuild:
Depend on >=dev-perl/Socket6-0.20 to avoid duplicate definitions, bug
diff --git a/net-analyzer/mrtg/files/mrtg-2.16.4-disable-static.patch b/net-analyzer/mrtg/files/mrtg-2.16.4-disable-static.patch
new file mode 100644
index 000000000000..af513a38c6e0
--- /dev/null
+++ b/net-analyzer/mrtg/files/mrtg-2.16.4-disable-static.patch
@@ -0,0 +1,29 @@
+http://oss.oetiker.ch/mrtg-trac/ticket/97
+
+--- configure.in 2010-11-09 16:25:34 +0000
++++ configure.in 2010-11-09 16:35:39 +0000
+@@ -98,6 +98,8 @@
+ AC_ARG_WITH(png-inc,[ --with-png-inc=DIR location of the libpng include files],
+ [CPPFLAGS="${CPPFLAGS} -I${withval}"])
+
++AC_ARG_ENABLE(static,[ --disable-static avoid rateup static linkage with gd],
++ [AVOID_STATIC="${enableval}"],[AVOID_STATIC="no"])
+
+ LIBS="${LIBS} ${MATHLIBS}"
+
+@@ -127,9 +129,11 @@
+ CPPFLAGS="$CPPFLAGS -DGFORM_GD=gdImageGif"
+ fi
+
+-AC_CHECK_LIB(gd,gdImageGd,[
+- GLIBS="-Wl,-Bstatic ${GLIBS} -Wl,-Bdynamic"
+- ],:,[-Wl,-Bstatic ${GLIBS} -Wl,-Bdynamic])
++if test x$AVOID_STATIC = xyes; then
++ AC_CHECK_LIB(gd,gdImageGd,[
++ GLIBS="-Wl,-Bstatic ${GLIBS} -Wl,-Bdynamic"
++ ],:,[-Wl,-Bstatic ${GLIBS} -Wl,-Bdynamic])
++fi
+
+ if test x$GDFORM_EXT = xpng; then
+ CPPFLAGS="$CPPFLAGS -DGFORM_GD=gdImagePng"
+
diff --git a/net-analyzer/mrtg/files/mrtg-2.16.4-no-rpath.patch b/net-analyzer/mrtg/files/mrtg-2.16.4-no-rpath.patch
new file mode 100644
index 000000000000..1f634134269d
--- /dev/null
+++ b/net-analyzer/mrtg/files/mrtg-2.16.4-no-rpath.patch
@@ -0,0 +1,46 @@
+http://oss.oetiker.ch/mrtg-trac/ticket/98
+
+--- Makefile.in 2010-11-09 16:25:34 +0000
++++ Makefile.in 2010-11-09 17:13:17 +0000
+@@ -21,7 +21,7 @@
+ CPPFLAGS = @CPPFLAGS@
+ LDFLAGS = @LDFLAGS@
+ GDFORM_EXT = @GDFORM_EXT@
+-LD_RUN_PATH = @LD_RUN_PATH@
++SET_LD_RUN_PATH = @SET_LD_RUN_PATH@
+ LIBS = @LIBS@
+
+ INSTALL = @INSTALL@
+@@ -30,7 +30,8 @@
+ all: bin/rateup subst
+
+ bin/rateup: bin/rateup.o
+- LD_RUN_PATH=$(LD_RUN_PATH) $(CC) bin/rateup.o -o bin/rateup $(LDFLAGS) $(LIBS)
++ $(SET_LD_RUN_PATH) $(CC) bin/rateup.o -o bin/rateup $(LDFLAGS) $(LIBS)
++
+
+ bin/rateup.o: $(top_srcdir)/src/rateup.c
+ $(CC) $(CPPFLAGS) $(CFLAGS) -c $(top_srcdir)/src/rateup.c -o bin/rateup.o
+
+--- configure.in 2010-11-09 17:11:20 +0000
++++ configure.in 2010-11-09 17:12:49 +0000
+@@ -141,6 +141,9 @@
+
+ LIBS="${GLIBS} ${LIBS}"
+
++if test x$LD_RUN_PATH != x; then
++ SET_LD_RUN_PATH="LD_RUN_PATH=${LD_RUN_PATH}"
++fi
+
+ dnl Make sure the header is here
+ AC_CHECK_HEADER( gd.h,:,[ GDFORM_EXT="" ])
+@@ -198,7 +201,7 @@
+ AC_SUBST(PERL)
+ AC_SUBST(RRD_PERL)
+ AC_SUBST(GDFORM_EXT)
+-AC_SUBST(LD_RUN_PATH)
++AC_SUBST(SET_LD_RUN_PATH)
+ AC_SUBST(LIBS)
+ AC_SUBST(CFLAGS)
+ AC_CONFIG_HEADERS(config.h)
+
diff --git a/net-analyzer/mrtg/mrtg-2.16.4-r1.ebuild b/net-analyzer/mrtg/mrtg-2.16.4-r1.ebuild
new file mode 100644
index 000000000000..5b0ffe042bb7
--- /dev/null
+++ b/net-analyzer/mrtg/mrtg-2.16.4-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mrtg/mrtg-2.16.4-r1.ebuild,v 1.1 2010/11/09 17:57:07 pva Exp $
+
+EAPI="3"
+
+inherit eutils autotools
+
+DESCRIPTION="A tool to monitor the traffic load on network-links"
+HOMEPAGE="http://oss.oetiker.ch/mrtg/"
+SRC_URI="http://oss.oetiker.ch/mrtg/pub/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl
+ dev-perl/SNMP_Session
+ >=dev-perl/Socket6-0.20
+ >=media-libs/gd-1.8.4"
+
+src_prepare() {
+ epatch ${FILESDIR}/${P}-disable-static.patch
+ epatch ${FILESDIR}/${P}-no-rpath.patch
+ rm ./lib/mrtg2/{SNMP_{Session,util},BER}.pm || die
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install () {
+ keepdir /var/lib/mrtg
+
+ emake DESTDIR="${ED}" install || die "emake install failed"
+ mv "${ED}/usr/share/doc/"{mrtg2,${PF}}
+
+ newinitd "${FILESDIR}/mrtg.rc" ${PN} || die
+ newconfd "${FILESDIR}/mrtg.confd" ${PN} || die
+}
+
+pkg_postinst(){
+ elog "You must configure mrtg before being able to run it. Try cfgmaker."
+ elog "The following thread may be useful:"
+ elog "http://forums.gentoo.org/viewtopic-t-105862.html"
+}