summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-12-24 14:51:48 +0000
committerJustin Lecher <jlec@gentoo.org>2013-12-24 14:51:48 +0000
commit6d77bce99d9b30c217be22712c61d8066f864513 (patch)
tree76e3d5ec0a916f46eb3e64d59674e0187fdc037d /net-analyzer/linkchecker
parentdev-python/argcomplete: Drop empty line (diff)
downloadgentoo-2-6d77bce99d9b30c217be22712c61d8066f864513.tar.gz
gentoo-2-6d77bce99d9b30c217be22712c61d8066f864513.tar.bz2
gentoo-2-6d77bce99d9b30c217be22712c61d8066f864513.zip
net-analyzer/linkchecker: Verion Bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'net-analyzer/linkchecker')
-rw-r--r--net-analyzer/linkchecker/ChangeLog7
-rw-r--r--net-analyzer/linkchecker/linkchecker-8.5.ebuild73
2 files changed, 79 insertions, 1 deletions
diff --git a/net-analyzer/linkchecker/ChangeLog b/net-analyzer/linkchecker/ChangeLog
index 02b628d42d47..3b3ad8e5c98f 100644
--- a/net-analyzer/linkchecker/ChangeLog
+++ b/net-analyzer/linkchecker/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/linkchecker
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/linkchecker/ChangeLog,v 1.91 2013/12/16 10:54:30 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/linkchecker/ChangeLog,v 1.92 2013/12/24 14:51:48 jlec Exp $
+
+*linkchecker-8.5 (24 Dec 2013)
+
+ 24 Dec 2013; Justin Lecher <jlec@gentoo.org> +linkchecker-8.5.ebuild:
+ Verion Bump
16 Dec 2013; Justin Lecher <jlec@gentoo.org> linkchecker-8.4-r1.ebuild,
linkchecker-9999.ebuild:
diff --git a/net-analyzer/linkchecker/linkchecker-8.5.ebuild b/net-analyzer/linkchecker/linkchecker-8.5.ebuild
new file mode 100644
index 000000000000..3644150029dd
--- /dev/null
+++ b/net-analyzer/linkchecker/linkchecker-8.5.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/linkchecker/linkchecker-8.5.ebuild,v 1.1 2013/12/24 14:51:48 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_REQ_USE="sqlite?"
+
+inherit bash-completion-r1 distutils-r1 eutils multilib
+
+MY_P="${P/linkchecker/LinkChecker}"
+
+DESCRIPTION="Check websites for broken links"
+HOMEPAGE="http://wummel.github.com/linkchecker/ http://pypi.python.org/pypi/linkchecker/"
+SRC_URI="http://wummel.github.io/${PN}/dist/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-solaris"
+IUSE="bash-completion clamav geoip gnome login nagios sqlite X"
+
+RDEPEND="
+ dev-python/dnspython[${PYTHON_USEDEP}]
+ bash-completion? ( dev-python/argcomplete[${PYTHON_USEDEP}] )
+ clamav? ( app-antivirus/clamav )
+ geoip? ( dev-python/geoip-python[${PYTHON_USEDEP}] )
+ gnome? ( dev-python/pygtk:2[${PYTHON_USEDEP}] )
+ login? ( dev-python/twill[${PYTHON_USEDEP}] )
+ X? (
+ dev-python/PyQt4[X,help,${PYTHON_USEDEP}]
+ dev-python/qscintilla-python[${PYTHON_USEDEP}]
+ )"
+DEPEND="
+ X? (
+ dev-qt/qthelp:4
+ dev-python/markdown2[${PYTHON_USEDEP}]
+ )"
+
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}"/${PN}-8.3-unbundle.patch
+ "${FILESDIR}"/${PN}-8.0-desktop.patch
+ )
+
+ emake -C doc/html
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if ! use X; then
+ delete_gui() {
+ rm -rf \
+ "${ED}"/usr/bin/linkchecker-gui* \
+ "${ED}"/$(python_get_sitedir)/linkcheck/gui* || die
+ }
+ python_foreach_impl delete_gui
+ fi
+ dohtml doc/html/*
+ use bash-completion && dobashcomp config/linkchecker-completion
+ if use nagios; then
+ insinto /usr/$(get_libdir)/nagios/plugins
+ doins linkchecker-nagios
+ else
+ rm -f "${ED}"/usr/bin/linkchecker-nagios* || die
+ fi
+}