summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-09-06 08:06:45 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-09-06 08:06:45 +0000
commitbb60a8593897b17ed3c838efc87580afcf3ca19d (patch)
treec51627648fecd55bffce8f00786dc53cd39f1f9d /net-analyzer/knocker
parentstable x86, bug 187093 (diff)
downloadgentoo-2-bb60a8593897b17ed3c838efc87580afcf3ca19d.tar.gz
gentoo-2-bb60a8593897b17ed3c838efc87580afcf3ca19d.tar.bz2
gentoo-2-bb60a8593897b17ed3c838efc87580afcf3ca19d.zip
Apply free patch for bug #185364 thanks to cmuelle8
(Portage version: 2.1.3.7)
Diffstat (limited to 'net-analyzer/knocker')
-rw-r--r--net-analyzer/knocker/ChangeLog8
-rw-r--r--net-analyzer/knocker/files/digest-knocker-0.7.1-r13
-rw-r--r--net-analyzer/knocker/files/knocker-0.7.1-free.patch31
-rw-r--r--net-analyzer/knocker/knocker-0.7.1-r1.ebuild37
4 files changed, 78 insertions, 1 deletions
diff --git a/net-analyzer/knocker/ChangeLog b/net-analyzer/knocker/ChangeLog
index 13eb6b44aaa6..67577defd993 100644
--- a/net-analyzer/knocker/ChangeLog
+++ b/net-analyzer/knocker/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/knocker
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/knocker/ChangeLog,v 1.11 2007/02/09 04:03:17 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/knocker/ChangeLog,v 1.12 2007/09/06 08:06:45 jokey Exp $
+
+*knocker-0.7.1-r1 (06 Sep 2007)
+
+ 06 Sep 2007; Markus Ullmann <jokey@gentoo.org>
+ +files/knocker-0.7.1-free.patch, +knocker-0.7.1-r1.ebuild:
+ Apply free patch for bug #185364 thanks to cmuelle8
09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/net-analyzer/knocker/files/digest-knocker-0.7.1-r1 b/net-analyzer/knocker/files/digest-knocker-0.7.1-r1
new file mode 100644
index 000000000000..5ab83c1b85da
--- /dev/null
+++ b/net-analyzer/knocker/files/digest-knocker-0.7.1-r1
@@ -0,0 +1,3 @@
+MD5 53d1a036071ceccb6500c0292feafacd knocker-0.7.1.tar.gz 72132
+RMD160 8791e4cf71e0bac86501b61d0f5782278780772a knocker-0.7.1.tar.gz 72132
+SHA256 db6f2a9e9705e3b678b9fd7fdd32ccdf13ab3f2dba2a6d053530a2faf67faf8d knocker-0.7.1.tar.gz 72132
diff --git a/net-analyzer/knocker/files/knocker-0.7.1-free.patch b/net-analyzer/knocker/files/knocker-0.7.1-free.patch
new file mode 100644
index 000000000000..3be3495cbdc8
--- /dev/null
+++ b/net-analyzer/knocker/files/knocker-0.7.1-free.patch
@@ -0,0 +1,31 @@
+diff -ur knocker-0.7.1/src/knocker_conf.c knocker-0.7.1.new/src/knocker_conf.c
+--- knocker-0.7.1/src/knocker_conf.c 2002-05-24 01:58:45.000000000 +0200
++++ knocker-0.7.1.new/src/knocker_conf.c 2007-07-15 02:14:17.000000000 +0200
+@@ -223,6 +223,8 @@
+ {
+ char *tmpp = malloc (strlen (line));
+ char *p = malloc (strlen (line));
++ char *tmpp_orig = tmpp;
++ char *p_orig = p;
+
+ /* Check if the option is present in the line */
+ tmpp = strstr (line, opt);
+@@ -234,7 +236,7 @@
+
+ if (!_isblank (*tmpp) || *tmpp != KNOCKER_OPTION_TOKEN)
+ {
+- free (tmpp);
++ free (tmpp_orig);
+ return 0;
+ }
+
+@@ -247,8 +249,7 @@
+
+ strcpy (value, p);
+
+- /* free(p); this cause knocker to segfault */
+- /* well I have to know why... */
++ free(p_orig);
+
+ return 1;
+ }
diff --git a/net-analyzer/knocker/knocker-0.7.1-r1.ebuild b/net-analyzer/knocker/knocker-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..548d1a323131
--- /dev/null
+++ b/net-analyzer/knocker/knocker-0.7.1-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/knocker/knocker-0.7.1-r1.ebuild,v 1.1 2007/09/06 08:06:45 jokey Exp $
+
+DESCRIPTION="Knocker is an easy to use security port scanner written in C"
+SRC_URI="mirror://sourceforge/knocker/${P}.tar.gz"
+HOMEPAGE="http://knocker.sourceforge.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.7.1-free.patch
+}
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+
+ emake || die "emake died"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die "emake install failed"
+
+ dodoc ChangeLog AUTHORS README BUGS TO-DO NEWS
+}