summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-06-02 11:55:37 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-06-02 11:55:37 +0000
commit51394d6f254cb07f6762591d6166a8552bd919e4 (patch)
tree48d8ee23517a2a2134614074cfa0cbcd966898cf /net-analyzer/jnettop
parentAdd patch to fix --as-needed by Kevin Pyle, close bug #247928. Remove -j1 fro... (diff)
downloadgentoo-2-51394d6f254cb07f6762591d6166a8552bd919e4.tar.gz
gentoo-2-51394d6f254cb07f6762591d6166a8552bd919e4.tar.bz2
gentoo-2-51394d6f254cb07f6762591d6166a8552bd919e4.zip
Add patch to fix build with --as-needed by Kevin Pyle, closes bug #247930. Also respect user cflags.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/jnettop')
-rw-r--r--net-analyzer/jnettop/ChangeLog9
-rw-r--r--net-analyzer/jnettop/files/jnettop-0.13.0-asneeded.patch13
-rw-r--r--net-analyzer/jnettop/jnettop-0.13.0-r1.ebuild14
3 files changed, 32 insertions, 4 deletions
diff --git a/net-analyzer/jnettop/ChangeLog b/net-analyzer/jnettop/ChangeLog
index d53536c4caa7..f8ff6599b9fd 100644
--- a/net-analyzer/jnettop/ChangeLog
+++ b/net-analyzer/jnettop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/jnettop
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/jnettop/ChangeLog,v 1.20 2007/08/20 10:31:11 jokey Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/jnettop/ChangeLog,v 1.21 2009/06/02 11:55:36 flameeyes Exp $
+
+ 02 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ jnettop-0.13.0-r1.ebuild, +files/jnettop-0.13.0-asneeded.patch:
+ Add patch to fix build with --as-needed by Kevin Pyle, closes bug #247930.
+ Also respect user cflags.
20 Aug 2007; Markus Ullmann <jokey@gentoo.org> jnettop-0.13.0-r1.ebuild:
Stable on x86
diff --git a/net-analyzer/jnettop/files/jnettop-0.13.0-asneeded.patch b/net-analyzer/jnettop/files/jnettop-0.13.0-asneeded.patch
new file mode 100644
index 000000000000..dc648f5fc1e0
--- /dev/null
+++ b/net-analyzer/jnettop/files/jnettop-0.13.0-asneeded.patch
@@ -0,0 +1,13 @@
+diff -ur a/Makefile.am b/Makefile.am
+--- a/Makefile.am 2006-04-14 11:32:14.000000000 -0500
++++ b/Makefile.am 2009-02-12 22:44:49.000000000 -0600
+@@ -1,8 +1,7 @@
+ # $Header: /var/cvsroot/gentoo-x86/net-analyzer/jnettop/files/jnettop-0.13.0-asneeded.patch,v 1.1 2009/06/02 11:55:37 flameeyes Exp $
+
+ INCLUDES = -I$(top_srcdir)/include @GLIB_CFLAGS@
+-AM_LDFLAGS = @GLIB_LIBS@ @NSL_LIBS@ @SOCKET_LIBS@
+-CFLAGS = -g -O0
++jnettop_LDADD = @GLIB_LIBS@ @NSL_LIBS@ @SOCKET_LIBS@
+
+ man_MANS = jnettop.8
+
diff --git a/net-analyzer/jnettop/jnettop-0.13.0-r1.ebuild b/net-analyzer/jnettop/jnettop-0.13.0-r1.ebuild
index b488b08fe97c..bf70253ae8b7 100644
--- a/net-analyzer/jnettop/jnettop-0.13.0-r1.ebuild
+++ b/net-analyzer/jnettop/jnettop-0.13.0-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/jnettop/jnettop-0.13.0-r1.ebuild,v 1.2 2007/08/20 10:31:11 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/jnettop/jnettop-0.13.0-r1.ebuild,v 1.3 2009/06/02 11:55:36 flameeyes Exp $
+
+inherit autotools eutils
DESCRIPTION="A top like console network traffic visualiser"
HOMEPAGE="http://jnettop.kubs.info/"
@@ -17,6 +19,14 @@ RDEPEND="net-libs/libpcap
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-asneeded.patch"
+ eautoreconf
+}
+
src_install() {
make DESTDIR="${D}" install || die
dodoc AUTHORS ChangeLog NEWS README .jnettop