summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-06-11 16:41:16 +0000
committerJeroen Roovers <jer@gentoo.org>2011-06-11 16:41:16 +0000
commitd951f06e992d836ba0798465e5d40ee3c4564ea8 (patch)
tree5a8cf6a56be182bbee49a4786c75207c48f87708 /net-analyzer/isic
parentMasked dev-haskell/gtk2hs for removal. (diff)
downloadgentoo-2-d951f06e992d836ba0798465e5d40ee3c4564ea8.tar.gz
gentoo-2-d951f06e992d836ba0798465e5d40ee3c4564ea8.tar.bz2
gentoo-2-d951f06e992d836ba0798465e5d40ee3c4564ea8.zip
Fix build failure (bug #351285). Install man page in the appropriate place (bug #247953). Move econf to src_configure(). Use emake instead of make. Remove unused inherit.
(Portage version: 2.2.0_alpha39/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/isic')
-rw-r--r--net-analyzer/isic/ChangeLog11
-rw-r--r--net-analyzer/isic/isic-0.07-r1.ebuild37
2 files changed, 46 insertions, 2 deletions
diff --git a/net-analyzer/isic/ChangeLog b/net-analyzer/isic/ChangeLog
index 1de2498c29d6..7c4efd866560 100644
--- a/net-analyzer/isic/ChangeLog
+++ b/net-analyzer/isic/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/isic
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/isic/ChangeLog,v 1.14 2007/09/06 17:25:44 jokey Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/isic/ChangeLog,v 1.15 2011/06/11 16:41:16 jer Exp $
+
+*isic-0.07-r1 (11 Jun 2011)
+
+ 11 Jun 2011; Jeroen Roovers <jer@gentoo.org> +isic-0.07-r1.ebuild:
+ Fix build failure (bug #351285). Install man page in the appropriate place
+ (bug #247953). Move econf to src_configure(). Use emake instead of make.
+ Remove unused inherit.
06 Sep 2007; Markus Ullmann <jokey@gentoo.org>
-files/isic-0.06-gcc4.patch, -files/isic-0.06-makefile.patch,
diff --git a/net-analyzer/isic/isic-0.07-r1.ebuild b/net-analyzer/isic/isic-0.07-r1.ebuild
new file mode 100644
index 000000000000..cd42058c51df
--- /dev/null
+++ b/net-analyzer/isic/isic-0.07-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/isic/isic-0.07-r1.ebuild,v 1.1 2011/06/11 16:41:16 jer Exp $
+
+EAPI="3"
+
+DESCRIPTION="IP Stack Integrity Checker"
+HOMEPAGE="http://isic.sourceforge.net/"
+SRC_URI="mirror://sourceforge/isic/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="net-libs/libnet:1.1"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Add two missing includes
+ echo "#include <netinet/udp.h>" >> isic.h || die
+ echo "#include <netinet/tcp.h>" >> isic.h || die
+
+ # Install man pages in /usr/share/man
+ sed -i Makefile.in -e 's|/man/man1|/share&|g' || die
+}
+
+src_configure() {
+ # Build system does not know about DESTDIR
+ econf --prefix="${D}/usr" --exec_prefix="${D}/usr"
+}
+
+src_install() {
+ # Build system does not know about DESTDIR
+ emake install || die "make install failed"
+ dodoc README
+}