summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2006-11-15 23:06:53 +0000
committerCédric Krier <cedk@gentoo.org>2006-11-15 23:06:53 +0000
commit744416d24e17478bc994a058eeb2d8e0291760f8 (patch)
tree5a4ecb7993939e1bf8b2f23da62eed3708e08245 /net-analyzer/iptraf
parentStable for HPPA (bug #154742). (diff)
downloadgentoo-2-744416d24e17478bc994a058eeb2d8e0291760f8.tar.gz
gentoo-2-744416d24e17478bc994a058eeb2d8e0291760f8.tar.bz2
gentoo-2-744416d24e17478bc994a058eeb2d8e0291760f8.zip
Add flag unicode and fix cross-compile
(Portage version: 2.1.1-r1)
Diffstat (limited to 'net-analyzer/iptraf')
-rw-r--r--net-analyzer/iptraf/ChangeLog5
-rw-r--r--net-analyzer/iptraf/iptraf-3.0.0-r3.ebuild17
2 files changed, 16 insertions, 6 deletions
diff --git a/net-analyzer/iptraf/ChangeLog b/net-analyzer/iptraf/ChangeLog
index b8228fc6b932..7d16f63550eb 100644
--- a/net-analyzer/iptraf/ChangeLog
+++ b/net-analyzer/iptraf/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-analyzer/iptraf
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/iptraf/ChangeLog,v 1.48 2006/11/14 20:25:34 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/iptraf/ChangeLog,v 1.49 2006/11/15 23:06:53 cedk Exp $
+
+ 15 Nov 2006; Cedric Krier <ced@ced.homedns.org> iptraf-3.0.0-r3.ebuild:
+ Add flag unicode and fix cross-compile
*iptraf-3.0.0-r3 (14 Nov 2006)
diff --git a/net-analyzer/iptraf/iptraf-3.0.0-r3.ebuild b/net-analyzer/iptraf/iptraf-3.0.0-r3.ebuild
index 52eb1445b8eb..4312fa5a184f 100644
--- a/net-analyzer/iptraf/iptraf-3.0.0-r3.ebuild
+++ b/net-analyzer/iptraf/iptraf-3.0.0-r3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/iptraf/iptraf-3.0.0-r3.ebuild,v 1.1 2006/11/14 20:25:34 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/iptraf/iptraf-3.0.0-r3.ebuild,v 1.2 2006/11/15 23:06:53 cedk Exp $
-inherit eutils flag-o-matic
+inherit eutils flag-o-matic toolchain-funcs
DESCRIPTION="IPTraf is an ncurses-based IP LAN monitor"
HOMEPAGE="http://iptraf.seul.org/"
@@ -12,10 +12,17 @@ SRC_URI="ftp://iptraf.seul.org/pub/iptraf/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
-IUSE="ipv6 suid"
+IUSE="ipv6 suid unicode"
DEPEND=">=sys-libs/ncurses-5.2-r1"
+pkg_setup() {
+ if use unicode && ! built_with_use sys-libs/ncurses unicode; then
+ eerror "sys-libs/ncurses must be build with unicode"
+ die "${PN} requires sys-libs/ncurses with USE=unicode"
+ fi
+}
+
src_unpack() {
unpack ${P}.tar.gz
cd ${S}
@@ -25,7 +32,7 @@ src_unpack() {
epatch ${FILESDIR}/${P}-bnep.patch
epatch ${FILESDIR}/${P}-Makefile.patch
# bug 152883
- epatch "${FILESDIR}/${P}-ncursesw.patch"
+ use unicode && epatch "${FILESDIR}/${P}-ncursesw.patch"
epatch "${FILESDIR}/${P}-setlocale.patch"
# bug 128965
@@ -53,7 +60,7 @@ src_compile() {
if use suid ; then
append-flags -DALLOWUSERS
fi
- emake CFLAGS="$CFLAGS" -C src || die "emake failed"
+ emake CFLAGS="$CFLAGS" CC="$(tc-getCC)" -C src || die "emake failed"
}
src_install() {