summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-10-12 10:43:32 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-10-12 10:43:32 +0000
commit111c3c3031d08a1dc3111d833387a9b1ca11d1f0 (patch)
tree3c428d33788fc82b561489b0187745d93575ea75 /net-analyzer/ippl
parentQA: assign RDEPEND explicitly (diff)
downloadgentoo-2-111c3c3031d08a1dc3111d833387a9b1ca11d1f0.tar.gz
gentoo-2-111c3c3031d08a1dc3111d833387a9b1ca11d1f0.tar.bz2
gentoo-2-111c3c3031d08a1dc3111d833387a9b1ca11d1f0.zip
Revision bump: bump to EAPI 4, fix bug #351287
(Portage version: 2.2.0_alpha136/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/ippl')
-rw-r--r--net-analyzer/ippl/ChangeLog7
-rw-r--r--net-analyzer/ippl/ippl-1.4.14-r3.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/net-analyzer/ippl/ChangeLog b/net-analyzer/ippl/ChangeLog
index 404c5f453ffa..5538354525f6 100644
--- a/net-analyzer/ippl/ChangeLog
+++ b/net-analyzer/ippl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/ippl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ippl/ChangeLog,v 1.19 2012/06/12 02:26:26 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ippl/ChangeLog,v 1.20 2012/10/12 10:43:32 pinkbyte Exp $
+
+*ippl-1.4.14-r3 (12 Oct 2012)
+
+ 12 Oct 2012; Sergey Popov <pinkbyte@gentoo.org> +ippl-1.4.14-r3.ebuild:
+ Revision bump: bump to EAPI 4, fix bug #351287
12 Jun 2012; Zac Medico <zmedico@gentoo.org> ippl-1.4.14-r1.ebuild,
ippl-1.4.14-r2.ebuild:
diff --git a/net-analyzer/ippl/ippl-1.4.14-r3.ebuild b/net-analyzer/ippl/ippl-1.4.14-r3.ebuild
new file mode 100644
index 000000000000..5aac65ce327a
--- /dev/null
+++ b/net-analyzer/ippl/ippl-1.4.14-r3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ippl/ippl-1.4.14-r3.ebuild,v 1.1 2012/10/12 10:43:32 pinkbyte Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs user
+
+DESCRIPTION="A daemon which logs TCP/UDP/ICMP packets"
+HOMEPAGE="http://pltplp.net/ippl/"
+SRC_URI="http://pltplp.net/ippl/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="|| ( sys-devel/bison >=dev-util/yacc-1.9.1-r1 )
+ >=sys-devel/flex-2.5.4a-r4"
+RDEPEND=""
+
+pkg_setup() {
+ enewuser ippl
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/ippl-1.4.14-noportresolve.patch \
+ "${FILESDIR}"/ippl-1.4.14-manpage.patch \
+ "${FILESDIR}"/ippl-1.4.14-privilege-drop.patch \
+ "${FILESDIR}"/ippl-1.4.14-includes.patch
+ sed -i Source/Makefile.in \
+ -e 's|^LDFLAGS=|&@LDFLAGS@|g' \
+ || die "sed Source/Makefile.in"
+ sed -i Makefile.in \
+ -e 's|make |$(MAKE) |g' \
+ || die "sed Makefile.in"
+ # fix for bug #351287
+ sed -i -e '/lex.yy.c/s/ippl.l/& y.tab.c/' Source/Makefile.in \
+ || die "sed src/Makefile.in"
+ tc-export CC
+}
+
+src_install() {
+ dosbin Source/ippl
+
+ insinto "/etc"
+ doins ippl.conf
+
+ doman Docs/{ippl.8,ippl.conf.5}
+
+ dodoc BUGS CREDITS HISTORY README TODO
+
+ newinitd "${FILESDIR}"/ippl.rc ippl
+}